From: Bruce Richardson <bruce.richardson@intel.com>
To: Pablo de Lara <pablo.de.lara.guarch@intel.com>
Cc: dev@dpdk.org
Subject: Re: [dpdk-dev] [PATCH v6 00/10] update jhash function
Date: Fri, 12 Jun 2015 11:37:36 +0100 [thread overview]
Message-ID: <20150612103736.GA10552@bricha3-MOBL3> (raw)
In-Reply-To: <1433949927-14767-1-git-send-email-pablo.de.lara.guarch@intel.com>
On Wed, Jun 10, 2015 at 04:25:17PM +0100, Pablo de Lara wrote:
> Jenkins hash function was developed originally in 1996,
> and was integrated in first versions of DPDK.
> The function has been improved in 2006,
> achieving up to 35% better performance, compared to the original one.
>
> This patchset updates the current jhash in DPDK,
> including two new functions that generate two hashes from a single key.
>
> It also separates the existing hash function performance tests to
> another file, to make it quicker to run, and add new unit tests.
>
> changes in v6:
> - Use RTE_DIM macro, so it saves lines of code
> - Correct mistaken performance improvement
> - Add deprecated attribute, instead of printing a message calling it
> - Add note stating the changes in release notes
>
> changes in v5:
> - Add functional tests (mainly to test that all functions
> return the expected hash values)
> - Modify range of key sizes to test
> - Change order of output for perf tests, so it is clearer
> to compare different hash functions for same key size/initial value
> - Add new initial value to test in the hash functions
> - Fix some errors caught by checkpatch
>
> changes in v4:
> - Simplify key alignment checks
> - Include missing x86 arch check
>
> changes in v3:
>
> - Update rte_jhash_1word, rte_jhash_2words and rte_jhash_3words
> functions
>
> changes in v2:
>
> - Split single commit in three commits, one that updates the existing functions
> and another that adds two new functions and use one of those functions
> as a base to be called by the other ones.
> - Remove some unnecessary ifdefs in the code.
> - Add new macros to help on the reutilization of constants
> - Separate hash function performance tests to another file
> and improve cycle measurements.
> - Rename existing function rte_jhash2 to rte_jhash_32b
> (something more meaninful) and mark rte_jhash2 as
> deprecated
>
Thanks for the all the work, and rework, Pablo.
Series Acked-by: Bruce Richardson <bruce.richardson@intel.com>
next prev parent reply other threads:[~2015-06-12 10:37 UTC|newest]
Thread overview: 62+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-04-16 13:26 [dpdk-dev] [PATCH] hash: update jhash function with the latest available Pablo de Lara
2015-04-16 14:01 ` Bruce Richardson
2015-04-17 16:03 ` De Lara Guarch, Pablo
2015-04-24 11:23 ` [dpdk-dev] [PATCH v2 0/6] update jhash function Pablo de Lara
2015-04-24 11:23 ` [dpdk-dev] [PATCH v2 1/6] test/hash: move hash function perf tests to separate file Pablo de Lara
2015-04-24 11:23 ` [dpdk-dev] [PATCH v2 2/6] test/hash: improve accuracy on cycle measurements Pablo de Lara
2015-04-24 11:23 ` [dpdk-dev] [PATCH v2 3/6] hash: update jhash function with the latest available Pablo de Lara
2015-04-24 11:23 ` [dpdk-dev] [PATCH v2 4/6] hash: add two new functions to jhash library Pablo de Lara
2015-04-24 11:23 ` [dpdk-dev] [PATCH v2 5/6] hash: remove duplicated code Pablo de Lara
2015-04-24 11:23 ` [dpdk-dev] [PATCH v2 6/6] hash: rename rte_jhash2 to rte_jhash_32b Pablo de Lara
2015-05-05 14:43 ` [dpdk-dev] [PATCH v3 0/6] update jhash function Pablo de Lara
2015-05-05 14:43 ` [dpdk-dev] [PATCH v3 1/6] test/hash: move hash function perf tests to separate file Pablo de Lara
2015-05-05 14:43 ` [dpdk-dev] [PATCH v3 2/6] test/hash: improve accuracy on cycle measurements Pablo de Lara
2015-05-05 14:43 ` [dpdk-dev] [PATCH v3 3/6] hash: update jhash function with the latest available Pablo de Lara
2015-05-06 0:35 ` Ananyev, Konstantin
2015-05-06 9:36 ` De Lara Guarch, Pablo
2015-05-06 16:11 ` Ananyev, Konstantin
2015-05-07 11:11 ` Ananyev, Konstantin
2015-05-05 14:43 ` [dpdk-dev] [PATCH v3 4/6] hash: add two new functions to jhash library Pablo de Lara
2015-05-05 14:43 ` [dpdk-dev] [PATCH v3 5/6] hash: remove duplicated code Pablo de Lara
2015-05-05 14:43 ` [dpdk-dev] [PATCH v3 6/6] hash: rename rte_jhash2 to rte_jhash_32b Pablo de Lara
2015-05-12 11:02 ` [dpdk-dev] [PATCH v4 0/6] update jhash function Pablo de Lara
2015-05-12 11:02 ` [dpdk-dev] [PATCH v4 1/6] test/hash: move hash function perf tests to separate file Pablo de Lara
2015-05-12 11:02 ` [dpdk-dev] [PATCH v4 2/6] test/hash: improve accuracy on cycle measurements Pablo de Lara
2015-05-12 11:02 ` [dpdk-dev] [PATCH v4 3/6] hash: update jhash function with the latest available Pablo de Lara
2015-05-12 11:02 ` [dpdk-dev] [PATCH v4 4/6] hash: add two new functions to jhash library Pablo de Lara
2015-05-12 11:02 ` [dpdk-dev] [PATCH v4 5/6] hash: remove duplicated code Pablo de Lara
2015-05-12 11:02 ` [dpdk-dev] [PATCH v4 6/6] hash: rename rte_jhash2 to rte_jhash_32b Pablo de Lara
2015-05-12 15:33 ` [dpdk-dev] [PATCH v4 0/6] update jhash function Neil Horman
2015-05-13 13:52 ` De Lara Guarch, Pablo
2015-05-13 14:20 ` Neil Horman
2015-05-18 16:14 ` Bruce Richardson
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 00/10] " Pablo de Lara
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 01/10] test/hash: move hash function perf tests to separate file Pablo de Lara
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 02/10] test/hash: improve accuracy on cycle measurements Pablo de Lara
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 03/10] test/hash: update key size range and initial values for testing Pablo de Lara
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 04/10] test/hash: change order of loops in hash function tests Pablo de Lara
2015-06-10 11:05 ` Bruce Richardson
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 05/10] test/hash: add new functional tests for hash functions Pablo de Lara
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 06/10] hash: update jhash function with the latest available Pablo de Lara
2015-06-10 11:07 ` Bruce Richardson
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 07/10] hash: add two new functions to jhash library Pablo de Lara
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 08/10] hash: remove duplicated code Pablo de Lara
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 09/10] hash: rename rte_jhash2 to rte_jhash_32b Pablo de Lara
2015-06-10 11:09 ` Bruce Richardson
2015-05-22 10:16 ` [dpdk-dev] [PATCH v5 10/10] test/hash: verify rte_jhash_1word/2words/3words Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 00/10] update jhash function Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 01/10] test/hash: move hash function perf tests to separate file Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 02/10] test/hash: improve accuracy on cycle measurements Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 03/10] test/hash: update key size range and initial values for testing Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 04/10] test/hash: change order of loops in hash function tests Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 05/10] test/hash: add new functional tests for hash functions Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 06/10] hash: update jhash function with the latest available Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 07/10] hash: add two new functions to jhash library Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 08/10] hash: remove duplicated code Pablo de Lara
2015-06-16 9:33 ` Thomas Monjalon
2015-06-16 10:31 ` De Lara Guarch, Pablo
2015-06-16 13:08 ` Thomas Monjalon
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 09/10] hash: rename rte_jhash2 to rte_jhash_32b Pablo de Lara
2015-06-10 15:25 ` [dpdk-dev] [PATCH v6 10/10] test/hash: verify rte_jhash_1word/2words/3words Pablo de Lara
2015-06-12 10:37 ` Bruce Richardson [this message]
2015-06-16 10:22 ` [dpdk-dev] [PATCH v6 00/10] update jhash function Thomas Monjalon
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150612103736.GA10552@bricha3-MOBL3 \
--to=bruce.richardson@intel.com \
--cc=dev@dpdk.org \
--cc=pablo.de.lara.guarch@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).