From: Bruce Richardson <bruce.richardson@intel.com>
To: Andrey Chilikin <andrey.chilikin@intel.com>
Cc: dev@dpdk.org
Subject: Re: [dpdk-dev] [PATCH 1/3] librte_ether: add RTE_ETH_FDIR_OTHER for flow director behavior
Date: Tue, 29 Sep 2015 15:38:23 +0100 [thread overview]
Message-ID: <20150929143823.GE6748@bricha3-MOBL3> (raw)
In-Reply-To: <1443536800-13269-2-git-send-email-andrey.chilikin@intel.com>
On Tue, Sep 29, 2015 at 03:26:38PM +0100, Andrey Chilikin wrote:
> Add new flow director behavior RTE_ETH_FDIR_OTHER to assign a queue by other filters
>
> Signed-off-by: Andrey Chilikin <andrey.chilikin@intel.com>
> ---
> lib/librte_ether/rte_eth_ctrl.h | 1 +
> 1 files changed, 1 insertions(+), 0 deletions(-)
>
> diff --git a/lib/librte_ether/rte_eth_ctrl.h b/lib/librte_ether/rte_eth_ctrl.h
> index 26b7b33..3acf501 100644
> --- a/lib/librte_ether/rte_eth_ctrl.h
> +++ b/lib/librte_ether/rte_eth_ctrl.h
> @@ -417,6 +417,7 @@ struct rte_eth_fdir_input {
> enum rte_eth_fdir_behavior {
> RTE_ETH_FDIR_ACCEPT = 0,
> RTE_ETH_FDIR_REJECT,
> + RTE_ETH_FDIR_OTHER,
> };
>
> /**
> --
> 1.7.4.1
>
Is "OTHER" meant to be a "NOOP" or a generic hold-all for a set of other possible
behaviours. From the description, I would assume NOOP - in which case would
RTE_ETH_FDIR_NOOP not be a better name?
/Bruce
next prev parent reply other threads:[~2015-09-29 14:38 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-09-29 14:26 [dpdk-dev] [PATCH 0/3] Support for flow director behavior "other" on Intel FVL NIC Andrey Chilikin
2015-09-29 14:26 ` [dpdk-dev] [PATCH 1/3] librte_ether: add RTE_ETH_FDIR_OTHER for flow director behavior Andrey Chilikin
2015-09-29 14:38 ` Bruce Richardson [this message]
2015-09-29 14:48 ` Chilikin, Andrey
2015-09-29 14:53 ` Bruce Richardson
2015-09-29 14:26 ` [dpdk-dev] [PATCH 2/3] i40e: add RTE_ETH_FDIR_OTHER processing " Andrey Chilikin
2015-09-29 14:26 ` [dpdk-dev] [PATCH 3/3] ixgbe: add check for supported flow director behaviors Andrey Chilikin
2015-09-30 13:43 ` [dpdk-dev] [PATCH v2 0/3] Support for flow director behavior "passthru" on Intel FVL NIC Andrey Chilikin
2015-09-30 13:43 ` [dpdk-dev] [PATCH v2 1/3] librte_ether: add RTE_ETH_FDIR_PASSTHRU for flow director behavior Andrey Chilikin
2015-09-30 13:43 ` [dpdk-dev] [PATCH v2 2/3] i40e: add RTE_ETH_FDIR_PASSTHRU processing " Andrey Chilikin
2015-09-30 13:43 ` [dpdk-dev] [PATCH v2 3/3] ixgbe: add check for supported flow director behaviors Andrey Chilikin
2015-10-19 1:51 ` [dpdk-dev] [PATCH v2 0/3] Support for flow director behavior "passthru" on Intel FVL NIC Wu, Jingjing
2015-11-04 21:54 ` Thomas Monjalon
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150929143823.GE6748@bricha3-MOBL3 \
--to=bruce.richardson@intel.com \
--cc=andrey.chilikin@intel.com \
--cc=dev@dpdk.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).