From: Jerin Jacob <jerin.jacob@caviumnetworks.com>
To: Thomas Monjalon <thomas@monjalon.net>
Cc: Ferruh Yigit <ferruh.yigit@intel.com>,
"Ananyev, Konstantin" <konstantin.ananyev@intel.com>,
Andrew Rybchenko <arybchenko@solarflare.com>,
"Lu, Wenzhuo" <wenzhuo.lu@intel.com>,
"Wu, Jingjing" <jingjing.wu@intel.com>,
"Iremonger, Bernard" <bernard.iremonger@intel.com>,
"Mcnamara, John" <john.mcnamara@intel.com>,
"Kovacevic, Marko" <marko.kovacevic@intel.com>,
Olivier Matz <olivier.matz@6wind.com>,
"dev@dpdk.org" <dev@dpdk.org>,
"shahafs@mellanox.com" <shahafs@mellanox.com>,
"didier.pallard@6wind.com" <didier.pallard@6wind.com>
Subject: Re: [dpdk-dev] [PATCH v2 1/4] ethdev: add Rx offload outer UDP checksum definition
Date: Mon, 8 Oct 2018 18:38:55 +0530 [thread overview]
Message-ID: <20181008130854.GA11965@jerin> (raw)
In-Reply-To: <2286504.krVn7HG0xW@xps>
-----Original Message-----
> Date: Mon, 08 Oct 2018 15:03:49 +0200
> From: Thomas Monjalon <thomas@monjalon.net>
> To: Jerin Jacob <jerin.jacob@caviumnetworks.com>
> Cc: Ferruh Yigit <ferruh.yigit@intel.com>, "Ananyev, Konstantin"
> <konstantin.ananyev@intel.com>, Andrew Rybchenko
> <arybchenko@solarflare.com>, "Lu, Wenzhuo" <wenzhuo.lu@intel.com>, "Wu,
> Jingjing" <jingjing.wu@intel.com>, "Iremonger, Bernard"
> <bernard.iremonger@intel.com>, "Mcnamara, John" <john.mcnamara@intel.com>,
> "Kovacevic, Marko" <marko.kovacevic@intel.com>, Olivier Matz
> <olivier.matz@6wind.com>, "dev@dpdk.org" <dev@dpdk.org>,
> "shahafs@mellanox.com" <shahafs@mellanox.com>, "didier.pallard@6wind.com"
> <didier.pallard@6wind.com>
> Subject: Re: [dpdk-dev] [PATCH v2 1/4] ethdev: add Rx offload outer UDP
> checksum definition
>
> 08/10/2018 14:25, Jerin Jacob:
> > From: Ferruh Yigit <ferruh.yigit@intel.com>
> > > On 10/8/2018 12:55 PM, Jerin Jacob wrote:
> > > > From: Ferruh Yigit <ferruh.yigit@intel.com>
> > > >> On 10/8/2018 10:37 AM, Jerin Jacob wrote:
> > > >>> From: Thomas Monjalon <thomas@monjalon.net>
> > > >>>> 08/10/2018 10:24, Jerin Jacob:
> > > >>>>> From: Ferruh Yigit <ferruh.yigit@intel.com>
> > > >>>>>> On 10/6/2018 1:18 PM, Ananyev, Konstantin wrote:
> > > >>>>>>> From: Jerin Jacob [mailto:jerin.jacob@caviumnetworks.com]
> > > >>>>>>>> From: Thomas Monjalon <thomas@monjalon.net>
> > > >>>>>>>>> However, we should re-visit the flag PKT_RX_EIP_CKSUM_BAD.
> > > >>>>>>>>
> > > >>>>>>>> Do we need to block this patch due to the exiting PKT_RX_EIP_CKSUM_BAD
> > > >>>>>>>> definition?
> > > >>>>>>>>
> > > >>>>>>>> I already added the author of the PKT_RX_EIP_CKSUM_BAD flag and ethdev and mbuf
> > > >>>>>>>> maintainers in this list. So what else I need make forward progress
> > > >>>>>>>> on this patch?
> > > >>>>>>>>
> > > >>>>>>>> I think, the definition of PKT_RX_EIP_CKSUM_BAD based on HW capability. It
> > > >>>>>>>> is safe to assume that ALL HW can support CKSUM BAD if the feature is
> > > >>>>>>>> available and hence it is more portable.
> > > >>>>>>>
> > > >>>>>>> Yes, as I remember PKT_RX_EIP_CKSUM_BAD is based on DEV_RX_OFFLOAD_OUTER_IPV4_CKSUM.
> > > >>>>>>
> > > >>>>>> Switching to two bit won't reduce the portability, HW supports only reporting
> > > >>>>>> CKSUM_BAD can set BAD || UNKNOWN.
> > > >>>>>
> > > >>>>> UNKNOWN is not a bit. It is represented as 0. It spec has 2 bit, then
> > > >>>>> driver need to report GOOD as well.
> > > >>>>>
> > > >>>>> Same applies for PKT_RX_EL4_CKSUM as well.
> > > >>>>>
> > > >>>>>>
> > > >>>>>> And I think patch is not blocked by PKT_RX_EIP_CKSUM_BAD, it can be changed
> > > >>>>>> separately, for this patch question is can we represent PKT_RX_EL4_CKSUM_* with
> > > >>>>>> two bits, to have BAD/GOOD/UNKNOWN?
> > > >>>>
> > > >>>> Yes, exact.
> > > >>>>
> > > >>>> PKT_RX_EIP_CKSUM_BAD must be left aside.
> > > >>>> We should just avoid taking it as a reference.
> > > >>>> And we can reconsider its definition later.
> > > >>>
> > > >>> OK.
> > > >>>
> > > >>> IMO, Using 2 bit scheme for tunneled checksum has following performance
> > > >>> issue from driver side.
> > > >>>
> > > >>> Driver need to mark the packet as GOOD. All the HW can support
> > > >>> detection of BAD. That not necessary mean GOOD in case of tunnel packet,
> > > >>> so driver has to detect the packet is tunneled and packet is not BAD
> > > >>> then mark GOOD.
> > > >>
> > > >> Yes UNKNOWN is not a bit, but a state, why don't use it? Why driver has to check
> > > >> it is GOOD?
> > > >
> > > > The application is going to check is it GOOD or not. Not the driver,
> > > > Right? My concern was, If application starts dropping the packet instead checking the BAD, if
> > > > it checks == !GOOD.
> > >
> > > Got it, but when 2 bits state introduced, app should check if check == BAD for
> > > drop decision, because it is not GOOD || BAD anymore.
> >
> > Got it.
> >
> > >
> > > >
> > > >>
> > > >> 0x0 => UNKNOWN
> > > >> 0x1 => BAD
> > > >> 0x2 => GOOD
> > > >> 0x3 => ? (invalid perhaps)
> > > >>
> > > >> HW that supports detecting good packets can set BAD || GOOD state, HW can detect
> > > >> only BAD packet can set BAD || UNKNOWN state.
> > > >>
> > > >> If BAD is not set, there is an ambiguity of state, lets clarify it in lower
> > > >> level, if it is UNKNOWN, let application know it is UNKNOWN.
> > > >
> > > > OK.
> > > >
> > > > How about the following then?
> > > >
> > > > /**
> > > > * Mask of bits used to determine the status of outer RX L4 checksum.
> > > > * - PKT_RX_EL4_CKSUM_UNKNOWN: no information about the outer RX L4 checksum
> > > > * - PKT_RX_EL4_CKSUM_BAD: the outer L4 checksum in the packet is wrong
> > > > * - PKT_RX_EL4_CKSUM_GOOD: the outer L4 checksum in the packet is valid
> > > > * - PKT_RX_EL4_CKSUM_INVALID: invalid outer L4 checksum state.
> > > > *
> > > > * The detection of PKT_RX_EL4_CKSUM_GOOD shall be based on the given
> > > > * HW capability, At minimum, the PMD should support
> > > > * PKT_RX_EL4_CKSUM_UNKNOWN and PKT_RX_EL4_CKSUM_BAD states
> > > > * if the offload is available.
> > > > */
> > > > #define PKT_RX_EL4_CKSUM_MASK ((1ULL << 21) | (1ULL << 22))
> > > >
> > > > #define PKT_RX_IP_CKSUM_UNKNOWN 0
> > > > #define PKT_RX_IP_CKSUM_BAD (1ULL << 21)
> > > > #define PKT_RX_IP_CKSUM_GOOD (1ULL << 22)
> > > > #define PKT_RX_IP_CKSUM_INVALID ((1ULL << 21) | (1ULL << 22))
> > >
> > > Looks good to me.
> >
> > If there is no objection with above flag definition, I will send the v3 with that.
>
> Just one objection about the name.
> Why naming it EL4 and commenting as outer L4?
> I think we should choose between "external" and "outer".
> Convention seems to be choosing "outer" word.
> So I suggest PKT_RX_OUTER_L4_CKSUM_*.
OK. I will change to PKT_RX_OUTER_L4_CKSUM_*
>
>
>
next prev parent reply other threads:[~2018-10-08 13:09 UTC|newest]
Thread overview: 87+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-09-13 13:47 [dpdk-dev] [PATCH 1/4] ethdev: add SCTP Rx checksum offload support Jerin Jacob
2018-09-13 13:47 ` [dpdk-dev] [PATCH 2/4] mbuf: fix Tx offload mask Jerin Jacob
2018-10-01 13:45 ` Ferruh Yigit
2018-10-01 15:53 ` Jerin Jacob
2018-10-01 16:13 ` Ferruh Yigit
2018-09-13 13:47 ` [dpdk-dev] [PATCH 3/4] ethdev: add Rx offload outer L4 checksum definitions Jerin Jacob
2018-09-13 17:24 ` Shahaf Shuler
2018-09-14 3:05 ` Jerin Jacob
2018-09-16 5:53 ` Shahaf Shuler
2018-09-16 9:32 ` Jerin Jacob
2018-09-13 13:47 ` [dpdk-dev] [PATCH 4/4] ethdev: add Tx " Jerin Jacob
2018-10-01 13:45 ` Ferruh Yigit
2018-10-02 9:52 ` Jerin Jacob
2018-10-01 13:45 ` [dpdk-dev] [PATCH 1/4] ethdev: add SCTP Rx checksum offload support Ferruh Yigit
2018-10-01 13:46 ` Ferruh Yigit
2018-10-01 15:59 ` Jerin Jacob
2018-10-01 16:11 ` Ferruh Yigit
2018-10-02 8:53 ` Jerin Jacob
2018-10-02 9:13 ` Ferruh Yigit
2018-10-02 10:51 ` [dpdk-dev] [PATCH v2 1/2] " Jerin Jacob
2018-10-02 10:51 ` [dpdk-dev] [PATCH v2 2/2] mbuf: fix Tx offload mask Jerin Jacob
2018-10-04 2:31 ` Hu, Jiayu
2018-10-04 16:05 ` Ferruh Yigit
2018-10-03 18:52 ` [dpdk-dev] [PATCH v2 1/2] ethdev: add SCTP Rx checksum offload support Ferruh Yigit
2018-10-02 19:24 ` [dpdk-dev] [PATCH v2 1/4] ethdev: add Rx offload outer UDP checksum definition Jerin Jacob
2018-10-02 19:24 ` [dpdk-dev] [PATCH v2 2/4] ethdev: add Tx " Jerin Jacob
2018-10-03 7:41 ` Andrew Rybchenko
2018-10-03 7:58 ` Jerin Jacob
2018-10-03 8:02 ` Ferruh Yigit
2018-10-03 8:36 ` Thomas Monjalon
2018-10-03 10:52 ` Iremonger, Bernard
2018-10-02 19:24 ` [dpdk-dev] [PATCH v2 3/4] app/testpmd: add outer UDP HW checksum support Jerin Jacob
2018-10-03 13:23 ` Iremonger, Bernard
2018-10-02 19:24 ` [dpdk-dev] [PATCH v2 4/4] app/testpmd: collect bad outer L4 checksum for csum engine Jerin Jacob
2018-10-03 8:29 ` Andrew Rybchenko
2018-10-03 7:34 ` [dpdk-dev] [PATCH v2 1/4] ethdev: add Rx offload outer UDP checksum definition Andrew Rybchenko
2018-10-03 7:57 ` Jerin Jacob
2018-10-03 8:35 ` Thomas Monjalon
2018-10-03 8:36 ` Andrew Rybchenko
2018-10-03 17:12 ` Jerin Jacob
2018-10-03 18:00 ` Andrew Rybchenko
2018-10-03 18:14 ` Jerin Jacob
2018-10-03 19:47 ` Andrew Rybchenko
2018-10-03 20:08 ` Thomas Monjalon
2018-10-04 5:59 ` Jerin Jacob
2018-10-05 19:48 ` Ferruh Yigit
2018-10-05 20:04 ` Ferruh Yigit
2018-10-05 22:44 ` Thomas Monjalon
2018-10-06 8:15 ` Jerin Jacob
2018-10-06 12:18 ` Ananyev, Konstantin
2018-10-08 8:12 ` Ferruh Yigit
2018-10-08 8:24 ` Jerin Jacob
2018-10-08 9:04 ` Thomas Monjalon
2018-10-08 9:37 ` Jerin Jacob
2018-10-08 10:53 ` Ferruh Yigit
2018-10-08 11:55 ` Jerin Jacob
2018-10-08 12:13 ` Ferruh Yigit
2018-10-08 12:25 ` Jerin Jacob
2018-10-08 13:03 ` Thomas Monjalon
2018-10-08 13:08 ` Jerin Jacob [this message]
2018-10-03 8:53 ` Ananyev, Konstantin
2018-10-03 8:59 ` Jerin Jacob
2018-10-03 9:17 ` Ananyev, Konstantin
2018-10-03 9:22 ` Jerin Jacob
2018-10-03 10:16 ` Ananyev, Konstantin
2018-10-03 11:15 ` Jerin Jacob
2018-10-03 10:51 ` Iremonger, Bernard
2018-10-03 11:19 ` Jerin Jacob
2018-10-03 13:00 ` Iremonger, Bernard
2018-10-03 18:16 ` [dpdk-dev] [PATCH v3 " Jerin Jacob
2018-10-03 18:16 ` [dpdk-dev] [PATCH v3 2/4] ethdev: add Tx " Jerin Jacob
2018-10-03 18:16 ` [dpdk-dev] [PATCH v3 3/4] app/testpmd: add outer UDP HW checksum support Jerin Jacob
2018-10-03 18:16 ` [dpdk-dev] [PATCH v3 4/4] app/testpmd: collect bad outer L4 checksum for csum engine Jerin Jacob
2018-10-04 13:45 ` Iremonger, Bernard
2018-10-04 14:16 ` Jerin Jacob
2018-10-04 15:06 ` Iremonger, Bernard
2018-10-08 16:09 ` [dpdk-dev] [PATCH v4 1/4] ethdev: add Rx offload outer UDP checksum definition Jerin Jacob
2018-10-08 16:09 ` [dpdk-dev] [PATCH v4 2/4] ethdev: add Tx " Jerin Jacob
2018-10-09 10:06 ` Andrew Rybchenko
2018-10-08 16:09 ` [dpdk-dev] [PATCH v4 3/4] app/testpmd: add outer UDP HW checksum support Jerin Jacob
2018-10-08 16:09 ` [dpdk-dev] [PATCH v4 4/4] app/testpmd: collect bad outer L4 checksum for csum engine Jerin Jacob
2018-10-09 10:06 ` [dpdk-dev] [PATCH v4 1/4] ethdev: add Rx offload outer UDP checksum definition Andrew Rybchenko
2018-10-09 14:18 ` [dpdk-dev] [PATCH v5 " Jerin Jacob
2018-10-09 14:18 ` [dpdk-dev] [PATCH v5 2/4] ethdev: add Tx " Jerin Jacob
2018-10-09 14:18 ` [dpdk-dev] [PATCH v5 3/4] app/testpmd: add outer UDP HW checksum support Jerin Jacob
2018-10-09 14:18 ` [dpdk-dev] [PATCH v5 4/4] app/testpmd: collect bad outer L4 checksum for csum engine Jerin Jacob
2018-10-09 16:46 ` [dpdk-dev] [PATCH v5 1/4] ethdev: add Rx offload outer UDP checksum definition Ferruh Yigit
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181008130854.GA11965@jerin \
--to=jerin.jacob@caviumnetworks.com \
--cc=arybchenko@solarflare.com \
--cc=bernard.iremonger@intel.com \
--cc=dev@dpdk.org \
--cc=didier.pallard@6wind.com \
--cc=ferruh.yigit@intel.com \
--cc=jingjing.wu@intel.com \
--cc=john.mcnamara@intel.com \
--cc=konstantin.ananyev@intel.com \
--cc=marko.kovacevic@intel.com \
--cc=olivier.matz@6wind.com \
--cc=shahafs@mellanox.com \
--cc=thomas@monjalon.net \
--cc=wenzhuo.lu@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).