From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from dpdk.org (dpdk.org [92.243.14.124]) by inbox.dpdk.org (Postfix) with ESMTP id E315DA0471 for ; Mon, 9 Sep 2019 14:40:46 +0200 (CEST) Received: from [92.243.14.124] (localhost [127.0.0.1]) by dpdk.org (Postfix) with ESMTP id 8C8541EAB2; Mon, 9 Sep 2019 14:40:45 +0200 (CEST) Received: from mga17.intel.com (mga17.intel.com [192.55.52.151]) by dpdk.org (Postfix) with ESMTP id DF2EC1EAB1 for ; Mon, 9 Sep 2019 14:40:43 +0200 (CEST) X-Amp-Result: UNKNOWN X-Amp-Original-Verdict: FILE UNKNOWN X-Amp-File-Uploaded: False Received: from fmsmga001.fm.intel.com ([10.253.24.23]) by fmsmga107.fm.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 09 Sep 2019 05:40:42 -0700 X-IronPort-AV: E=Sophos;i="5.64,484,1559545200"; d="scan'208";a="200056721" Received: from bricha3-mobl.ger.corp.intel.com ([10.237.221.46]) by fmsmga001-auth.fm.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 09 Sep 2019 05:40:41 -0700 Date: Mon, 9 Sep 2019 13:40:38 +0100 From: Bruce Richardson To: Ferruh Yigit Cc: "Wang, Haiyue" , Ray Kinsella , "dev@dpdk.org" , "Sun, Chenmin" Message-ID: <20190909124038.GA1889@bricha3-MOBL.ger.corp.intel.com> References: <1565665572-65495-1-git-send-email-haiyue.wang@intel.com> <1565665572-65495-2-git-send-email-haiyue.wang@intel.com> <20190812202436.662e6ca8@hermes.lan> <75f88e4b-97ca-7e1f-1385-8e69f659be7f@intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <75f88e4b-97ca-7e1f-1385-8e69f659be7f@intel.com> User-Agent: Mutt/1.11.4 (2019-03-13) Subject: Re: [dpdk-dev] [RFC v2 1/3] ethdev: add the API for getting trace information X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On Mon, Sep 09, 2019 at 12:23:36PM +0100, Ferruh Yigit wrote: > On 9/7/2019 3:42 AM, Wang, Haiyue wrote: > >> -----Original Message----- > >> From: Yigit, Ferruh > >> Sent: Friday, September 6, 2019 22:22 > >> To: Ray Kinsella ; Wang, Haiyue > >> Cc: dev@dpdk.org > >> Subject: Re: [dpdk-dev] [RFC v2 1/3] ethdev: add the API for getting trace information > >> > >> On 8/13/2019 1:51 PM, Ray Kinsella wrote: > >>> > >>> > >>> On 13/08/2019 04:24, Stephen Hemminger wrote: > >>>> On Tue, 13 Aug 2019 11:06:10 +0800 > >>>> Haiyue Wang wrote: > >>>> > >>>>> Enhance the PMD to support retrieving trace information like > >>>>> Rx/Tx burst selection etc. > >>>>> > >>>>> Signed-off-by: Haiyue Wang > >>>>> --- > >>>>> lib/librte_ethdev/rte_ethdev.c | 18 ++++++++++++++++++ > >>>>> lib/librte_ethdev/rte_ethdev.h | 9 +++++++++ > >>>>> lib/librte_ethdev/rte_ethdev_core.h | 4 ++++ > >>>>> 3 files changed, 31 insertions(+) > >>>>> > >>>>> diff --git a/lib/librte_ethdev/rte_ethdev.c b/lib/librte_ethdev/rte_ethdev.c > >>>>> index 17d183e..6098fad 100644 > >>>>> --- a/lib/librte_ethdev/rte_ethdev.c > >>>>> +++ b/lib/librte_ethdev/rte_ethdev.c > >>>>> @@ -4083,6 +4083,24 @@ rte_eth_tx_queue_info_get(uint16_t port_id, uint16_t queue_id, > >>>>> } > >>>>> > >>>>> int > >>>>> +rte_eth_trace_info_get(uint16_t port_id, uint16_t queue_id, > >>>>> + enum rte_eth_trace type, char *buf, int sz) > >> > >> Better to use struct as argument instead of individual variables because it is > >> easier to extend the struct later if needed. > >> > >>>>> +{ > >>>>> + struct rte_eth_dev *dev; > >>>>> + > >>>>> + RTE_ETH_VALID_PORTID_OR_ERR_RET(port_id, -ENODEV); > >>>>> + > >>>>> + if (buf == NULL) > >>>>> + return -EINVAL; > >>>>> + > >>>>> + dev = &rte_eth_devices[port_id]; > >>>>> + > >>>>> + RTE_FUNC_PTR_OR_ERR_RET(*dev->dev_ops->trace_info_get, -ENOTSUP); > >>>>> + > >>>>> + return dev->dev_ops->trace_info_get(dev, queue_id, type, buf, sz); > >>>> > >>>> What if queueid is out of bounds? > >>>> > >>>> The bigger problem is that this information is like a log message > >>>> and unstructured, which makes it device specific and useless for automation. > >>> > >>> IMHO - this is much better implemented as a capability bitfield, that > >>> can be queried. > >> > >> +1 to return the datapath capability as bitfield. > >> > >> Also +1 to have a new API, > >> - I am not sure about the API name, 'rte_eth_trace_info_get()', can we find > >> something better instead of 'trace' there. > >> - I think we should limit this API only to get current datapath configuration, > >> for clarity of the API don't return capability or not datapath related config. > >> > >> Also this information not always supported in queue level, what do you think > >> having ability to get this information in port level, > >> like this API can return a struct, which may have a field that says if the > >> output is for queue or port, or this can be another bitfield, what do you think? > >> > > > > #define RX_SCALAR (1ULL < 0) > > #define RX_VECTOR_AVX2 ... > > What about having RX_VECTOR value, later another bit group for the details of > the vectorization: > SSE > AVX2 > AVX512 > NEON > ALTIVEC > > Since above options can exist together, what about using values for them instead > of bitfields? Reserving 4 bits, 2^4 = 16, can be enough I think for long term. > Rather than having named vector types, we just need to worry about the ones for the current architecture. Therefore I'd suggest just using vector widths, one bit each for 16B, 32B and 64B vector support. For supporting multiple values, 16 combinations is not enough for all the possibilities.