DPDK patches and discussions
 help / color / Atom feed
* [dpdk-dev] [PATCH] kni: increase kernel version requirement for VA
@ 2019-11-20 16:00 Ferruh Yigit
  2019-11-20 16:24 ` Igor Ryzhov
  2019-11-20 17:22 ` [dpdk-dev] [PATCH v2] " Ferruh Yigit
  0 siblings, 2 replies; 15+ messages in thread
From: Ferruh Yigit @ 2019-11-20 16:00 UTC (permalink / raw)
  To: John McNamara, Marko Kovacevic
  Cc: dev, David Marchand, Vamsi Attunuru, Kiran Kumar K, Jerin Jacob

A build error reported related to the selected
'get_user_pages_remote()' kernel API:

.../kernel/linux/kni/kni_dev.h:113:8:
  error: too few arguments to function ‘get_user_pages_remote’
  ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
        ^~~~~~~~~~~~~~~~~~~~~

Currently there are three version of the 'get_user_pages_remote()'
supported, based on kernel version
< 4.9, = 4.9, > 4.9

These version based checks are not working fine with the distro kernels
which is the cause of reported build error. The error reported by the
kernel version 4.8, but it is using API defined in > 4.9.

To be able to take control of this, and possible more, related build
error, increasing the minimum supported kernel version for iova=va with
KNI to kernel version 4.9.

This leaves us with single version of the kernel API and more
manageable.

Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
---
Cc: David Marchand <david.marchand@redhat.com>
Cc: Vamsi Attunuru <vattunuru@marvell.com>
Cc: Kiran Kumar K <kirankumark@marvell.com>
Cc: Jerin Jacob <jerinj@marvell.com>
---
 doc/guides/prog_guide/kernel_nic_interface.rst |  2 +-
 doc/guides/rel_notes/release_19_11.rst         |  2 +-
 kernel/linux/kni/compat.h                      | 16 +++++-----------
 kernel/linux/kni/kni_dev.h                     | 10 ----------
 lib/librte_eal/linux/eal/eal.c                 |  6 +++---
 lib/librte_kni/rte_kni.c                       |  2 +-
 6 files changed, 11 insertions(+), 27 deletions(-)

diff --git a/doc/guides/prog_guide/kernel_nic_interface.rst b/doc/guides/prog_guide/kernel_nic_interface.rst
index c4479ffbf..848b00253 100644
--- a/doc/guides/prog_guide/kernel_nic_interface.rst
+++ b/doc/guides/prog_guide/kernel_nic_interface.rst
@@ -305,7 +305,7 @@ IOVA = VA: Support
 
 KNI operates in IOVA_VA scheme when
 
-- LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0) and
+- LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0) and
 - EAL option `iova-mode=va` is passed or bus IOVA scheme in the DPDK is selected
   as RTE_IOVA_VA.
 
diff --git a/doc/guides/rel_notes/release_19_11.rst b/doc/guides/rel_notes/release_19_11.rst
index 21be600ab..45b58190c 100644
--- a/doc/guides/rel_notes/release_19_11.rst
+++ b/doc/guides/rel_notes/release_19_11.rst
@@ -299,7 +299,7 @@ New Features
   * Added IOVA = VA support for KNI, KNI can operate in IOVA = VA mode when
     `iova-mode=va` EAL option is passed to the application or when bus IOVA
     scheme is selected as RTE_IOVA_VA. This mode only works on Linux Kernel
-    versions 4.6.0 and above.
+    versions above 4.9.0.
 
   * Due to IOVA to KVA address translations, based on the KNI use case there
     can be a performance impact. For mitigation, forcing IOVA to PA via EAL
diff --git a/kernel/linux/kni/compat.h b/kernel/linux/kni/compat.h
index 062b170ef..339dd25a7 100644
--- a/kernel/linux/kni/compat.h
+++ b/kernel/linux/kni/compat.h
@@ -122,16 +122,10 @@
 #define HAVE_SIGNAL_FUNCTIONS_OWN_HEADER
 #endif
 
-#if KERNEL_VERSION(4, 6, 0) <= LINUX_VERSION_CODE
-
+/*
+ * iova to kva mapping support can be provided since 4.6.0, but support
+ * version incread to > 4.9.0 because of the updates in get_user_pages_remote()
+ */
+#if KERNEL_VERSION(4, 9, 0) < LINUX_VERSION_CODE
 #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
-
-#if KERNEL_VERSION(4, 9, 0) > LINUX_VERSION_CODE
-#define GET_USER_PAGES_REMOTE_API_V1
-#elif KERNEL_VERSION(4, 9, 0) == LINUX_VERSION_CODE
-#define GET_USER_PAGES_REMOTE_API_V2
-#else
-#define GET_USER_PAGES_REMOTE_API_V3
-#endif
-
 #endif
diff --git a/kernel/linux/kni/kni_dev.h b/kernel/linux/kni/kni_dev.h
index fb641b696..5e75c6371 100644
--- a/kernel/linux/kni/kni_dev.h
+++ b/kernel/linux/kni/kni_dev.h
@@ -101,18 +101,8 @@ static inline phys_addr_t iova_to_phys(struct task_struct *tsk,
 	offset = iova & (PAGE_SIZE - 1);
 
 	/* Read one page struct info */
-#ifdef GET_USER_PAGES_REMOTE_API_V3
 	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
 				    FOLL_TOUCH, &page, NULL, NULL);
-#endif
-#ifdef GET_USER_PAGES_REMOTE_API_V2
-	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
-				    FOLL_TOUCH, &page, NULL);
-#endif
-#ifdef GET_USER_PAGES_REMOTE_API_V1
-	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
-				    0, 0, &page, NULL);
-#endif
 	if (ret < 0)
 		return 0;
 
diff --git a/lib/librte_eal/linux/eal/eal.c b/lib/librte_eal/linux/eal/eal.c
index b5b71500c..5879e33e5 100644
--- a/lib/librte_eal/linux/eal/eal.c
+++ b/lib/librte_eal/linux/eal/eal.c
@@ -1073,7 +1073,7 @@ rte_eal_init(int argc, char **argv)
 				 */
 				iova_mode = RTE_IOVA_VA;
 				RTE_LOG(DEBUG, EAL, "Physical addresses are unavailable, selecting IOVA as VA mode.\n");
-#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
+#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0)
 			} else if (rte_eal_check_module("rte_kni") == 1) {
 				iova_mode = RTE_IOVA_PA;
 				RTE_LOG(DEBUG, EAL, "KNI is loaded, selecting IOVA as PA mode for better KNI perfomance.\n");
@@ -1090,9 +1090,9 @@ rte_eal_init(int argc, char **argv)
 				RTE_LOG(DEBUG, EAL, "IOMMU is not available, selecting IOVA as PA mode.\n");
 			}
 		}
-#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 6, 0)
+#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9, 0)
 		/* Workaround for KNI which requires physical address to work
-		 * in kernels < 4.6
+		 * in kernels <= 4.9
 		 */
 		if (iova_mode == RTE_IOVA_VA &&
 				rte_eal_check_module("rte_kni") == 1) {
diff --git a/lib/librte_kni/rte_kni.c b/lib/librte_kni/rte_kni.c
index 86995fc81..b564482fe 100644
--- a/lib/librte_kni/rte_kni.c
+++ b/lib/librte_kni/rte_kni.c
@@ -98,7 +98,7 @@ static volatile int kni_fd = -1;
 int
 rte_kni_init(unsigned int max_kni_ifaces __rte_unused)
 {
-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 6, 0)
+#if LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9, 0)
 	if (rte_eal_iova_mode() != RTE_IOVA_PA) {
 		RTE_LOG(ERR, KNI, "KNI requires IOVA as PA\n");
 		return -1;
-- 
2.21.0


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH] kni: increase kernel version requirement for VA
  2019-11-20 16:00 [dpdk-dev] [PATCH] kni: increase kernel version requirement for VA Ferruh Yigit
@ 2019-11-20 16:24 ` Igor Ryzhov
  2019-11-20 16:26   ` Ferruh Yigit
  2019-11-20 17:22 ` [dpdk-dev] [PATCH v2] " Ferruh Yigit
  1 sibling, 1 reply; 15+ messages in thread
From: Igor Ryzhov @ 2019-11-20 16:24 UTC (permalink / raw)
  To: Ferruh Yigit
  Cc: John McNamara, Marko Kovacevic, dev, David Marchand,
	Vamsi Attunuru, Kiran Kumar K, Jerin Jacob

Hi Ferruh,

There is a typo in "version incread to > 4.9.0 ...".
incread > increased

Igor

On Wed, Nov 20, 2019 at 7:00 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:

> A build error reported related to the selected
> 'get_user_pages_remote()' kernel API:
>
> .../kernel/linux/kni/kni_dev.h:113:8:
>   error: too few arguments to function ‘get_user_pages_remote’
>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
>         ^~~~~~~~~~~~~~~~~~~~~
>
> Currently there are three version of the 'get_user_pages_remote()'
> supported, based on kernel version
> < 4.9, = 4.9, > 4.9
>
> These version based checks are not working fine with the distro kernels
> which is the cause of reported build error. The error reported by the
> kernel version 4.8, but it is using API defined in > 4.9.
>
> To be able to take control of this, and possible more, related build
> error, increasing the minimum supported kernel version for iova=va with
> KNI to kernel version 4.9.
>
> This leaves us with single version of the kernel API and more
> manageable.
>
> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> ---
> Cc: David Marchand <david.marchand@redhat.com>
> Cc: Vamsi Attunuru <vattunuru@marvell.com>
> Cc: Kiran Kumar K <kirankumark@marvell.com>
> Cc: Jerin Jacob <jerinj@marvell.com>
> ---
>  doc/guides/prog_guide/kernel_nic_interface.rst |  2 +-
>  doc/guides/rel_notes/release_19_11.rst         |  2 +-
>  kernel/linux/kni/compat.h                      | 16 +++++-----------
>  kernel/linux/kni/kni_dev.h                     | 10 ----------
>  lib/librte_eal/linux/eal/eal.c                 |  6 +++---
>  lib/librte_kni/rte_kni.c                       |  2 +-
>  6 files changed, 11 insertions(+), 27 deletions(-)
>
> diff --git a/doc/guides/prog_guide/kernel_nic_interface.rst
> b/doc/guides/prog_guide/kernel_nic_interface.rst
> index c4479ffbf..848b00253 100644
> --- a/doc/guides/prog_guide/kernel_nic_interface.rst
> +++ b/doc/guides/prog_guide/kernel_nic_interface.rst
> @@ -305,7 +305,7 @@ IOVA = VA: Support
>
>  KNI operates in IOVA_VA scheme when
>
> -- LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0) and
> +- LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0) and
>  - EAL option `iova-mode=va` is passed or bus IOVA scheme in the DPDK is
> selected
>    as RTE_IOVA_VA.
>
> diff --git a/doc/guides/rel_notes/release_19_11.rst
> b/doc/guides/rel_notes/release_19_11.rst
> index 21be600ab..45b58190c 100644
> --- a/doc/guides/rel_notes/release_19_11.rst
> +++ b/doc/guides/rel_notes/release_19_11.rst
> @@ -299,7 +299,7 @@ New Features
>    * Added IOVA = VA support for KNI, KNI can operate in IOVA = VA mode
> when
>      `iova-mode=va` EAL option is passed to the application or when bus
> IOVA
>      scheme is selected as RTE_IOVA_VA. This mode only works on Linux
> Kernel
> -    versions 4.6.0 and above.
> +    versions above 4.9.0.
>
>    * Due to IOVA to KVA address translations, based on the KNI use case
> there
>      can be a performance impact. For mitigation, forcing IOVA to PA via
> EAL
> diff --git a/kernel/linux/kni/compat.h b/kernel/linux/kni/compat.h
> index 062b170ef..339dd25a7 100644
> --- a/kernel/linux/kni/compat.h
> +++ b/kernel/linux/kni/compat.h
> @@ -122,16 +122,10 @@
>  #define HAVE_SIGNAL_FUNCTIONS_OWN_HEADER
>  #endif
>
> -#if KERNEL_VERSION(4, 6, 0) <= LINUX_VERSION_CODE
> -
> +/*
> + * iova to kva mapping support can be provided since 4.6.0, but support
> + * version incread to > 4.9.0 because of the updates in
> get_user_pages_remote()
> + */
> +#if KERNEL_VERSION(4, 9, 0) < LINUX_VERSION_CODE
>  #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
> -
> -#if KERNEL_VERSION(4, 9, 0) > LINUX_VERSION_CODE
> -#define GET_USER_PAGES_REMOTE_API_V1
> -#elif KERNEL_VERSION(4, 9, 0) == LINUX_VERSION_CODE
> -#define GET_USER_PAGES_REMOTE_API_V2
> -#else
> -#define GET_USER_PAGES_REMOTE_API_V3
> -#endif
> -
>  #endif
> diff --git a/kernel/linux/kni/kni_dev.h b/kernel/linux/kni/kni_dev.h
> index fb641b696..5e75c6371 100644
> --- a/kernel/linux/kni/kni_dev.h
> +++ b/kernel/linux/kni/kni_dev.h
> @@ -101,18 +101,8 @@ static inline phys_addr_t iova_to_phys(struct
> task_struct *tsk,
>         offset = iova & (PAGE_SIZE - 1);
>
>         /* Read one page struct info */
> -#ifdef GET_USER_PAGES_REMOTE_API_V3
>         ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
>                                     FOLL_TOUCH, &page, NULL, NULL);
> -#endif
> -#ifdef GET_USER_PAGES_REMOTE_API_V2
> -       ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
> -                                   FOLL_TOUCH, &page, NULL);
> -#endif
> -#ifdef GET_USER_PAGES_REMOTE_API_V1
> -       ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> -                                   0, 0, &page, NULL);
> -#endif
>         if (ret < 0)
>                 return 0;
>
> diff --git a/lib/librte_eal/linux/eal/eal.c
> b/lib/librte_eal/linux/eal/eal.c
> index b5b71500c..5879e33e5 100644
> --- a/lib/librte_eal/linux/eal/eal.c
> +++ b/lib/librte_eal/linux/eal/eal.c
> @@ -1073,7 +1073,7 @@ rte_eal_init(int argc, char **argv)
>                                  */
>                                 iova_mode = RTE_IOVA_VA;
>                                 RTE_LOG(DEBUG, EAL, "Physical addresses
> are unavailable, selecting IOVA as VA mode.\n");
> -#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6,
> 0)
> +#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE > KERNEL_VERSION(4, 9,
> 0)
>                         } else if (rte_eal_check_module("rte_kni") == 1) {
>                                 iova_mode = RTE_IOVA_PA;
>                                 RTE_LOG(DEBUG, EAL, "KNI is loaded,
> selecting IOVA as PA mode for better KNI perfomance.\n");
> @@ -1090,9 +1090,9 @@ rte_eal_init(int argc, char **argv)
>                                 RTE_LOG(DEBUG, EAL, "IOMMU is not
> available, selecting IOVA as PA mode.\n");
>                         }
>                 }
> -#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 6,
> 0)
> +#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9,
> 0)
>                 /* Workaround for KNI which requires physical address to
> work
> -                * in kernels < 4.6
> +                * in kernels <= 4.9
>                  */
>                 if (iova_mode == RTE_IOVA_VA &&
>                                 rte_eal_check_module("rte_kni") == 1) {
> diff --git a/lib/librte_kni/rte_kni.c b/lib/librte_kni/rte_kni.c
> index 86995fc81..b564482fe 100644
> --- a/lib/librte_kni/rte_kni.c
> +++ b/lib/librte_kni/rte_kni.c
> @@ -98,7 +98,7 @@ static volatile int kni_fd = -1;
>  int
>  rte_kni_init(unsigned int max_kni_ifaces __rte_unused)
>  {
> -#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 6, 0)
> +#if LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9, 0)
>         if (rte_eal_iova_mode() != RTE_IOVA_PA) {
>                 RTE_LOG(ERR, KNI, "KNI requires IOVA as PA\n");
>                 return -1;
> --
> 2.21.0
>
>

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH] kni: increase kernel version requirement for VA
  2019-11-20 16:24 ` Igor Ryzhov
@ 2019-11-20 16:26   ` Ferruh Yigit
  0 siblings, 0 replies; 15+ messages in thread
From: Ferruh Yigit @ 2019-11-20 16:26 UTC (permalink / raw)
  To: Igor Ryzhov
  Cc: John McNamara, Marko Kovacevic, dev, David Marchand,
	Vamsi Attunuru, Kiran Kumar K, Jerin Jacob

On 11/20/2019 4:24 PM, Igor Ryzhov wrote:
> Hi Ferruh,
> 
> There is a typo in "version incread to > 4.9.0 ...".
> incread > increased

Thanks Igor, I will fix in next version.

> 
> Igor
> 
> On Wed, Nov 20, 2019 at 7:00 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
> 
>> A build error reported related to the selected
>> 'get_user_pages_remote()' kernel API:
>>
>> .../kernel/linux/kni/kni_dev.h:113:8:
>>   error: too few arguments to function ‘get_user_pages_remote’
>>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
>>         ^~~~~~~~~~~~~~~~~~~~~
>>
>> Currently there are three version of the 'get_user_pages_remote()'
>> supported, based on kernel version
>> < 4.9, = 4.9, > 4.9
>>
>> These version based checks are not working fine with the distro kernels
>> which is the cause of reported build error. The error reported by the
>> kernel version 4.8, but it is using API defined in > 4.9.
>>
>> To be able to take control of this, and possible more, related build
>> error, increasing the minimum supported kernel version for iova=va with
>> KNI to kernel version 4.9.
>>
>> This leaves us with single version of the kernel API and more
>> manageable.
>>
>> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
>> ---
>> Cc: David Marchand <david.marchand@redhat.com>
>> Cc: Vamsi Attunuru <vattunuru@marvell.com>
>> Cc: Kiran Kumar K <kirankumark@marvell.com>
>> Cc: Jerin Jacob <jerinj@marvell.com>
>> ---
>>  doc/guides/prog_guide/kernel_nic_interface.rst |  2 +-
>>  doc/guides/rel_notes/release_19_11.rst         |  2 +-
>>  kernel/linux/kni/compat.h                      | 16 +++++-----------
>>  kernel/linux/kni/kni_dev.h                     | 10 ----------
>>  lib/librte_eal/linux/eal/eal.c                 |  6 +++---
>>  lib/librte_kni/rte_kni.c                       |  2 +-
>>  6 files changed, 11 insertions(+), 27 deletions(-)
>>
>> diff --git a/doc/guides/prog_guide/kernel_nic_interface.rst
>> b/doc/guides/prog_guide/kernel_nic_interface.rst
>> index c4479ffbf..848b00253 100644
>> --- a/doc/guides/prog_guide/kernel_nic_interface.rst
>> +++ b/doc/guides/prog_guide/kernel_nic_interface.rst
>> @@ -305,7 +305,7 @@ IOVA = VA: Support
>>
>>  KNI operates in IOVA_VA scheme when
>>
>> -- LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0) and
>> +- LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0) and
>>  - EAL option `iova-mode=va` is passed or bus IOVA scheme in the DPDK is
>> selected
>>    as RTE_IOVA_VA.
>>
>> diff --git a/doc/guides/rel_notes/release_19_11.rst
>> b/doc/guides/rel_notes/release_19_11.rst
>> index 21be600ab..45b58190c 100644
>> --- a/doc/guides/rel_notes/release_19_11.rst
>> +++ b/doc/guides/rel_notes/release_19_11.rst
>> @@ -299,7 +299,7 @@ New Features
>>    * Added IOVA = VA support for KNI, KNI can operate in IOVA = VA mode
>> when
>>      `iova-mode=va` EAL option is passed to the application or when bus
>> IOVA
>>      scheme is selected as RTE_IOVA_VA. This mode only works on Linux
>> Kernel
>> -    versions 4.6.0 and above.
>> +    versions above 4.9.0.
>>
>>    * Due to IOVA to KVA address translations, based on the KNI use case
>> there
>>      can be a performance impact. For mitigation, forcing IOVA to PA via
>> EAL
>> diff --git a/kernel/linux/kni/compat.h b/kernel/linux/kni/compat.h
>> index 062b170ef..339dd25a7 100644
>> --- a/kernel/linux/kni/compat.h
>> +++ b/kernel/linux/kni/compat.h
>> @@ -122,16 +122,10 @@
>>  #define HAVE_SIGNAL_FUNCTIONS_OWN_HEADER
>>  #endif
>>
>> -#if KERNEL_VERSION(4, 6, 0) <= LINUX_VERSION_CODE
>> -
>> +/*
>> + * iova to kva mapping support can be provided since 4.6.0, but support
>> + * version incread to > 4.9.0 because of the updates in
>> get_user_pages_remote()
>> + */
>> +#if KERNEL_VERSION(4, 9, 0) < LINUX_VERSION_CODE
>>  #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
>> -
>> -#if KERNEL_VERSION(4, 9, 0) > LINUX_VERSION_CODE
>> -#define GET_USER_PAGES_REMOTE_API_V1
>> -#elif KERNEL_VERSION(4, 9, 0) == LINUX_VERSION_CODE
>> -#define GET_USER_PAGES_REMOTE_API_V2
>> -#else
>> -#define GET_USER_PAGES_REMOTE_API_V3
>> -#endif
>> -
>>  #endif
>> diff --git a/kernel/linux/kni/kni_dev.h b/kernel/linux/kni/kni_dev.h
>> index fb641b696..5e75c6371 100644
>> --- a/kernel/linux/kni/kni_dev.h
>> +++ b/kernel/linux/kni/kni_dev.h
>> @@ -101,18 +101,8 @@ static inline phys_addr_t iova_to_phys(struct
>> task_struct *tsk,
>>         offset = iova & (PAGE_SIZE - 1);
>>
>>         /* Read one page struct info */
>> -#ifdef GET_USER_PAGES_REMOTE_API_V3
>>         ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
>>                                     FOLL_TOUCH, &page, NULL, NULL);
>> -#endif
>> -#ifdef GET_USER_PAGES_REMOTE_API_V2
>> -       ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
>> -                                   FOLL_TOUCH, &page, NULL);
>> -#endif
>> -#ifdef GET_USER_PAGES_REMOTE_API_V1
>> -       ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
>> -                                   0, 0, &page, NULL);
>> -#endif
>>         if (ret < 0)
>>                 return 0;
>>
>> diff --git a/lib/librte_eal/linux/eal/eal.c
>> b/lib/librte_eal/linux/eal/eal.c
>> index b5b71500c..5879e33e5 100644
>> --- a/lib/librte_eal/linux/eal/eal.c
>> +++ b/lib/librte_eal/linux/eal/eal.c
>> @@ -1073,7 +1073,7 @@ rte_eal_init(int argc, char **argv)
>>                                  */
>>                                 iova_mode = RTE_IOVA_VA;
>>                                 RTE_LOG(DEBUG, EAL, "Physical addresses
>> are unavailable, selecting IOVA as VA mode.\n");
>> -#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6,
>> 0)
>> +#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE > KERNEL_VERSION(4, 9,
>> 0)
>>                         } else if (rte_eal_check_module("rte_kni") == 1) {
>>                                 iova_mode = RTE_IOVA_PA;
>>                                 RTE_LOG(DEBUG, EAL, "KNI is loaded,
>> selecting IOVA as PA mode for better KNI perfomance.\n");
>> @@ -1090,9 +1090,9 @@ rte_eal_init(int argc, char **argv)
>>                                 RTE_LOG(DEBUG, EAL, "IOMMU is not
>> available, selecting IOVA as PA mode.\n");
>>                         }
>>                 }
>> -#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 6,
>> 0)
>> +#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9,
>> 0)
>>                 /* Workaround for KNI which requires physical address to
>> work
>> -                * in kernels < 4.6
>> +                * in kernels <= 4.9
>>                  */
>>                 if (iova_mode == RTE_IOVA_VA &&
>>                                 rte_eal_check_module("rte_kni") == 1) {
>> diff --git a/lib/librte_kni/rte_kni.c b/lib/librte_kni/rte_kni.c
>> index 86995fc81..b564482fe 100644
>> --- a/lib/librte_kni/rte_kni.c
>> +++ b/lib/librte_kni/rte_kni.c
>> @@ -98,7 +98,7 @@ static volatile int kni_fd = -1;
>>  int
>>  rte_kni_init(unsigned int max_kni_ifaces __rte_unused)
>>  {
>> -#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 6, 0)
>> +#if LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9, 0)
>>         if (rte_eal_iova_mode() != RTE_IOVA_PA) {
>>                 RTE_LOG(ERR, KNI, "KNI requires IOVA as PA\n");
>>                 return -1;
>> --
>> 2.21.0
>>
>>


^ permalink raw reply	[flat|nested] 15+ messages in thread

* [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-20 16:00 [dpdk-dev] [PATCH] kni: increase kernel version requirement for VA Ferruh Yigit
  2019-11-20 16:24 ` Igor Ryzhov
@ 2019-11-20 17:22 ` " Ferruh Yigit
  2019-11-20 17:28   ` David Marchand
  2019-11-28 12:13   ` [dpdk-dev] " Ferruh Yigit
  1 sibling, 2 replies; 15+ messages in thread
From: Ferruh Yigit @ 2019-11-20 17:22 UTC (permalink / raw)
  To: John McNamara, Marko Kovacevic
  Cc: dev, David Marchand, Vamsi Attunuru, Kiran Kumar K, Jerin Jacob,
	Igor Ryzhov

A build error reported related to the selected
'get_user_pages_remote()' kernel API:

.../kernel/linux/kni/kni_dev.h:113:8:
  error: too few arguments to function ‘get_user_pages_remote’
  ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
        ^~~~~~~~~~~~~~~~~~~~~

Currently there are three version of the 'get_user_pages_remote()'
supported, based on kernel version
< 4.9, = 4.9, > 4.9

These version based checks are not working fine with the distro kernels
which is the cause of reported build error. The error reported by the
kernel version 4.8, but it is using API defined in > 4.9.

To be able to take control of this, and possible more, related build
error, increasing the minimum supported kernel version for iova=va with
KNI to kernel version 4.9.

This leaves us with single version of the kernel API and more
manageable.

Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
---
Cc: David Marchand <david.marchand@redhat.com>
Cc: Vamsi Attunuru <vattunuru@marvell.com>
Cc: Kiran Kumar K <kirankumark@marvell.com>
Cc: Jerin Jacob <jerinj@marvell.com>

v2:
* fixed typo in comment
Cc: Igor Ryzhov <iryzhov@nfware.com>
---
 doc/guides/prog_guide/kernel_nic_interface.rst |  2 +-
 doc/guides/rel_notes/release_19_11.rst         |  2 +-
 kernel/linux/kni/compat.h                      | 17 ++++++-----------
 kernel/linux/kni/kni_dev.h                     | 10 ----------
 lib/librte_eal/linux/eal/eal.c                 |  6 +++---
 lib/librte_kni/rte_kni.c                       |  2 +-
 6 files changed, 12 insertions(+), 27 deletions(-)

diff --git a/doc/guides/prog_guide/kernel_nic_interface.rst b/doc/guides/prog_guide/kernel_nic_interface.rst
index c4479ffbf..848b00253 100644
--- a/doc/guides/prog_guide/kernel_nic_interface.rst
+++ b/doc/guides/prog_guide/kernel_nic_interface.rst
@@ -305,7 +305,7 @@ IOVA = VA: Support
 
 KNI operates in IOVA_VA scheme when
 
-- LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0) and
+- LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0) and
 - EAL option `iova-mode=va` is passed or bus IOVA scheme in the DPDK is selected
   as RTE_IOVA_VA.
 
diff --git a/doc/guides/rel_notes/release_19_11.rst b/doc/guides/rel_notes/release_19_11.rst
index 21be600ab..45b58190c 100644
--- a/doc/guides/rel_notes/release_19_11.rst
+++ b/doc/guides/rel_notes/release_19_11.rst
@@ -299,7 +299,7 @@ New Features
   * Added IOVA = VA support for KNI, KNI can operate in IOVA = VA mode when
     `iova-mode=va` EAL option is passed to the application or when bus IOVA
     scheme is selected as RTE_IOVA_VA. This mode only works on Linux Kernel
-    versions 4.6.0 and above.
+    versions above 4.9.0.
 
   * Due to IOVA to KVA address translations, based on the KNI use case there
     can be a performance impact. For mitigation, forcing IOVA to PA via EAL
diff --git a/kernel/linux/kni/compat.h b/kernel/linux/kni/compat.h
index 062b170ef..83ecac2d8 100644
--- a/kernel/linux/kni/compat.h
+++ b/kernel/linux/kni/compat.h
@@ -122,16 +122,11 @@
 #define HAVE_SIGNAL_FUNCTIONS_OWN_HEADER
 #endif
 
-#if KERNEL_VERSION(4, 6, 0) <= LINUX_VERSION_CODE
-
+/*
+ * iova to kva mapping support can be provided since 4.6.0, but required
+ * kernel version increased to > 4.9.0 because of the updates in
+ * get_user_pages_remote() kernel API
+ */
+#if KERNEL_VERSION(4, 9, 0) < LINUX_VERSION_CODE
 #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
-
-#if KERNEL_VERSION(4, 9, 0) > LINUX_VERSION_CODE
-#define GET_USER_PAGES_REMOTE_API_V1
-#elif KERNEL_VERSION(4, 9, 0) == LINUX_VERSION_CODE
-#define GET_USER_PAGES_REMOTE_API_V2
-#else
-#define GET_USER_PAGES_REMOTE_API_V3
-#endif
-
 #endif
diff --git a/kernel/linux/kni/kni_dev.h b/kernel/linux/kni/kni_dev.h
index fb641b696..5e75c6371 100644
--- a/kernel/linux/kni/kni_dev.h
+++ b/kernel/linux/kni/kni_dev.h
@@ -101,18 +101,8 @@ static inline phys_addr_t iova_to_phys(struct task_struct *tsk,
 	offset = iova & (PAGE_SIZE - 1);
 
 	/* Read one page struct info */
-#ifdef GET_USER_PAGES_REMOTE_API_V3
 	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
 				    FOLL_TOUCH, &page, NULL, NULL);
-#endif
-#ifdef GET_USER_PAGES_REMOTE_API_V2
-	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
-				    FOLL_TOUCH, &page, NULL);
-#endif
-#ifdef GET_USER_PAGES_REMOTE_API_V1
-	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
-				    0, 0, &page, NULL);
-#endif
 	if (ret < 0)
 		return 0;
 
diff --git a/lib/librte_eal/linux/eal/eal.c b/lib/librte_eal/linux/eal/eal.c
index b5b71500c..5879e33e5 100644
--- a/lib/librte_eal/linux/eal/eal.c
+++ b/lib/librte_eal/linux/eal/eal.c
@@ -1073,7 +1073,7 @@ rte_eal_init(int argc, char **argv)
 				 */
 				iova_mode = RTE_IOVA_VA;
 				RTE_LOG(DEBUG, EAL, "Physical addresses are unavailable, selecting IOVA as VA mode.\n");
-#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
+#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0)
 			} else if (rte_eal_check_module("rte_kni") == 1) {
 				iova_mode = RTE_IOVA_PA;
 				RTE_LOG(DEBUG, EAL, "KNI is loaded, selecting IOVA as PA mode for better KNI perfomance.\n");
@@ -1090,9 +1090,9 @@ rte_eal_init(int argc, char **argv)
 				RTE_LOG(DEBUG, EAL, "IOMMU is not available, selecting IOVA as PA mode.\n");
 			}
 		}
-#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 6, 0)
+#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9, 0)
 		/* Workaround for KNI which requires physical address to work
-		 * in kernels < 4.6
+		 * in kernels <= 4.9
 		 */
 		if (iova_mode == RTE_IOVA_VA &&
 				rte_eal_check_module("rte_kni") == 1) {
diff --git a/lib/librte_kni/rte_kni.c b/lib/librte_kni/rte_kni.c
index 86995fc81..b564482fe 100644
--- a/lib/librte_kni/rte_kni.c
+++ b/lib/librte_kni/rte_kni.c
@@ -98,7 +98,7 @@ static volatile int kni_fd = -1;
 int
 rte_kni_init(unsigned int max_kni_ifaces __rte_unused)
 {
-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 6, 0)
+#if LINUX_VERSION_CODE <= KERNEL_VERSION(4, 9, 0)
 	if (rte_eal_iova_mode() != RTE_IOVA_PA) {
 		RTE_LOG(ERR, KNI, "KNI requires IOVA as PA\n");
 		return -1;
-- 
2.21.0


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-20 17:22 ` [dpdk-dev] [PATCH v2] " Ferruh Yigit
@ 2019-11-20 17:28   ` David Marchand
  2019-11-20 22:30     ` David Marchand
  2019-11-21  1:58     ` Jerin Jacob
  2019-11-28 12:13   ` [dpdk-dev] " Ferruh Yigit
  1 sibling, 2 replies; 15+ messages in thread
From: David Marchand @ 2019-11-20 17:28 UTC (permalink / raw)
  To: Vamsi Attunuru, Jerin Jacob
  Cc: John McNamara, Marko Kovacevic, dev, Kiran Kumar K, Igor Ryzhov,
	Ferruh Yigit

On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
>
> A build error reported related to the selected
> 'get_user_pages_remote()' kernel API:
>
> .../kernel/linux/kni/kni_dev.h:113:8:
>   error: too few arguments to function ‘get_user_pages_remote’
>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
>         ^~~~~~~~~~~~~~~~~~~~~
>
> Currently there are three version of the 'get_user_pages_remote()'
> supported, based on kernel version
> < 4.9, = 4.9, > 4.9
>
> These version based checks are not working fine with the distro kernels
> which is the cause of reported build error. The error reported by the
> kernel version 4.8, but it is using API defined in > 4.9.
>
> To be able to take control of this, and possible more, related build
> error, increasing the minimum supported kernel version for iova=va with
> KNI to kernel version 4.9.
>
> This leaves us with single version of the kernel API and more
> manageable.
>
> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>

Jerin, Vamsi,

Is this okay for you?
Thanks.


-- 
David Marchand


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-20 17:28   ` David Marchand
@ 2019-11-20 22:30     ` David Marchand
  2019-11-28 10:44       ` Andrew Rybchenko
  2019-11-21  1:58     ` Jerin Jacob
  1 sibling, 1 reply; 15+ messages in thread
From: David Marchand @ 2019-11-20 22:30 UTC (permalink / raw)
  To: Vamsi Attunuru, Jerin Jacob
  Cc: John McNamara, Marko Kovacevic, dev, Kiran Kumar K, Igor Ryzhov,
	Ferruh Yigit

On Wed, Nov 20, 2019 at 6:28 PM David Marchand
<david.marchand@redhat.com> wrote:
>
> On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
> >
> > A build error reported related to the selected
> > 'get_user_pages_remote()' kernel API:
> >
> > .../kernel/linux/kni/kni_dev.h:113:8:
> >   error: too few arguments to function ‘get_user_pages_remote’
> >   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> >         ^~~~~~~~~~~~~~~~~~~~~
> >
> > Currently there are three version of the 'get_user_pages_remote()'
> > supported, based on kernel version
> > < 4.9, = 4.9, > 4.9
> >
> > These version based checks are not working fine with the distro kernels
> > which is the cause of reported build error. The error reported by the
> > kernel version 4.8, but it is using API defined in > 4.9.
> >
> > To be able to take control of this, and possible more, related build
> > error, increasing the minimum supported kernel version for iova=va with
> > KNI to kernel version 4.9.
> >
> > This leaves us with single version of the kernel API and more
> > manageable.
> >
> > Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>

Reviewed-by: David Marchand <david.marchand@redhat.com>

We need this change to fix compilation issues for -rc3.
Applied, thanks.


-- 
David Marchand


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-20 17:28   ` David Marchand
  2019-11-20 22:30     ` David Marchand
@ 2019-11-21  1:58     ` Jerin Jacob
  2019-11-21  2:18       ` [dpdk-dev] [EXT] " Vamsi Krishna Attunuru
  1 sibling, 1 reply; 15+ messages in thread
From: Jerin Jacob @ 2019-11-21  1:58 UTC (permalink / raw)
  To: David Marchand
  Cc: Vamsi Attunuru, Jerin Jacob, John McNamara, Marko Kovacevic, dev,
	Kiran Kumar K, Igor Ryzhov, Ferruh Yigit

On Wed, Nov 20, 2019 at 10:59 PM David Marchand
<david.marchand@redhat.com> wrote:
>
> On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
> >
> > A build error reported related to the selected
> > 'get_user_pages_remote()' kernel API:
> >
> > .../kernel/linux/kni/kni_dev.h:113:8:
> >   error: too few arguments to function ‘get_user_pages_remote’
> >   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> >         ^~~~~~~~~~~~~~~~~~~~~
> >
> > Currently there are three version of the 'get_user_pages_remote()'
> > supported, based on kernel version
> > < 4.9, = 4.9, > 4.9
> >
> > These version based checks are not working fine with the distro kernels
> > which is the cause of reported build error. The error reported by the
> > kernel version 4.8, but it is using API defined in > 4.9.
> >
> > To be able to take control of this, and possible more, related build
> > error, increasing the minimum supported kernel version for iova=va with
> > KNI to kernel version 4.9.
> >
> > This leaves us with single version of the kernel API and more
> > manageable.
> >
> > Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
>
> Jerin, Vamsi,
>
> Is this okay for you?

Acked-by: Jerin Jacob <jerinj@marvell.com>


> Thanks.
>
>
> --
> David Marchand
>

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [EXT] Re: [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-21  1:58     ` Jerin Jacob
@ 2019-11-21  2:18       ` " Vamsi Krishna Attunuru
  0 siblings, 0 replies; 15+ messages in thread
From: Vamsi Krishna Attunuru @ 2019-11-21  2:18 UTC (permalink / raw)
  To: Jerin Jacob, David Marchand
  Cc: Jerin Jacob Kollanukkaran, John McNamara, Marko Kovacevic, dev,
	Kiran Kumar Kokkilagadda, Igor Ryzhov, Ferruh Yigit



> -----Original Message-----
> From: Jerin Jacob <jerinjacobk@gmail.com>
> Sent: Thursday, November 21, 2019 7:28 AM
> To: David Marchand <david.marchand@redhat.com>
> Cc: Vamsi Krishna Attunuru <vattunuru@marvell.com>; Jerin Jacob
> Kollanukkaran <jerinj@marvell.com>; John McNamara
> <john.mcnamara@intel.com>; Marko Kovacevic
> <marko.kovacevic@intel.com>; dev <dev@dpdk.org>; Kiran Kumar
> Kokkilagadda <kirankumark@marvell.com>; Igor Ryzhov
> <iryzhov@nfware.com>; Ferruh Yigit <ferruh.yigit@intel.com>
> Subject: [EXT] Re: [dpdk-dev] [PATCH v2] kni: increase kernel version
> requirement for VA
> 
> External Email
> 
> ----------------------------------------------------------------------
> On Wed, Nov 20, 2019 at 10:59 PM David Marchand
> <david.marchand@redhat.com> wrote:
> >
> > On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com>
> wrote:
> > >
> > > A build error reported related to the selected
> > > 'get_user_pages_remote()' kernel API:
> > >
> > > .../kernel/linux/kni/kni_dev.h:113:8:
> > >   error: too few arguments to function ‘get_user_pages_remote’
> > >   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> > >         ^~~~~~~~~~~~~~~~~~~~~
> > >
> > > Currently there are three version of the 'get_user_pages_remote()'
> > > supported, based on kernel version
> > > < 4.9, = 4.9, > 4.9
> > >
> > > These version based checks are not working fine with the distro
> > > kernels which is the cause of reported build error. The error
> > > reported by the kernel version 4.8, but it is using API defined in > 4.9.
> > >
> > > To be able to take control of this, and possible more, related build
> > > error, increasing the minimum supported kernel version for iova=va
> > > with KNI to kernel version 4.9.
> > >
> > > This leaves us with single version of the kernel API and more
> > > manageable.
> > >
> > > Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> >
> > Jerin, Vamsi,
> >
> > Is this okay for you?
> 
> Acked-by: Jerin Jacob <jerinj@marvell.com>
> 

Acked-by: Vamsi Attunuru <vattunuru@marvell.com>
> 
> > Thanks.
> >
> >
> > --
> > David Marchand
> >

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-20 22:30     ` David Marchand
@ 2019-11-28 10:44       ` Andrew Rybchenko
  2019-11-28 10:50         ` Thomas Monjalon
                           ` (2 more replies)
  0 siblings, 3 replies; 15+ messages in thread
From: Andrew Rybchenko @ 2019-11-28 10:44 UTC (permalink / raw)
  To: David Marchand, Vamsi Attunuru, Jerin Jacob, Ferruh Yigit
  Cc: John McNamara, Marko Kovacevic, dev, Kiran Kumar K, Igor Ryzhov,
	Thomas Monjalon

On 11/21/19 1:30 AM, David Marchand wrote:
> On Wed, Nov 20, 2019 at 6:28 PM David Marchand
> <david.marchand@redhat.com> wrote:
>> On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
>>> A build error reported related to the selected
>>> 'get_user_pages_remote()' kernel API:
>>>
>>> .../kernel/linux/kni/kni_dev.h:113:8:
>>>   error: too few arguments to function ‘get_user_pages_remote’
>>>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
>>>         ^~~~~~~~~~~~~~~~~~~~~
>>>
>>> Currently there are three version of the 'get_user_pages_remote()'
>>> supported, based on kernel version
>>> < 4.9, = 4.9, > 4.9
>>>
>>> These version based checks are not working fine with the distro kernels
>>> which is the cause of reported build error. The error reported by the
>>> kernel version 4.8, but it is using API defined in > 4.9.
>>>
>>> To be able to take control of this, and possible more, related build
>>> error, increasing the minimum supported kernel version for iova=va with
>>> KNI to kernel version 4.9.
>>>
>>> This leaves us with single version of the kernel API and more
>>> manageable.
>>>
>>> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> Reviewed-by: David Marchand <david.marchand@redhat.com>
>
> We need this change to fix compilation issues for -rc3.
> Applied, thanks.

The build is still broken on Debian 9 stretch which has Linux 4.9.189,
but corresponding function still has no the last argument.
It looks like requirements should be bumped to >=4.10.0.



^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-28 10:44       ` Andrew Rybchenko
@ 2019-11-28 10:50         ` Thomas Monjalon
  2019-11-28 11:01         ` Jerin Jacob
  2019-11-28 11:02         ` David Marchand
  2 siblings, 0 replies; 15+ messages in thread
From: Thomas Monjalon @ 2019-11-28 10:50 UTC (permalink / raw)
  To: Andrew Rybchenko
  Cc: David Marchand, Vamsi Attunuru, Jerin Jacob, Ferruh Yigit,
	John McNamara, Marko Kovacevic, dev, Kiran Kumar K, Igor Ryzhov

28/11/2019 11:44, Andrew Rybchenko:
> On 11/21/19 1:30 AM, David Marchand wrote:
> > On Wed, Nov 20, 2019 at 6:28 PM David Marchand
> > <david.marchand@redhat.com> wrote:
> >> On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
> >>> A build error reported related to the selected
> >>> 'get_user_pages_remote()' kernel API:
> >>>
> >>> .../kernel/linux/kni/kni_dev.h:113:8:
> >>>   error: too few arguments to function ‘get_user_pages_remote’
> >>>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> >>>         ^~~~~~~~~~~~~~~~~~~~~
> >>>
> >>> Currently there are three version of the 'get_user_pages_remote()'
> >>> supported, based on kernel version
> >>> < 4.9, = 4.9, > 4.9
> >>>
> >>> These version based checks are not working fine with the distro kernels
> >>> which is the cause of reported build error. The error reported by the
> >>> kernel version 4.8, but it is using API defined in > 4.9.
> >>>
> >>> To be able to take control of this, and possible more, related build
> >>> error, increasing the minimum supported kernel version for iova=va with
> >>> KNI to kernel version 4.9.
> >>>
> >>> This leaves us with single version of the kernel API and more
> >>> manageable.
> >>>
> >>> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> > Reviewed-by: David Marchand <david.marchand@redhat.com>
> >
> > We need this change to fix compilation issues for -rc3.
> > Applied, thanks.
> 
> The build is still broken on Debian 9 stretch which has Linux 4.9.189,
> but corresponding function still has no the last argument.
> It looks like requirements should be bumped to >=4.10.0.

No opinion. I am fine with any fix (today).



^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-28 10:44       ` Andrew Rybchenko
  2019-11-28 10:50         ` Thomas Monjalon
@ 2019-11-28 11:01         ` Jerin Jacob
  2019-11-28 11:02         ` David Marchand
  2 siblings, 0 replies; 15+ messages in thread
From: Jerin Jacob @ 2019-11-28 11:01 UTC (permalink / raw)
  To: Andrew Rybchenko
  Cc: David Marchand, Vamsi Attunuru, Jerin Jacob, Ferruh Yigit,
	John McNamara, Marko Kovacevic, dev, Kiran Kumar K, Igor Ryzhov,
	Thomas Monjalon

On Thu, Nov 28, 2019 at 7:45 PM Andrew Rybchenko
<arybchenko@solarflare.com> wrote:
>
> On 11/21/19 1:30 AM, David Marchand wrote:
> > On Wed, Nov 20, 2019 at 6:28 PM David Marchand
> > <david.marchand@redhat.com> wrote:
> >> On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
> >>> A build error reported related to the selected
> >>> 'get_user_pages_remote()' kernel API:
> >>>
> >>> .../kernel/linux/kni/kni_dev.h:113:8:
> >>>   error: too few arguments to function ‘get_user_pages_remote’
> >>>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> >>>         ^~~~~~~~~~~~~~~~~~~~~
> >>>
> >>> Currently there are three version of the 'get_user_pages_remote()'
> >>> supported, based on kernel version
> >>> < 4.9, = 4.9, > 4.9
> >>>
> >>> These version based checks are not working fine with the distro kernels
> >>> which is the cause of reported build error. The error reported by the
> >>> kernel version 4.8, but it is using API defined in > 4.9.
> >>>
> >>> To be able to take control of this, and possible more, related build
> >>> error, increasing the minimum supported kernel version for iova=va with
> >>> KNI to kernel version 4.9.
> >>>
> >>> This leaves us with single version of the kernel API and more
> >>> manageable.
> >>>
> >>> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> > Reviewed-by: David Marchand <david.marchand@redhat.com>
> >
> > We need this change to fix compilation issues for -rc3.
> > Applied, thanks.
>
> The build is still broken on Debian 9 stretch which has Linux 4.9.189,
> but corresponding function still has no the last argument.
> It looks like requirements should be bumped to >=4.10.0.

+1

>
>

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-28 10:44       ` Andrew Rybchenko
  2019-11-28 10:50         ` Thomas Monjalon
  2019-11-28 11:01         ` Jerin Jacob
@ 2019-11-28 11:02         ` David Marchand
  2019-11-28 11:05           ` Ferruh Yigit
  2 siblings, 1 reply; 15+ messages in thread
From: David Marchand @ 2019-11-28 11:02 UTC (permalink / raw)
  To: Andrew Rybchenko
  Cc: Vamsi Attunuru, Jerin Jacob, Ferruh Yigit, John McNamara,
	Marko Kovacevic, dev, Kiran Kumar K, Igor Ryzhov,
	Thomas Monjalon

On Thu, Nov 28, 2019 at 11:45 AM Andrew Rybchenko
<arybchenko@solarflare.com> wrote:
>
> On 11/21/19 1:30 AM, David Marchand wrote:
> > On Wed, Nov 20, 2019 at 6:28 PM David Marchand
> > <david.marchand@redhat.com> wrote:
> >> On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
> >>> A build error reported related to the selected
> >>> 'get_user_pages_remote()' kernel API:
> >>>
> >>> .../kernel/linux/kni/kni_dev.h:113:8:
> >>>   error: too few arguments to function ‘get_user_pages_remote’
> >>>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> >>>         ^~~~~~~~~~~~~~~~~~~~~
> >>>
> >>> Currently there are three version of the 'get_user_pages_remote()'
> >>> supported, based on kernel version
> >>> < 4.9, = 4.9, > 4.9
> >>>
> >>> These version based checks are not working fine with the distro kernels
> >>> which is the cause of reported build error. The error reported by the
> >>> kernel version 4.8, but it is using API defined in > 4.9.
> >>>
> >>> To be able to take control of this, and possible more, related build
> >>> error, increasing the minimum supported kernel version for iova=va with
> >>> KNI to kernel version 4.9.
> >>>
> >>> This leaves us with single version of the kernel API and more
> >>> manageable.
> >>>
> >>> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> > Reviewed-by: David Marchand <david.marchand@redhat.com>
> >
> > We need this change to fix compilation issues for -rc3.
> > Applied, thanks.
>
> The build is still broken on Debian 9 stretch which has Linux 4.9.189,
> but corresponding function still has no the last argument.
> It looks like requirements should be bumped to >=4.10.0.

It came with:
5b56d49fc31d - mm: add locked parameter to get_user_pages_remote() (2
years, 11 months ago) <Lorenzo Stoakes>

$ git describe --contains 5b56d49fc31d
v4.10-rc1~110^2~56

The check on > 4.9.0 is wrong, it should be >= 4.10.0 yes.


-- 
David Marchand


^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-28 11:02         ` David Marchand
@ 2019-11-28 11:05           ` Ferruh Yigit
  0 siblings, 0 replies; 15+ messages in thread
From: Ferruh Yigit @ 2019-11-28 11:05 UTC (permalink / raw)
  To: David Marchand, Andrew Rybchenko
  Cc: Vamsi Attunuru, Jerin Jacob, John McNamara, Marko Kovacevic, dev,
	Kiran Kumar K, Igor Ryzhov, Thomas Monjalon

On 11/28/2019 11:02 AM, David Marchand wrote:
> On Thu, Nov 28, 2019 at 11:45 AM Andrew Rybchenko
> <arybchenko@solarflare.com> wrote:
>>
>> On 11/21/19 1:30 AM, David Marchand wrote:
>>> On Wed, Nov 20, 2019 at 6:28 PM David Marchand
>>> <david.marchand@redhat.com> wrote:
>>>> On Wed, Nov 20, 2019 at 6:22 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
>>>>> A build error reported related to the selected
>>>>> 'get_user_pages_remote()' kernel API:
>>>>>
>>>>> .../kernel/linux/kni/kni_dev.h:113:8:
>>>>>   error: too few arguments to function ‘get_user_pages_remote’
>>>>>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
>>>>>         ^~~~~~~~~~~~~~~~~~~~~
>>>>>
>>>>> Currently there are three version of the 'get_user_pages_remote()'
>>>>> supported, based on kernel version
>>>>> < 4.9, = 4.9, > 4.9
>>>>>
>>>>> These version based checks are not working fine with the distro kernels
>>>>> which is the cause of reported build error. The error reported by the
>>>>> kernel version 4.8, but it is using API defined in > 4.9.
>>>>>
>>>>> To be able to take control of this, and possible more, related build
>>>>> error, increasing the minimum supported kernel version for iova=va with
>>>>> KNI to kernel version 4.9.
>>>>>
>>>>> This leaves us with single version of the kernel API and more
>>>>> manageable.
>>>>>
>>>>> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
>>> Reviewed-by: David Marchand <david.marchand@redhat.com>
>>>
>>> We need this change to fix compilation issues for -rc3.
>>> Applied, thanks.
>>
>> The build is still broken on Debian 9 stretch which has Linux 4.9.189,
>> but corresponding function still has no the last argument.
>> It looks like requirements should be bumped to >=4.10.0.
> 
> It came with:
> 5b56d49fc31d - mm: add locked parameter to get_user_pages_remote() (2
> years, 11 months ago) <Lorenzo Stoakes>
> 
> $ git describe --contains 5b56d49fc31d
> v4.10-rc1~110^2~56
> 
> The check on > 4.9.0 is wrong, it should be >= 4.10.0 yes.
> 
> 

Thanks for details, let me do the patch.

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-20 17:22 ` [dpdk-dev] [PATCH v2] " Ferruh Yigit
  2019-11-20 17:28   ` David Marchand
@ 2019-11-28 12:13   ` " Ferruh Yigit
  2019-11-28 14:58     ` [dpdk-dev] [EXT] " Vamsi Krishna Attunuru
  1 sibling, 1 reply; 15+ messages in thread
From: Ferruh Yigit @ 2019-11-28 12:13 UTC (permalink / raw)
  To: John McNamara, Marko Kovacevic
  Cc: dev, David Marchand, Vamsi Attunuru, Kiran Kumar K, Jerin Jacob,
	Igor Ryzhov

On 11/20/2019 5:22 PM, Ferruh Yigit wrote:
> A build error reported related to the selected
> 'get_user_pages_remote()' kernel API:
> 
> .../kernel/linux/kni/kni_dev.h:113:8:
>   error: too few arguments to function ‘get_user_pages_remote’
>   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
>         ^~~~~~~~~~~~~~~~~~~~~
> 
> Currently there are three version of the 'get_user_pages_remote()'
> supported, based on kernel version
> < 4.9, = 4.9, > 4.9
> 
> These version based checks are not working fine with the distro kernels
> which is the cause of reported build error. The error reported by the
> kernel version 4.8, but it is using API defined in > 4.9.
> 
> To be able to take control of this, and possible more, related build
> error, increasing the minimum supported kernel version for iova=va with
> KNI to kernel version 4.9.
> 
> This leaves us with single version of the kernel API and more
> manageable.
> 
> Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> ---
> Cc: David Marchand <david.marchand@redhat.com>
> Cc: Vamsi Attunuru <vattunuru@marvell.com>
> Cc: Kiran Kumar K <kirankumark@marvell.com>
> Cc: Jerin Jacob <jerinj@marvell.com>
> 
> v2:
> * fixed typo in comment
> Cc: Igor Ryzhov <iryzhov@nfware.com>
> ---
>  doc/guides/prog_guide/kernel_nic_interface.rst |  2 +-
>  doc/guides/rel_notes/release_19_11.rst         |  2 +-
>  kernel/linux/kni/compat.h                      | 17 ++++++-----------
>  kernel/linux/kni/kni_dev.h                     | 10 ----------
>  lib/librte_eal/linux/eal/eal.c                 |  6 +++---
>  lib/librte_kni/rte_kni.c                       |  2 +-
>  6 files changed, 12 insertions(+), 27 deletions(-)
> 
> diff --git a/doc/guides/prog_guide/kernel_nic_interface.rst b/doc/guides/prog_guide/kernel_nic_interface.rst
> index c4479ffbf..848b00253 100644
> --- a/doc/guides/prog_guide/kernel_nic_interface.rst
> +++ b/doc/guides/prog_guide/kernel_nic_interface.rst
> @@ -305,7 +305,7 @@ IOVA = VA: Support
>  
>  KNI operates in IOVA_VA scheme when
>  
> -- LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0) and
> +- LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0) and
>  - EAL option `iova-mode=va` is passed or bus IOVA scheme in the DPDK is selected
>    as RTE_IOVA_VA.
>  
> diff --git a/doc/guides/rel_notes/release_19_11.rst b/doc/guides/rel_notes/release_19_11.rst
> index 21be600ab..45b58190c 100644
> --- a/doc/guides/rel_notes/release_19_11.rst
> +++ b/doc/guides/rel_notes/release_19_11.rst
> @@ -299,7 +299,7 @@ New Features
>    * Added IOVA = VA support for KNI, KNI can operate in IOVA = VA mode when
>      `iova-mode=va` EAL option is passed to the application or when bus IOVA
>      scheme is selected as RTE_IOVA_VA. This mode only works on Linux Kernel
> -    versions 4.6.0 and above.
> +    versions above 4.9.0.
>  
>    * Due to IOVA to KVA address translations, based on the KNI use case there
>      can be a performance impact. For mitigation, forcing IOVA to PA via EAL
> diff --git a/kernel/linux/kni/compat.h b/kernel/linux/kni/compat.h
> index 062b170ef..83ecac2d8 100644
> --- a/kernel/linux/kni/compat.h
> +++ b/kernel/linux/kni/compat.h
> @@ -122,16 +122,11 @@
>  #define HAVE_SIGNAL_FUNCTIONS_OWN_HEADER
>  #endif
>  
> -#if KERNEL_VERSION(4, 6, 0) <= LINUX_VERSION_CODE
> -
> +/*
> + * iova to kva mapping support can be provided since 4.6.0, but required
> + * kernel version increased to > 4.9.0 because of the updates in
> + * get_user_pages_remote() kernel API
> + */
> +#if KERNEL_VERSION(4, 9, 0) < LINUX_VERSION_CODE
>  #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
> -
> -#if KERNEL_VERSION(4, 9, 0) > LINUX_VERSION_CODE
> -#define GET_USER_PAGES_REMOTE_API_V1
> -#elif KERNEL_VERSION(4, 9, 0) == LINUX_VERSION_CODE
> -#define GET_USER_PAGES_REMOTE_API_V2
> -#else
> -#define GET_USER_PAGES_REMOTE_API_V3
> -#endif
> -
>  #endif
> diff --git a/kernel/linux/kni/kni_dev.h b/kernel/linux/kni/kni_dev.h
> index fb641b696..5e75c6371 100644
> --- a/kernel/linux/kni/kni_dev.h
> +++ b/kernel/linux/kni/kni_dev.h
> @@ -101,18 +101,8 @@ static inline phys_addr_t iova_to_phys(struct task_struct *tsk,
>  	offset = iova & (PAGE_SIZE - 1);
>  
>  	/* Read one page struct info */
> -#ifdef GET_USER_PAGES_REMOTE_API_V3
>  	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
>  				    FOLL_TOUCH, &page, NULL, NULL);
> -#endif
> -#ifdef GET_USER_PAGES_REMOTE_API_V2
> -	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
> -				    FOLL_TOUCH, &page, NULL);
> -#endif
> -#ifdef GET_USER_PAGES_REMOTE_API_V1
> -	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> -				    0, 0, &page, NULL);
> -#endif
>  	if (ret < 0)
>  		return 0;
>  
> diff --git a/lib/librte_eal/linux/eal/eal.c b/lib/librte_eal/linux/eal/eal.c
> index b5b71500c..5879e33e5 100644
> --- a/lib/librte_eal/linux/eal/eal.c
> +++ b/lib/librte_eal/linux/eal/eal.c
> @@ -1073,7 +1073,7 @@ rte_eal_init(int argc, char **argv)
>  				 */
>  				iova_mode = RTE_IOVA_VA;
>  				RTE_LOG(DEBUG, EAL, "Physical addresses are unavailable, selecting IOVA as VA mode.\n");
> -#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
> +#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0)
>  			} else if (rte_eal_check_module("rte_kni") == 1) {
>  				iova_mode = RTE_IOVA_PA;
>  				RTE_LOG(DEBUG, EAL, "KNI is loaded, selecting IOVA as PA mode for better KNI perfomance.\n");

Btw, since issue is revisited, I have a question about this check,

This check is to favor PA when bus mode is DC for the KNI performance concerns,
For this selection, why we need the kernel version check at all?
KNI can work in the PA mode without any specific kernel version dependency, so
why not if bus mode is DC and kni kernel module is inserted, select iova mode as
PA independent from kernel version?

^ permalink raw reply	[flat|nested] 15+ messages in thread

* Re: [dpdk-dev] [EXT] Re: [PATCH v2] kni: increase kernel version requirement for VA
  2019-11-28 12:13   ` [dpdk-dev] " Ferruh Yigit
@ 2019-11-28 14:58     ` " Vamsi Krishna Attunuru
  0 siblings, 0 replies; 15+ messages in thread
From: Vamsi Krishna Attunuru @ 2019-11-28 14:58 UTC (permalink / raw)
  To: Ferruh Yigit, John McNamara, Marko Kovacevic
  Cc: dev, David Marchand, Kiran Kumar Kokkilagadda,
	Jerin Jacob Kollanukkaran, Igor Ryzhov



> -----Original Message-----
> From: Ferruh Yigit <ferruh.yigit@intel.com>
> Sent: Thursday, November 28, 2019 5:43 PM
> To: John McNamara <john.mcnamara@intel.com>; Marko Kovacevic
> <marko.kovacevic@intel.com>
> Cc: dev@dpdk.org; David Marchand <david.marchand@redhat.com>; Vamsi
> Krishna Attunuru <vattunuru@marvell.com>; Kiran Kumar Kokkilagadda
> <kirankumark@marvell.com>; Jerin Jacob Kollanukkaran
> <jerinj@marvell.com>; Igor Ryzhov <iryzhov@nfware.com>
> Subject: [EXT] Re: [dpdk-dev] [PATCH v2] kni: increase kernel version
> requirement for VA
> 
> External Email
> 
> ----------------------------------------------------------------------
> On 11/20/2019 5:22 PM, Ferruh Yigit wrote:
> > A build error reported related to the selected
> > 'get_user_pages_remote()' kernel API:
> >
> > .../kernel/linux/kni/kni_dev.h:113:8:
> >   error: too few arguments to function ‘get_user_pages_remote’
> >   ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> >         ^~~~~~~~~~~~~~~~~~~~~
> >
> > Currently there are three version of the 'get_user_pages_remote()'
> > supported, based on kernel version
> > < 4.9, = 4.9, > 4.9
> >
> > These version based checks are not working fine with the distro
> > kernels which is the cause of reported build error. The error reported
> > by the kernel version 4.8, but it is using API defined in > 4.9.
> >
> > To be able to take control of this, and possible more, related build
> > error, increasing the minimum supported kernel version for iova=va
> > with KNI to kernel version 4.9.
> >
> > This leaves us with single version of the kernel API and more
> > manageable.
> >
> > Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
> > ---
> > Cc: David Marchand <david.marchand@redhat.com>
> > Cc: Vamsi Attunuru <vattunuru@marvell.com>
> > Cc: Kiran Kumar K <kirankumark@marvell.com>
> > Cc: Jerin Jacob <jerinj@marvell.com>
> >
> > v2:
> > * fixed typo in comment
> > Cc: Igor Ryzhov <iryzhov@nfware.com>
> > ---
> >  doc/guides/prog_guide/kernel_nic_interface.rst |  2 +-
> >  doc/guides/rel_notes/release_19_11.rst         |  2 +-
> >  kernel/linux/kni/compat.h                      | 17 ++++++-----------
> >  kernel/linux/kni/kni_dev.h                     | 10 ----------
> >  lib/librte_eal/linux/eal/eal.c                 |  6 +++---
> >  lib/librte_kni/rte_kni.c                       |  2 +-
> >  6 files changed, 12 insertions(+), 27 deletions(-)
> >
> > diff --git a/doc/guides/prog_guide/kernel_nic_interface.rst
> > b/doc/guides/prog_guide/kernel_nic_interface.rst
> > index c4479ffbf..848b00253 100644
> > --- a/doc/guides/prog_guide/kernel_nic_interface.rst
> > +++ b/doc/guides/prog_guide/kernel_nic_interface.rst
> > @@ -305,7 +305,7 @@ IOVA = VA: Support
> >
> >  KNI operates in IOVA_VA scheme when
> >
> > -- LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0) and
> > +- LINUX_VERSION_CODE > KERNEL_VERSION(4, 9, 0) and
> >  - EAL option `iova-mode=va` is passed or bus IOVA scheme in the DPDK is
> selected
> >    as RTE_IOVA_VA.
> >
> > diff --git a/doc/guides/rel_notes/release_19_11.rst
> > b/doc/guides/rel_notes/release_19_11.rst
> > index 21be600ab..45b58190c 100644
> > --- a/doc/guides/rel_notes/release_19_11.rst
> > +++ b/doc/guides/rel_notes/release_19_11.rst
> > @@ -299,7 +299,7 @@ New Features
> >    * Added IOVA = VA support for KNI, KNI can operate in IOVA = VA mode
> when
> >      `iova-mode=va` EAL option is passed to the application or when bus
> IOVA
> >      scheme is selected as RTE_IOVA_VA. This mode only works on Linux
> Kernel
> > -    versions 4.6.0 and above.
> > +    versions above 4.9.0.
> >
> >    * Due to IOVA to KVA address translations, based on the KNI use case
> there
> >      can be a performance impact. For mitigation, forcing IOVA to PA
> > via EAL diff --git a/kernel/linux/kni/compat.h
> > b/kernel/linux/kni/compat.h index 062b170ef..83ecac2d8 100644
> > --- a/kernel/linux/kni/compat.h
> > +++ b/kernel/linux/kni/compat.h
> > @@ -122,16 +122,11 @@
> >  #define HAVE_SIGNAL_FUNCTIONS_OWN_HEADER  #endif
> >
> > -#if KERNEL_VERSION(4, 6, 0) <= LINUX_VERSION_CODE
> > -
> > +/*
> > + * iova to kva mapping support can be provided since 4.6.0, but
> > +required
> > + * kernel version increased to > 4.9.0 because of the updates in
> > + * get_user_pages_remote() kernel API  */ #if KERNEL_VERSION(4, 9, 0)
> > +< LINUX_VERSION_CODE
> >  #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
> > -
> > -#if KERNEL_VERSION(4, 9, 0) > LINUX_VERSION_CODE -#define
> > GET_USER_PAGES_REMOTE_API_V1 -#elif KERNEL_VERSION(4, 9, 0) ==
> > LINUX_VERSION_CODE -#define GET_USER_PAGES_REMOTE_API_V2 -#else
> > -#define GET_USER_PAGES_REMOTE_API_V3 -#endif
> > -
> >  #endif
> > diff --git a/kernel/linux/kni/kni_dev.h b/kernel/linux/kni/kni_dev.h
> > index fb641b696..5e75c6371 100644
> > --- a/kernel/linux/kni/kni_dev.h
> > +++ b/kernel/linux/kni/kni_dev.h
> > @@ -101,18 +101,8 @@ static inline phys_addr_t iova_to_phys(struct
> task_struct *tsk,
> >  	offset = iova & (PAGE_SIZE - 1);
> >
> >  	/* Read one page struct info */
> > -#ifdef GET_USER_PAGES_REMOTE_API_V3
> >  	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
> >  				    FOLL_TOUCH, &page, NULL, NULL); -#endif
> -#ifdef
> > GET_USER_PAGES_REMOTE_API_V2
> > -	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1,
> > -				    FOLL_TOUCH, &page, NULL);
> > -#endif
> > -#ifdef GET_USER_PAGES_REMOTE_API_V1
> > -	ret = get_user_pages_remote(tsk, tsk->mm, iova, 1
> > -				    0, 0, &page, NULL);
> > -#endif
> >  	if (ret < 0)
> >  		return 0;
> >
> > diff --git a/lib/librte_eal/linux/eal/eal.c
> > b/lib/librte_eal/linux/eal/eal.c index b5b71500c..5879e33e5 100644
> > --- a/lib/librte_eal/linux/eal/eal.c
> > +++ b/lib/librte_eal/linux/eal/eal.c
> > @@ -1073,7 +1073,7 @@ rte_eal_init(int argc, char **argv)
> >  				 */
> >  				iova_mode = RTE_IOVA_VA;
> >  				RTE_LOG(DEBUG, EAL, "Physical addresses
> are unavailable,
> > selecting IOVA as VA mode.\n"); -#if defined(RTE_LIBRTE_KNI) &&
> > LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
> > +#if defined(RTE_LIBRTE_KNI) && LINUX_VERSION_CODE >
> KERNEL_VERSION(4,
> > +9, 0)
> >  			} else if (rte_eal_check_module("rte_kni") == 1) {
> >  				iova_mode = RTE_IOVA_PA;
> >  				RTE_LOG(DEBUG, EAL, "KNI is loaded,
> selecting IOVA as PA mode for
> > better KNI perfomance.\n");
> 
> Btw, since issue is revisited, I have a question about this check,
> 
> This check is to favor PA when bus mode is DC for the KNI performance
> concerns, For this selection, why we need the kernel version check at all?
> KNI can work in the PA mode without any specific kernel version
> dependency, so why not if bus mode is DC and kni kernel module is inserted,
> select iova mode as PA independent from kernel version?

Yes,  correct, kernel version check is not needed.

^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, back to index

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-11-20 16:00 [dpdk-dev] [PATCH] kni: increase kernel version requirement for VA Ferruh Yigit
2019-11-20 16:24 ` Igor Ryzhov
2019-11-20 16:26   ` Ferruh Yigit
2019-11-20 17:22 ` [dpdk-dev] [PATCH v2] " Ferruh Yigit
2019-11-20 17:28   ` David Marchand
2019-11-20 22:30     ` David Marchand
2019-11-28 10:44       ` Andrew Rybchenko
2019-11-28 10:50         ` Thomas Monjalon
2019-11-28 11:01         ` Jerin Jacob
2019-11-28 11:02         ` David Marchand
2019-11-28 11:05           ` Ferruh Yigit
2019-11-21  1:58     ` Jerin Jacob
2019-11-21  2:18       ` [dpdk-dev] [EXT] " Vamsi Krishna Attunuru
2019-11-28 12:13   ` [dpdk-dev] " Ferruh Yigit
2019-11-28 14:58     ` [dpdk-dev] [EXT] " Vamsi Krishna Attunuru

DPDK patches and discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/dev/0 dev/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 dev dev/ http://inbox.dpdk.org/dev \
		dev@dpdk.org
	public-inbox-index dev


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.dev


AGPL code for this site: git clone https://public-inbox.org/ public-inbox