From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mga04.intel.com (mga04.intel.com [192.55.52.120]) by dpdk.org (Postfix) with ESMTP id 8BF2E2C22 for ; Wed, 9 Mar 2016 01:54:26 +0100 (CET) Received: from fmsmga002.fm.intel.com ([10.253.24.26]) by fmsmga104.fm.intel.com with ESMTP; 08 Mar 2016 16:54:25 -0800 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.22,559,1449561600"; d="scan'208";a="932636921" Received: from fmsmsx104.amr.corp.intel.com ([10.18.124.202]) by fmsmga002.fm.intel.com with ESMTP; 08 Mar 2016 16:53:48 -0800 Received: from fmsmsx158.amr.corp.intel.com (10.18.116.75) by fmsmsx104.amr.corp.intel.com (10.18.124.202) with Microsoft SMTP Server (TLS) id 14.3.248.2; Tue, 8 Mar 2016 16:53:46 -0800 Received: from shsmsx104.ccr.corp.intel.com (10.239.4.70) by fmsmsx158.amr.corp.intel.com (10.18.116.75) with Microsoft SMTP Server (TLS) id 14.3.248.2; Tue, 8 Mar 2016 16:53:46 -0800 Received: from shsmsx102.ccr.corp.intel.com ([169.254.2.232]) by SHSMSX104.ccr.corp.intel.com ([169.254.5.132]) with mapi id 14.03.0248.002; Wed, 9 Mar 2016 08:53:44 +0800 From: "Lu, Wenzhuo" To: Thomas Monjalon Thread-Topic: [dpdk-dev] [PATCH v7 1/5] lib/librte_ether: change function name of tunnel port config Thread-Index: AQHRdb6HSEZhGhtjgEeRWxn0VKdpBZ9PtLUAgACYBSA= Date: Wed, 9 Mar 2016 00:53:44 +0000 Message-ID: <6A0DE07E22DDAD4C9103DF62FEBC090903439160@shsmsx102.ccr.corp.intel.com> References: <1452496044-17524-1-git-send-email-wenzhuo.lu@intel.com> <1457058915-9439-1-git-send-email-wenzhuo.lu@intel.com> <1457058915-9439-2-git-send-email-wenzhuo.lu@intel.com> <1916349.pcHeyTKjoM@xps13> In-Reply-To: <1916349.pcHeyTKjoM@xps13> Accept-Language: en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [10.239.127.40] Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable MIME-Version: 1.0 Cc: "dev@dpdk.org" Subject: Re: [dpdk-dev] [PATCH v7 1/5] lib/librte_ether: change function name of tunnel port config X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Wed, 09 Mar 2016 00:54:27 -0000 Hi Thomas, > -----Original Message----- > From: Thomas Monjalon [mailto:thomas.monjalon@6wind.com] > Sent: Wednesday, March 9, 2016 7:35 AM > To: Lu, Wenzhuo > Cc: dev@dpdk.org > Subject: Re: [dpdk-dev] [PATCH v7 1/5] lib/librte_ether: change function = name > of tunnel port config >=20 > 2016-03-04 10:35, Wenzhuo Lu: > > The names of function for tunnel port configuration are not accurate. > > They're tunnel_add/del, better change them to tunnel_port_add/del. >=20 > As a lot of ethdev API, it is really badly documented. >=20 > Please explain why this renaming and let's try to reword the > doxygen: > * Add UDP tunneling port of an Ethernet device for filtering a specific > * tunneling packet by UDP port number. As we discussed before, these APIs only change the UDP port value of the tu= nnel.=20 But according to their names, seems like they're trying to add/delete a who= le tunnel. The names don't tell us what the functions really do, so we want to change = the names. >=20 > Please what are the values of > struct rte_eth_udp_tunnel { > uint16_t udp_port; > uint8_t prot_type; > }; > When I see an API struct without any comment, I feel it must be dropped. I'm confused. I don't do anything about this structure. You want me to add= more comments for it? >=20 > By the way, it is yet another filtering API, so it must be totally rework= ed. Not quite understand. I only try to change the name. If rework needed, coul= d we do this with a new patch? >=20 > > As it may be an ABI change if change the names directly, the new > > functions are added but not remove the old ones. The old ones will be > > removed in the next release after an ABI change announcement. >=20 > Please make the announce in this patch. Sure, I'll do that. >=20 > > --- a/lib/librte_ether/rte_ethdev.h > > +++ b/lib/librte_ether/rte_ethdev.h > > @@ -3403,6 +3415,9 @@ rte_eth_dev_rss_hash_conf_get(uint8_t port_id, > > int rte_eth_dev_udp_tunnel_add(uint8_t port_id, > > struct rte_eth_udp_tunnel *tunnel_udp); >=20 > You must deprecate this one and put a comment above with something like > @see rte_eth_dev_udp_tunnel_port_add. I'll add this. Thanks. >=20 > > +int > > +rte_eth_dev_udp_tunnel_port_add(uint8_t port_id, > > + struct rte_eth_udp_tunnel *tunnel_udp); >=20 > You must move it below the doxygen comment. OK. Honestly, I'd like to act like that. But seems the style is to put the = function above the comment.(Don't know the reason.) It'll be a little strange if I do something different. > > > > /** > > * Detete UDP tunneling port configuration of Ethernet device @@ > > -3420,6 +3435,9 @@ rte_eth_dev_udp_tunnel_add(uint8_t port_id, int > > rte_eth_dev_udp_tunnel_delete(uint8_t port_id, > > struct rte_eth_udp_tunnel *tunnel_udp); > > +int > > +rte_eth_dev_udp_tunnel_port_delete(uint8_t port_id, > > + struct rte_eth_udp_tunnel *tunnel_udp); >=20 > idem >=20 > > --- a/lib/librte_ether/rte_ether_version.map > > +++ b/lib/librte_ether/rte_ether_version.map > > @@ -114,6 +114,8 @@ DPDK_2.2 { > > rte_eth_tx_queue_setup; > > rte_eth_xstats_get; > > rte_eth_xstats_reset; > > + rte_eth_dev_udp_tunnel_port_add; > > + rte_eth_dev_udp_tunnel_port_delete; > > > > local: *; > > }; >=20 > Panu already made a comment about adding a new section for 16.04. Thanks for the info. Let me follow it.