<snipped>
- printf("Error: Source or destination numa exceeds the acture numa nodes.\n"); + printf("Error: %s numa exceeds the available numa nodes.\n", + (cfg->src_numa_node >= nr_sockets) ? "Source" : "Destination");
Thank you for comments, please find my reasoning as `change is
added to address spelling issue of acture numa to available numa`
There are three cases to invoking: 1) src_numa_node >= nr_sockets 2) dst_numa_node >= nr_sockets 3) both src_numa_node and dst_numa_node >= nr_sockets
As per my testing, following scenarios are explored
1) if src-numa is incorrect, we get error message as `source is
incorrect numa`
2) if dst-numa is incorrect, we get error message as `destination is incorrect numa`
3) if both src-numa and dst-numa are incorrect, we get error as
`source is incorrect numa`, fixing source and rerunning
`destination is incorrect numa` (which is expected)
I am happy to make changes to reflect the third scenario also. But please note as shared, the real intention is to fix ` acture numa` to something meaningful.It could cover cases 1&2 in your commit, but could not cover case 3.
So I think we should keep original implement.
I humbly disagree, based on the explanation as shared above. I
can share v2 patch to address
1. acture numa
2. soruce or destination or src & destination
<snipped>