From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from out1-smtp.messagingengine.com (out1-smtp.messagingengine.com [66.111.4.25]) by dpdk.org (Postfix) with ESMTP id 8DE152BB9 for ; Thu, 8 Jun 2017 18:35:56 +0200 (CEST) Received: from compute1.internal (compute1.nyi.internal [10.202.2.41]) by mailout.nyi.internal (Postfix) with ESMTP id 05CCC20A28; Thu, 8 Jun 2017 12:35:56 -0400 (EDT) Received: from frontend1 ([10.202.2.160]) by compute1.internal (MEProxy); Thu, 08 Jun 2017 12:35:56 -0400 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=monjalon.net; h= cc:content-transfer-encoding:content-type:date:from:in-reply-to :message-id:mime-version:references:subject:to:x-me-sender :x-me-sender:x-sasl-enc:x-sasl-enc; s=mesmtp; bh=PaMkBcBCe39CX5f HjKZcIMxg8izoGWb5SZ9UH/F1qiU=; b=B+Pdg8LMxy3p41SAS9vQegzVFdV1MU8 Lr/4jb3iAH4IzoJ0f+kIqER2eoaL+wmdmaguuxTEw2nDIz/yK90FyyAq19r6A9eK mYbAeI2b4E56W85E8zL3FdXjhKyPJ3Du+7ou6el00xdd2q0aYvoYCPcaGWR2rmj1 G2INzlb0x4TU= DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d= messagingengine.com; h=cc:content-transfer-encoding:content-type :date:from:in-reply-to:message-id:mime-version:references :subject:to:x-me-sender:x-me-sender:x-sasl-enc:x-sasl-enc; s= fm1; bh=PaMkBcBCe39CX5fHjKZcIMxg8izoGWb5SZ9UH/F1qiU=; b=Wz0s2r+V t+0vCoruBcDQykvvCKYohTeE6XKmWpGrnDdX8rEktLtn43Mqjcktr4l3ps9K/58m xKuX/NXDGEpb/i17zBIbpJo8f+UbLA4rFg1FkmEhsc/wmSSHHbeTIF3r3XlXn3F6 W/8aqcE9O6Z0pQmypTzt5oCNFQB5jygGfFDIELHNPyxOBlOrjdbIiQdBI8jp/6xq jD+S8SItMGFu6r54Q0b2eNmXBlZDdkf7Ru7hnlQsX92P4PcGKYrKvaOg1XF/HDg2 6bYdqWK3gZpEWST46WcnbHet3V0zTI36H6sZfTw91vNttK+fD6ucxeMQwAB/w64f wlMyYzMIjmSpWg== X-ME-Sender: X-Sasl-enc: XI/00J+JGIdslg4LIpfMEkSSGaz2EgzIwyebfah0d4Ya 1496939755 Received: from xps.localnet (184.203.134.77.rev.sfr.net [77.134.203.184]) by mail.messagingengine.com (Postfix) with ESMTPA id A21917E800; Thu, 8 Jun 2017 12:35:55 -0400 (EDT) From: Thomas Monjalon To: Adrien Mazarguil Cc: dev@dpdk.org Date: Thu, 08 Jun 2017 18:35:54 +0200 Message-ID: <7271414.7fXyP8HQPW@xps> In-Reply-To: <20170608091416.GU1758@6wind.com> References: <840342851720fc237214aeb30d38565615293b58.1495101988.git.adrien.mazarguil@6wind.com> <44029570.D8ug5AmCbY@xps> <20170608091416.GU1758@6wind.com> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" Subject: Re: [dpdk-dev] [PATCH 1/2] eal: add static endianness conversion macros X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 08 Jun 2017 16:35:56 -0000 08/06/2017 11:14, Adrien Mazarguil: > On Wed, Jun 07, 2017 at 04:16:58PM +0200, Thomas Monjalon wrote: > > Hi, some comments below: > > > > 18/05/2017 12:14, Adrien Mazarguil: > > > +#define RTE_STATIC_BSWAP64(v) \ > > > + ((((uint64_t)(v) & UINT64_C(0x00000000000000ff)) << 56) | \ > > > + (((uint64_t)(v) & UINT64_C(0x000000000000ff00)) << 40) | \ > > > + (((uint64_t)(v) & UINT64_C(0x0000000000ff0000)) << 24) | \ > > > + (((uint64_t)(v) & UINT64_C(0x00000000ff000000)) << 8) | \ > > > + (((uint64_t)(v) & UINT64_C(0x000000ff00000000)) >> 8) | \ > > > + (((uint64_t)(v) & UINT64_C(0x0000ff0000000000)) >> 24) | \ > > > + (((uint64_t)(v) & UINT64_C(0x00ff000000000000)) >> 40) | \ > > > + (((uint64_t)(v) & UINT64_C(0xff00000000000000)) >> 56)) > > > > Minor nit: you could align lines by inserting a space before 8. > > I think alignment attempts past the mandatory line indentation often end up > in a failure (e.g. when grouping macros by name, one of them inevitably > happens to be longer than initially envisioned, same for structure fields > and trailing comment blocks, etc.) Since I'm not convinced it improves > readability, I tend to avoid them altogether for consistency. I agree Here it is just adding a space in front of the single digit to make bits numbers aligned on 2 digits :) > It's a matter of style but I can change that if you prefer. > > > > +#if RTE_BYTE_ORDER == RTE_BIG_ENDIAN > > > +#define RTE_BE16(v) (uint16_t)(v) > > > +#define RTE_BE32(v) (uint32_t)(v) > > > +#define RTE_BE64(v) (uint64_t)(v) > > > +#define RTE_LE16(v) RTE_STATIC_BSWAP16(v) > > > +#define RTE_LE32(v) RTE_STATIC_BSWAP32(v) > > > +#define RTE_LE64(v) RTE_STATIC_BSWAP64(v) > > > +#elif RTE_BYTE_ORDER == RTE_LITTLE_ENDIAN > > > +#define RTE_BE16(v) RTE_STATIC_BSWAP16(v) > > > +#define RTE_BE32(v) RTE_STATIC_BSWAP32(v) > > > +#define RTE_BE64(v) RTE_STATIC_BSWAP64(v) > > > +#define RTE_LE16(v) (uint16_t)(v) > > > +#define RTE_LE32(v) (uint32_t)(v) > > > +#define RTE_LE64(v) (uint64_t)(v) > > > > This naming is confusing. > > Let's take RTE_BE16() as example, it does not say wether the input value > > is big endian or the output value will be big endian. > > I think we should mimic the wording of run-time conversions: > > RTE_BE_TO_CPU_16() > > > > Any other ideas? > > First I'd like to keep those macro names as short as possible, ideally not > much larger than simply casting the provided value to the target type for > usability and readability purposes. Think about files full of static > initializers, while there are not many examples right now, the definition of > static rte_flow rules and capability trees will need to use these macros > extensively. > > The fact you suggested RTE_BE_TO_CPU_16() instead of RTE_CPU_TO_BE_16() as a > replacement for RTE_BE16() highlights the misunderstanding. However I find > "CPU_TO" overly verbose, particularly since the reverse macros won't exist, > remember these are made for static conversions of integer constants resolved > at compilation time, not variables. Users may additionally confuse > RTE_CPU_TO_BE_16() with its similarly-named inline function counterpart. You're right. RTE_BE_TO_CPU_16 does not make sense. I think you could add a comment like that: RTE_XE_NN is equivalent to rte_cpu_to_Xe_NN run-time conversion > Functions and macros are typically named after their output, not their > input. In that sense and without further precision, RTE_BE16() is fine in my > opinion. Good point. > Remember this [1]? I think we could make everything clearer by perhaps > applying it and casting the results of these macros to the proper type, > e.g.: > > #define RTE_BE16(v) (rte_be16_t)(v) > > I can probably modify this series to introduce the new types first, use them > in the conversion macro and then later clarify existing structure > fields. How about this? Yes good idea.