DPDK patches and discussions
 help / color / Atom feed
* [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
@ 2020-10-26 21:46 Ajit Khaparde
  2020-11-03 10:50 ` Kevin Traynor
  2020-11-24 15:34 ` Ferruh Yigit
  0 siblings, 2 replies; 12+ messages in thread
From: Ajit Khaparde @ 2020-10-26 21:46 UTC (permalink / raw)
  To: dev

Devices belonging to BCM573xx and BCM5740x family will not be supported
from the 21.02 release.

Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
---
 doc/guides/rel_notes/deprecation.rst | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
index 2e082499b8..f1fce4210d 100644
--- a/doc/guides/rel_notes/deprecation.rst
+++ b/doc/guides/rel_notes/deprecation.rst
@@ -166,3 +166,9 @@ Deprecation Notices
   ``make``. Given environments are too much variables for such a simple script,
   it will be removed in DPDK 20.11.
   Some useful parts may be converted into specific scripts.
+
+* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
+  BCM5740x`` families will no longer be supported as of DPDK 21.02.
+  Specifically the support for the following Broadcom PCI ids will be removed
+  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
+  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
-- 
2.21.1 (Apple Git-122.3)


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-10-26 21:46 [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices Ajit Khaparde
@ 2020-11-03 10:50 ` Kevin Traynor
  2020-11-03 17:26   ` Ajit Khaparde
  2020-11-24 15:34 ` Ferruh Yigit
  1 sibling, 1 reply; 12+ messages in thread
From: Kevin Traynor @ 2020-11-03 10:50 UTC (permalink / raw)
  To: Ajit Khaparde, dev

Hi Ajit,

On 26/10/2020 21:46, Ajit Khaparde wrote:
> Devices belonging to BCM573xx and BCM5740x family will not be supported
> from the 21.02 release.
> 
> Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> ---
>  doc/guides/rel_notes/deprecation.rst | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> index 2e082499b8..f1fce4210d 100644
> --- a/doc/guides/rel_notes/deprecation.rst
> +++ b/doc/guides/rel_notes/deprecation.rst
> @@ -166,3 +166,9 @@ Deprecation Notices
>    ``make``. Given environments are too much variables for such a simple script,
>    it will be removed in DPDK 20.11.
>    Some useful parts may be converted into specific scripts.
> +
> +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> +  Specifically the support for the following Broadcom PCI ids will be removed
> +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> 

It might be worth adding to the bnxt.rst section about these NICs, as
there is no hint that they are deprecated for a user reading that.

Where I'm not clear is about 20.11. It will be an LTS, will they be
supported for the lifetime of 20.11 on the 20.11 branch?

Kevin.


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-03 10:50 ` Kevin Traynor
@ 2020-11-03 17:26   ` Ajit Khaparde
  2020-11-06 19:22     ` Kevin Traynor
  0 siblings, 1 reply; 12+ messages in thread
From: Ajit Khaparde @ 2020-11-03 17:26 UTC (permalink / raw)
  To: Kevin Traynor; +Cc: dpdk-dev

On Tue, Nov 3, 2020 at 2:50 AM Kevin Traynor <ktraynor@redhat.com> wrote:
>
> Hi Ajit,
>
> On 26/10/2020 21:46, Ajit Khaparde wrote:
> > Devices belonging to BCM573xx and BCM5740x family will not be supported
> > from the 21.02 release.
> >
> > Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> > ---
> >  doc/guides/rel_notes/deprecation.rst | 6 ++++++
> >  1 file changed, 6 insertions(+)
> >
> > diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> > index 2e082499b8..f1fce4210d 100644
> > --- a/doc/guides/rel_notes/deprecation.rst
> > +++ b/doc/guides/rel_notes/deprecation.rst
> > @@ -166,3 +166,9 @@ Deprecation Notices
> >    ``make``. Given environments are too much variables for such a simple script,
> >    it will be removed in DPDK 20.11.
> >    Some useful parts may be converted into specific scripts.
> > +
> > +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> > +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> > +  Specifically the support for the following Broadcom PCI ids will be removed
> > +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> > +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> >
>
> It might be worth adding to the bnxt.rst section about these NICs, as
> there is no hint that they are deprecated for a user reading that.
Thanks Kevin.
I will add that when the support is really removed.

Since the deprecation is not really planned for 20.11 I think it is not really
needed for now?

>
> Where I'm not clear is about 20.11. It will be an LTS, will they be
> supported for the lifetime of 20.11 on the 20.11 branch?
20.11 will have the support. The deprecation is planned for 21.02.

Thanks
Ajit

>
> Kevin.
>

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-03 17:26   ` Ajit Khaparde
@ 2020-11-06 19:22     ` Kevin Traynor
  2020-11-06 20:59       ` Ajit Khaparde
  0 siblings, 1 reply; 12+ messages in thread
From: Kevin Traynor @ 2020-11-06 19:22 UTC (permalink / raw)
  To: Ajit Khaparde; +Cc: dpdk-dev

On 03/11/2020 17:26, Ajit Khaparde wrote:
> On Tue, Nov 3, 2020 at 2:50 AM Kevin Traynor <ktraynor@redhat.com> wrote:
>>
>> Hi Ajit,
>>
>> On 26/10/2020 21:46, Ajit Khaparde wrote:
>>> Devices belonging to BCM573xx and BCM5740x family will not be supported
>>> from the 21.02 release.
>>>
>>> Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
>>> ---
>>>  doc/guides/rel_notes/deprecation.rst | 6 ++++++
>>>  1 file changed, 6 insertions(+)
>>>
>>> diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
>>> index 2e082499b8..f1fce4210d 100644
>>> --- a/doc/guides/rel_notes/deprecation.rst
>>> +++ b/doc/guides/rel_notes/deprecation.rst
>>> @@ -166,3 +166,9 @@ Deprecation Notices
>>>    ``make``. Given environments are too much variables for such a simple script,
>>>    it will be removed in DPDK 20.11.
>>>    Some useful parts may be converted into specific scripts.
>>> +
>>> +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
>>> +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
>>> +  Specifically the support for the following Broadcom PCI ids will be removed
>>> +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
>>> +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
>>>
>>
>> It might be worth adding to the bnxt.rst section about these NICs, as
>> there is no hint that they are deprecated for a user reading that.
> Thanks Kevin.
> I will add that when the support is really removed.
> 
> Since the deprecation is not really planned for 20.11 I think it is not really
> needed for now?
> 

Ok, it's the correct section for it, so I won't argue.

>>
>> Where I'm not clear is about 20.11. It will be an LTS, will they be
>> supported for the lifetime of 20.11 on the 20.11 branch?
> 20.11 will have the support. The deprecation is planned for 21.02.
> 

Right, I'm just concerned about it getting broken in say 20.11.2 because
of backports to the driver. Once it's in 20.11, it should continue to
work in 20.11.x releases which will be for 2 years.

Anyway, that is a side issue to this patch for deprecation, so,

Acked-by: Kevin Traynor <ktraynor@redhat.com>

> Thanks
> Ajit
> 
>>
>> Kevin.
>>


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-06 19:22     ` Kevin Traynor
@ 2020-11-06 20:59       ` Ajit Khaparde
  2020-11-20 17:30         ` Ajit Khaparde
  0 siblings, 1 reply; 12+ messages in thread
From: Ajit Khaparde @ 2020-11-06 20:59 UTC (permalink / raw)
  To: Kevin Traynor; +Cc: dpdk-dev

On Fri, Nov 6, 2020 at 11:22 AM Kevin Traynor <ktraynor@redhat.com> wrote:

> On 03/11/2020 17:26, Ajit Khaparde wrote:
> > On Tue, Nov 3, 2020 at 2:50 AM Kevin Traynor <ktraynor@redhat.com>
> wrote:
> >>
> >> Hi Ajit,
> >>
> >> On 26/10/2020 21:46, Ajit Khaparde wrote:
> >>> Devices belonging to BCM573xx and BCM5740x family will not be supported
> >>> from the 21.02 release.
> >>>
> >>> Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> >>> ---
> >>>  doc/guides/rel_notes/deprecation.rst | 6 ++++++
> >>>  1 file changed, 6 insertions(+)
> >>>
> >>> diff --git a/doc/guides/rel_notes/deprecation.rst
> b/doc/guides/rel_notes/deprecation.rst
> >>> index 2e082499b8..f1fce4210d 100644
> >>> --- a/doc/guides/rel_notes/deprecation.rst
> >>> +++ b/doc/guides/rel_notes/deprecation.rst
> >>> @@ -166,3 +166,9 @@ Deprecation Notices
> >>>    ``make``. Given environments are too much variables for such a
> simple script,
> >>>    it will be removed in DPDK 20.11.
> >>>    Some useful parts may be converted into specific scripts.
> >>> +
> >>> +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> >>> +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> >>> +  Specifically the support for the following Broadcom PCI ids will be
> removed
> >>> +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf,
> 0x16df,``
> >>> +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> >>>
> >>
> >> It might be worth adding to the bnxt.rst section about these NICs, as
> >> there is no hint that they are deprecated for a user reading that.
> > Thanks Kevin.
> > I will add that when the support is really removed.
> >
> > Since the deprecation is not really planned for 20.11 I think it is not
> really
> > needed for now?
> >
>
> Ok, it's the correct section for it, so I won't argue.
>
> >>
> >> Where I'm not clear is about 20.11. It will be an LTS, will they be
> >> supported for the lifetime of 20.11 on the 20.11 branch?
> > 20.11 will have the support. The deprecation is planned for 21.02.
> >
>
> Right, I'm just concerned about it getting broken in say 20.11.2 because
> of backports to the driver. Once it's in 20.11, it should continue to
> work in 20.11.x releases which will be for 2 years.
>
Yes. Thanks. We will keep the lights on for the LTS releases.


>
> Anyway, that is a side issue to this patch for deprecation, so,
>
> Acked-by: Kevin Traynor <ktraynor@redhat.com>
>
> > Thanks
> > Ajit
> >
> >>
> >> Kevin.
> >>
>
>

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-06 20:59       ` Ajit Khaparde
@ 2020-11-20 17:30         ` Ajit Khaparde
  2020-11-22 20:15           ` Thomas Monjalon
  0 siblings, 1 reply; 12+ messages in thread
From: Ajit Khaparde @ 2020-11-20 17:30 UTC (permalink / raw)
  To: Thomas Monjalon; +Cc: dpdk-dev

On Fri, Nov 6, 2020 at 12:59 PM Ajit Khaparde
<ajit.khaparde@broadcom.com> wrote:
>
>
>
> On Fri, Nov 6, 2020 at 11:22 AM Kevin Traynor <ktraynor@redhat.com> wrote:
>>
>> On 03/11/2020 17:26, Ajit Khaparde wrote:
>> > On Tue, Nov 3, 2020 at 2:50 AM Kevin Traynor <ktraynor@redhat.com> wrote:
>> >>
>> >> Hi Ajit,
>> >>
>> >> On 26/10/2020 21:46, Ajit Khaparde wrote:
>> >>> Devices belonging to BCM573xx and BCM5740x family will not be supported
>> >>> from the 21.02 release.
>> >>>
>> >>> Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
>> >>> ---
>> >>>  doc/guides/rel_notes/deprecation.rst | 6 ++++++
>> >>>  1 file changed, 6 insertions(+)
>> >>>
>> >>> diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
>> >>> index 2e082499b8..f1fce4210d 100644
>> >>> --- a/doc/guides/rel_notes/deprecation.rst
>> >>> +++ b/doc/guides/rel_notes/deprecation.rst
>> >>> @@ -166,3 +166,9 @@ Deprecation Notices
>> >>>    ``make``. Given environments are too much variables for such a simple script,
>> >>>    it will be removed in DPDK 20.11.
>> >>>    Some useful parts may be converted into specific scripts.
>> >>> +
>> >>> +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
>> >>> +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
>> >>> +  Specifically the support for the following Broadcom PCI ids will be removed
>> >>> +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
>> >>> +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
>> >>>
>> >>
>> >> It might be worth adding to the bnxt.rst section about these NICs, as
>> >> there is no hint that they are deprecated for a user reading that.
>> > Thanks Kevin.
>> > I will add that when the support is really removed.
>> >
>> > Since the deprecation is not really planned for 20.11 I think it is not really
>> > needed for now?
>> >
>>
>> Ok, it's the correct section for it, so I won't argue.
>>
>> >>
>> >> Where I'm not clear is about 20.11. It will be an LTS, will they be
>> >> supported for the lifetime of 20.11 on the 20.11 branch?
>> > 20.11 will have the support. The deprecation is planned for 21.02.
>> >
>>
>> Right, I'm just concerned about it getting broken in say 20.11.2 because
>> of backports to the driver. Once it's in 20.11, it should continue to
>> work in 20.11.x releases which will be for 2 years.
>
> Yes. Thanks. We will keep the lights on for the LTS releases.
>
>>
>>
>> Anyway, that is a side issue to this patch for deprecation, so,
>>
>> Acked-by: Kevin Traynor <ktraynor@redhat.com>

Thomas, Can you please pick this? Thanks

>>
>> > Thanks
>> > Ajit
>> >
>> >>
>> >> Kevin.
>> >>
>>

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-20 17:30         ` Ajit Khaparde
@ 2020-11-22 20:15           ` Thomas Monjalon
  2020-11-23 14:56             ` Ajit Khaparde
  0 siblings, 1 reply; 12+ messages in thread
From: Thomas Monjalon @ 2020-11-22 20:15 UTC (permalink / raw)
  To: Ajit Khaparde
  Cc: dev, bruce.richardson, ferruh.yigit, jerinj, hemant.agrawal,
	david.marchand, honnappa.nagarahalli, ktraynor

20/11/2020 18:30, Ajit Khaparde:
> On Fri, Nov 6, 2020 at 12:59 PM Ajit Khaparde
> <ajit.khaparde@broadcom.com> wrote:
> >
> >
> >
> > On Fri, Nov 6, 2020 at 11:22 AM Kevin Traynor <ktraynor@redhat.com> wrote:
> >>
> >> On 03/11/2020 17:26, Ajit Khaparde wrote:
> >> > On Tue, Nov 3, 2020 at 2:50 AM Kevin Traynor <ktraynor@redhat.com> wrote:
> >> >>
> >> >> Hi Ajit,
> >> >>
> >> >> On 26/10/2020 21:46, Ajit Khaparde wrote:
> >> >>> Devices belonging to BCM573xx and BCM5740x family will not be supported
> >> >>> from the 21.02 release.
> >> >>>
> >> >>> Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> >> >>> ---
> >> >>>  doc/guides/rel_notes/deprecation.rst | 6 ++++++
> >> >>>  1 file changed, 6 insertions(+)
> >> >>>
> >> >>> diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> >> >>> index 2e082499b8..f1fce4210d 100644
> >> >>> --- a/doc/guides/rel_notes/deprecation.rst
> >> >>> +++ b/doc/guides/rel_notes/deprecation.rst
> >> >>> @@ -166,3 +166,9 @@ Deprecation Notices
> >> >>>    ``make``. Given environments are too much variables for such a simple script,
> >> >>>    it will be removed in DPDK 20.11.
> >> >>>    Some useful parts may be converted into specific scripts.
> >> >>> +
> >> >>> +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> >> >>> +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> >> >>> +  Specifically the support for the following Broadcom PCI ids will be removed
> >> >>> +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> >> >>> +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> >> >>>
> >> >>
> >> >> It might be worth adding to the bnxt.rst section about these NICs, as
> >> >> there is no hint that they are deprecated for a user reading that.
> >> > Thanks Kevin.
> >> > I will add that when the support is really removed.
> >> >
> >> > Since the deprecation is not really planned for 20.11 I think it is not really
> >> > needed for now?
> >> >
> >>
> >> Ok, it's the correct section for it, so I won't argue.
> >>
> >> >>
> >> >> Where I'm not clear is about 20.11. It will be an LTS, will they be
> >> >> supported for the lifetime of 20.11 on the 20.11 branch?
> >> > 20.11 will have the support. The deprecation is planned for 21.02.
> >> >
> >>
> >> Right, I'm just concerned about it getting broken in say 20.11.2 because
> >> of backports to the driver. Once it's in 20.11, it should continue to
> >> work in 20.11.x releases which will be for 2 years.
> >
> > Yes. Thanks. We will keep the lights on for the LTS releases.
> >
> >>
> >>
> >> Anyway, that is a side issue to this patch for deprecation, so,
> >>
> >> Acked-by: Kevin Traynor <ktraynor@redhat.com>
> 
> Thomas, Can you please pick this? Thanks

Usually we wait for 3 acks for deprecation.
It has been discussed in the techboard, so I prefer getting some acks
reflecting the discussion, please.



^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-22 20:15           ` Thomas Monjalon
@ 2020-11-23 14:56             ` Ajit Khaparde
  0 siblings, 0 replies; 12+ messages in thread
From: Ajit Khaparde @ 2020-11-23 14:56 UTC (permalink / raw)
  To: Thomas Monjalon
  Cc: dpdk-dev, Bruce Richardson, Ferruh Yigit,
	Jerin Jacob Kollanukkaran, Hemant Agrawal, David Marchand,
	Honnappa Nagarahalli, Kevin Traynor

On Sun, Nov 22, 2020 at 12:15 PM Thomas Monjalon <thomas@monjalon.net> wrote:
>
> 20/11/2020 18:30, Ajit Khaparde:
> > On Fri, Nov 6, 2020 at 12:59 PM Ajit Khaparde
> > <ajit.khaparde@broadcom.com> wrote:
> > >
> > >
> > >
> > > On Fri, Nov 6, 2020 at 11:22 AM Kevin Traynor <ktraynor@redhat.com> wrote:
> > >>
> > >> On 03/11/2020 17:26, Ajit Khaparde wrote:
> > >> > On Tue, Nov 3, 2020 at 2:50 AM Kevin Traynor <ktraynor@redhat.com> wrote:
> > >> >>
> > >> >> Hi Ajit,
> > >> >>
> > >> >> On 26/10/2020 21:46, Ajit Khaparde wrote:
> > >> >>> Devices belonging to BCM573xx and BCM5740x family will not be supported
> > >> >>> from the 21.02 release.
> > >> >>>
> > >> >>> Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> > >> >>> ---
> > >> >>>  doc/guides/rel_notes/deprecation.rst | 6 ++++++
> > >> >>>  1 file changed, 6 insertions(+)
> > >> >>>
> > >> >>> diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> > >> >>> index 2e082499b8..f1fce4210d 100644
> > >> >>> --- a/doc/guides/rel_notes/deprecation.rst
> > >> >>> +++ b/doc/guides/rel_notes/deprecation.rst
> > >> >>> @@ -166,3 +166,9 @@ Deprecation Notices
> > >> >>>    ``make``. Given environments are too much variables for such a simple script,
> > >> >>>    it will be removed in DPDK 20.11.
> > >> >>>    Some useful parts may be converted into specific scripts.
> > >> >>> +
> > >> >>> +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> > >> >>> +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> > >> >>> +  Specifically the support for the following Broadcom PCI ids will be removed
> > >> >>> +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> > >> >>> +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> > >> >>>
> > >> >>
> > >> >> It might be worth adding to the bnxt.rst section about these NICs, as
> > >> >> there is no hint that they are deprecated for a user reading that.
> > >> > Thanks Kevin.
> > >> > I will add that when the support is really removed.
> > >> >
> > >> > Since the deprecation is not really planned for 20.11 I think it is not really
> > >> > needed for now?
> > >> >
> > >>
> > >> Ok, it's the correct section for it, so I won't argue.
> > >>
> > >> >>
> > >> >> Where I'm not clear is about 20.11. It will be an LTS, will they be
> > >> >> supported for the lifetime of 20.11 on the 20.11 branch?
> > >> > 20.11 will have the support. The deprecation is planned for 21.02.
> > >> >
> > >>
> > >> Right, I'm just concerned about it getting broken in say 20.11.2 because
> > >> of backports to the driver. Once it's in 20.11, it should continue to
> > >> work in 20.11.x releases which will be for 2 years.
> > >
> > > Yes. Thanks. We will keep the lights on for the LTS releases.
> > >
> > >>
> > >>
> > >> Anyway, that is a side issue to this patch for deprecation, so,
> > >>
> > >> Acked-by: Kevin Traynor <ktraynor@redhat.com>
> >
> > Thomas, Can you please pick this? Thanks
>
> Usually we wait for 3 acks for deprecation.
> It has been discussed in the techboard, so I prefer getting some acks
> reflecting the discussion, please.
Ok. Thanks.
All, It will be good to get the Acks before the 20.11 release.

>
>

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-10-26 21:46 [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices Ajit Khaparde
  2020-11-03 10:50 ` Kevin Traynor
@ 2020-11-24 15:34 ` Ferruh Yigit
  2020-11-25  8:48   ` Jerin Jacob
  1 sibling, 1 reply; 12+ messages in thread
From: Ferruh Yigit @ 2020-11-24 15:34 UTC (permalink / raw)
  To: Ajit Khaparde, dev

On 10/26/2020 9:46 PM, Ajit Khaparde wrote:
> Devices belonging to BCM573xx and BCM5740x family will not be supported
> from the 21.02 release.
> 
> Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> ---
>   doc/guides/rel_notes/deprecation.rst | 6 ++++++
>   1 file changed, 6 insertions(+)
> 
> diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> index 2e082499b8..f1fce4210d 100644
> --- a/doc/guides/rel_notes/deprecation.rst
> +++ b/doc/guides/rel_notes/deprecation.rst
> @@ -166,3 +166,9 @@ Deprecation Notices
>     ``make``. Given environments are too much variables for such a simple script,
>     it will be removed in DPDK 20.11.
>     Some useful parts may be converted into specific scripts.
> +
> +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> +  Specifically the support for the following Broadcom PCI ids will be removed
> +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> 

Reviewed-by: Ferruh Yigit <ferruh.yigit@intel.com>

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-24 15:34 ` Ferruh Yigit
@ 2020-11-25  8:48   ` Jerin Jacob
  2020-11-26 11:31     ` Bruce Richardson
  0 siblings, 1 reply; 12+ messages in thread
From: Jerin Jacob @ 2020-11-25  8:48 UTC (permalink / raw)
  To: Ferruh Yigit; +Cc: Ajit Khaparde, dpdk-dev

On Tue, Nov 24, 2020 at 9:04 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
>
> On 10/26/2020 9:46 PM, Ajit Khaparde wrote:
> > Devices belonging to BCM573xx and BCM5740x family will not be supported
> > from the 21.02 release.
> >
> > Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> > ---
> >   doc/guides/rel_notes/deprecation.rst | 6 ++++++
> >   1 file changed, 6 insertions(+)
> >
> > diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> > index 2e082499b8..f1fce4210d 100644
> > --- a/doc/guides/rel_notes/deprecation.rst
> > +++ b/doc/guides/rel_notes/deprecation.rst
> > @@ -166,3 +166,9 @@ Deprecation Notices
> >     ``make``. Given environments are too much variables for such a simple script,
> >     it will be removed in DPDK 20.11.
> >     Some useful parts may be converted into specific scripts.
> > +
> > +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> > +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> > +  Specifically the support for the following Broadcom PCI ids will be removed
> > +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> > +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> >
>
> Reviewed-by: Ferruh Yigit <ferruh.yigit@intel.com>

Acked-by: Jerin Jacob <jerinj@marvell.com>

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-25  8:48   ` Jerin Jacob
@ 2020-11-26 11:31     ` Bruce Richardson
  2020-11-26 16:52       ` Thomas Monjalon
  0 siblings, 1 reply; 12+ messages in thread
From: Bruce Richardson @ 2020-11-26 11:31 UTC (permalink / raw)
  To: Jerin Jacob; +Cc: Ferruh Yigit, Ajit Khaparde, dpdk-dev

On Wed, Nov 25, 2020 at 02:18:43PM +0530, Jerin Jacob wrote:
> On Tue, Nov 24, 2020 at 9:04 PM Ferruh Yigit <ferruh.yigit@intel.com> wrote:
> >
> > On 10/26/2020 9:46 PM, Ajit Khaparde wrote:
> > > Devices belonging to BCM573xx and BCM5740x family will not be supported
> > > from the 21.02 release.
> > >
> > > Signed-off-by: Ajit Khaparde <ajit.khaparde@broadcom.com>
> > > ---
> > >   doc/guides/rel_notes/deprecation.rst | 6 ++++++
> > >   1 file changed, 6 insertions(+)
> > >
> > > diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> > > index 2e082499b8..f1fce4210d 100644
> > > --- a/doc/guides/rel_notes/deprecation.rst
> > > +++ b/doc/guides/rel_notes/deprecation.rst
> > > @@ -166,3 +166,9 @@ Deprecation Notices
> > >     ``make``. Given environments are too much variables for such a simple script,
> > >     it will be removed in DPDK 20.11.
> > >     Some useful parts may be converted into specific scripts.
> > > +
> > > +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> > > +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> > > +  Specifically the support for the following Broadcom PCI ids will be removed
> > > +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> > > +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> > >
> >
> > Reviewed-by: Ferruh Yigit <ferruh.yigit@intel.com>
> 
> Acked-by: Jerin Jacob <jerinj@marvell.com>

Acked-by: Bruce Richardson <bruce.richardson@intel.com>

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices
  2020-11-26 11:31     ` Bruce Richardson
@ 2020-11-26 16:52       ` Thomas Monjalon
  0 siblings, 0 replies; 12+ messages in thread
From: Thomas Monjalon @ 2020-11-26 16:52 UTC (permalink / raw)
  To: Ajit Khaparde; +Cc: Jerin Jacob, dev, Ferruh Yigit, Bruce Richardson

> > > > +* Broadcom bnxt PMD: NetXtreme devices belonging to the ``BCM573xx and
> > > > +  BCM5740x`` families will no longer be supported as of DPDK 21.02.
> > > > +  Specifically the support for the following Broadcom PCI ids will be removed
> > > > +  from the release: ``0x16c8, 0x16c9, 0x16ca, 0x16ce, 0x16cf, 0x16df,``
> > > > +  ``0x16d0, 0x16d1, 0x16d2, 0x16d4, 0x16d5, 0x16e7, 0x16e8, 0x16e9``.
> > > >
> > >
> > > Reviewed-by: Ferruh Yigit <ferruh.yigit@intel.com>
> > 
> > Acked-by: Jerin Jacob <jerinj@marvell.com>
> 
> Acked-by: Bruce Richardson <bruce.richardson@intel.com>

Applied, thanks.



^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, back to index

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-26 21:46 [dpdk-dev] [PATCH] doc: announce end of support for some Broadcom devices Ajit Khaparde
2020-11-03 10:50 ` Kevin Traynor
2020-11-03 17:26   ` Ajit Khaparde
2020-11-06 19:22     ` Kevin Traynor
2020-11-06 20:59       ` Ajit Khaparde
2020-11-20 17:30         ` Ajit Khaparde
2020-11-22 20:15           ` Thomas Monjalon
2020-11-23 14:56             ` Ajit Khaparde
2020-11-24 15:34 ` Ferruh Yigit
2020-11-25  8:48   ` Jerin Jacob
2020-11-26 11:31     ` Bruce Richardson
2020-11-26 16:52       ` Thomas Monjalon

DPDK patches and discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/dev/0 dev/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 dev dev/ http://inbox.dpdk.org/dev \
		dev@dpdk.org
	public-inbox-index dev


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.dev


AGPL code for this site: git clone https://public-inbox.org/ public-inbox