DPDK patches and discussions
 help / color / mirror / Atom feed
* [Bug 1009] [dpdk-22.07*] drivers/crypto/qat meson build failed with gcc 11.2.0 on Ub22.04/64
@ 2022-05-13  8:58 bugzilla
  0 siblings, 0 replies; only message in thread
From: bugzilla @ 2022-05-13  8:58 UTC (permalink / raw)
  To: dev

https://bugs.dpdk.org/show_bug.cgi?id=1009

            Bug ID: 1009
           Summary: [dpdk-22.07*] drivers/crypto/qat meson build failed
                    with gcc 11.2.0 on Ub22.04/64
           Product: DPDK
           Version: unspecified
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: Normal
         Component: core
          Assignee: dev@dpdk.org
          Reporter: daxuex.gao@intel.com
  Target Milestone: ---

[DPDK Version]
dpdk latest code dpdk-next-* and dpdk branch  

[OS version]
Ubuntu22.04 LTS/(5.17.5-051705-generic/5.15.0-25-generic)
GCC 11.2.0

[Test Setup]
# meson --werror -Denable_kmods=True -Dlibdir=lib -Dexamples=all
--default-library=static gcc-linux-app 
# ninja -C gcc-linux-app

[log]
FAILED: drivers/libtmp_rte_common_qat.a.p/crypto_qat_qat_sym_session.c.o 
clang -Idrivers/libtmp_rte_common_qat.a.p -Idrivers -I../drivers
-Idrivers/common/qat -I../drivers/common/qat -I../drivers/common/qat/qat_adf
-I../drivers/crypto/qat -I../drivers/compress/qat -Idrivers/bus/pci
-I../drivers/bus/pci -I../drivers/bus/pci/linux -I. -I.. -Iconfig -I../config
-Ilib/eal/include -I../lib/eal/include -Ilib/eal/linux/include
-I../lib/eal/linux/include -Ilib/eal/x86/include -I../lib/eal/x86/include
-Ilib/eal/common -I../lib/eal/common -Ilib/eal -I../lib/eal -Ilib/kvargs
-I../lib/kvargs -Ilib/metrics -I../lib/metrics -Ilib/telemetry
-I../lib/telemetry -Ilib/pci -I../lib/pci -Ilib/cryptodev -I../lib/cryptodev
-Ilib/mbuf -I../lib/mbuf -Ilib/mempool -I../lib/mempool -Ilib/ring
-I../lib/ring -Ilib/rcu -I../lib/rcu -Ilib/net -I../lib/net -Ilib/compressdev
-I../lib/compressdev -Ilib/security -I../lib/security -fcolor-diagnostics
-D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wextra -Werror -O3 -include
rte_config.h -Wcast-qual -Wdeprecated -Wformat -Wformat-nonliteral
-Wformat-security -Wmissing-declarations -Wmissing-prototypes -Wnested-externs
-Wold-style-definition -Wpointer-arith -Wsign-compare -Wstrict-prototypes
-Wundef -Wwrite-strings -Wno-address-of-packed-member
-Wno-missing-field-initializers -D_GNU_SOURCE -fPIC -march=native
-DALLOW_EXPERIMENTAL_API -DALLOW_INTERNAL_API -DBUILD_QAT_SYM -DBUILD_QAT_ASYM
-DRTE_LOG_DEFAULT_LOGTYPE=pmd.common.qat -MD -MQ
drivers/libtmp_rte_common_qat.a.p/crypto_qat_qat_sym_session.c.o -MF
drivers/libtmp_rte_common_qat.a.p/crypto_qat_qat_sym_session.c.o.d -o
drivers/libtmp_rte_common_qat.a.p/crypto_qat_qat_sym_session.c.o -c
../drivers/crypto/qat/qat_sym_session.c
../drivers/crypto/qat/qat_sym_session.c:1064:7: error: 'SHA1_Init' is
deprecated [-Werror,-Wdeprecated-declarations]
        if (!SHA1_Init(&ctx))
             ^
/usr/include/openssl/sha.h:49:1: note: 'SHA1_Init' has been explicitly marked
deprecated here
OSSL_DEPRECATEDIN_3_0 int SHA1_Init(SHA_CTX *c);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1066:2: error: 'SHA1_Transform' is
deprecated [-Werror,-Wdeprecated-declarations]
        SHA1_Transform(&ctx, data_in);
        ^
/usr/include/openssl/sha.h:52:1: note: 'SHA1_Transform' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 void SHA1_Transform(SHA_CTX *c, const unsigned char
*data);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1075:7: error: 'SHA224_Init' is
deprecated [-Werror,-Wdeprecated-declarations]
        if (!SHA224_Init(&ctx))
             ^
/usr/include/openssl/sha.h:69:1: note: 'SHA224_Init' has been explicitly marked
deprecated here
OSSL_DEPRECATEDIN_3_0 int SHA224_Init(SHA256_CTX *c);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1077:2: error: 'SHA256_Transform' is
deprecated [-Werror,-Wdeprecated-declarations]
        SHA256_Transform(&ctx, data_in);
        ^
/usr/include/openssl/sha.h:77:1: note: 'SHA256_Transform' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 void SHA256_Transform(SHA256_CTX *c,
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1086:7: error: 'SHA256_Init' is
deprecated [-Werror,-Wdeprecated-declarations]
        if (!SHA256_Init(&ctx))
             ^
/usr/include/openssl/sha.h:73:1: note: 'SHA256_Init' has been explicitly marked
deprecated here
OSSL_DEPRECATEDIN_3_0 int SHA256_Init(SHA256_CTX *c);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1088:2: error: 'SHA256_Transform' is
deprecated [-Werror,-Wdeprecated-declarations]
        SHA256_Transform(&ctx, data_in);
        ^
/usr/include/openssl/sha.h:77:1: note: 'SHA256_Transform' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 void SHA256_Transform(SHA256_CTX *c,
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1097:7: error: 'SHA384_Init' is
deprecated [-Werror,-Wdeprecated-declarations]
        if (!SHA384_Init(&ctx))
             ^
/usr/include/openssl/sha.h:119:1: note: 'SHA384_Init' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 int SHA384_Init(SHA512_CTX *c);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1099:2: error: 'SHA512_Transform' is
deprecated [-Werror,-Wdeprecated-declarations]
        SHA512_Transform(&ctx, data_in);
        ^
/usr/include/openssl/sha.h:127:1: note: 'SHA512_Transform' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 void SHA512_Transform(SHA512_CTX *c,
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1108:7: error: 'SHA512_Init' is
deprecated [-Werror,-Wdeprecated-declarations]
        if (!SHA512_Init(&ctx))
             ^
/usr/include/openssl/sha.h:123:1: note: 'SHA512_Init' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 int SHA512_Init(SHA512_CTX *c);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1110:2: error: 'SHA512_Transform' is
deprecated [-Werror,-Wdeprecated-declarations]
        SHA512_Transform(&ctx, data_in);
        ^
/usr/include/openssl/sha.h:127:1: note: 'SHA512_Transform' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 void SHA512_Transform(SHA512_CTX *c,
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1119:7: error: 'MD5_Init' is deprecated
[-Werror,-Wdeprecated-declarations]
        if (!MD5_Init(&ctx))
             ^
/usr/include/openssl/md5.h:49:1: note: 'MD5_Init' has been explicitly marked
deprecated here
OSSL_DEPRECATEDIN_3_0 int MD5_Init(MD5_CTX *c);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1121:2: error: 'MD5_Transform' is
deprecated [-Werror,-Wdeprecated-declarations]
        MD5_Transform(&ctx, data_in);
        ^
/usr/include/openssl/md5.h:54:1: note: 'MD5_Transform' has been explicitly
marked deprecated here
OSSL_DEPRECATEDIN_3_0 void MD5_Transform(MD5_CTX *c, const unsigned char *b);
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1250:8: error: 'AES_set_encrypt_key' is
deprecated [-Werror,-Wdeprecated-declarations]
                        if (AES_set_encrypt_key(auth_key, auth_keylen << 3,
                            ^
/usr/include/openssl/aes.h:50:1: note: 'AES_set_encrypt_key' has been
explicitly marked deprecated here
OSSL_DEPRECATEDIN_3_0
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1256:4: error: 'AES_encrypt' is
deprecated [-Werror,-Wdeprecated-declarations]
                        AES_encrypt(in, k0, &enc_key);
                        ^
/usr/include/openssl/aes.h:56:1: note: 'AES_encrypt' has been explicitly marked
deprecated here
OSSL_DEPRECATEDIN_3_0
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1294:9: error: 'AES_set_encrypt_key' is
deprecated [-Werror,-Wdeprecated-declarations]
                                if (AES_set_encrypt_key(auth_key,
                                    ^
/usr/include/openssl/aes.h:50:1: note: 'AES_set_encrypt_key' has been
explicitly marked deprecated here
OSSL_DEPRECATEDIN_3_0
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1304:5: error: 'AES_encrypt' is
deprecated [-Werror,-Wdeprecated-declarations]
                                AES_encrypt(in, out, &enc_key);
                                ^
/usr/include/openssl/aes.h:56:1: note: 'AES_encrypt' has been explicitly marked
deprecated here
OSSL_DEPRECATEDIN_3_0
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1330:7: error: 'AES_set_encrypt_key' is
deprecated [-Werror,-Wdeprecated-declarations]
                if (AES_set_encrypt_key(auth_key, auth_keylen << 3,
                    ^
/usr/include/openssl/aes.h:50:1: note: 'AES_set_encrypt_key' has been
explicitly marked deprecated here
OSSL_DEPRECATEDIN_3_0
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
../drivers/crypto/qat/qat_sym_session.c:1334:3: error: 'AES_encrypt' is
deprecated [-Werror,-Wdeprecated-declarations]
                AES_encrypt(in, out, &enc_key);
                ^
/usr/include/openssl/aes.h:56:1: note: 'AES_encrypt' has been explicitly marked
deprecated here
OSSL_DEPRECATEDIN_3_0
^
/usr/include/openssl/macros.h:182:49: note: expanded from macro
'OSSL_DEPRECATEDIN_3_0'
#   define OSSL_DEPRECATEDIN_3_0                OSSL_DEPRECATED(3.0)
                                                ^
/usr/include/openssl/macros.h:62:52: note: expanded from macro
'OSSL_DEPRECATED'
#     define OSSL_DEPRECATED(since) __attribute__((deprecated))
                                                   ^
18 errors generated.
[844/3631] Compiling C object
drivers/libtmp_rte_common_qat.a.p/crypto_qat_qat_crypto.c.o
[845/3631] Compiling C object
drivers/libtmp_rte_common_qat.a.p/crypto_qat_dev_qat_asym_pmd_gen1.c.o
[846/3631] Compiling C object
drivers/libtmp_rte_common_qat.a.p/crypto_qat_dev_qat_crypto_pmd_gen2.c.o
[847/3631] Compiling C object
drivers/common/sfc_efx/base/libsfc_base.a.p/efx_hash.c.o
[848/3631] Compiling C object
drivers/libtmp_rte_common_qat.a.p/crypto_qat_dev_qat_crypto_pmd_gen4.c.o
[849/3631] Generating drivers/rte_common_cnxk.sym_chk with a custom command
(wrapped by meson to capture output)
[850/3631] Compiling C object
drivers/libtmp_rte_common_qat.a.p/crypto_qat_dev_qat_crypto_pmd_gen3.c.o
[851/3631] Compiling C object
drivers/libtmp_rte_common_qat.a.p/crypto_qat_dev_qat_sym_pmd_gen1.c.o
[852/3631] Compiling C object
drivers/libtmp_rte_common_qat.a.p/crypto_qat_qat_asym.c.o
ninja: build stopped


[Bad commit]
I can't find bad commit, Because it's using openssl v3 these errors occur, The
package name on ubuntu is libssl-dev.

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2022-05-13  8:58 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-05-13  8:58 [Bug 1009] [dpdk-22.07*] drivers/crypto/qat meson build failed with gcc 11.2.0 on Ub22.04/64 bugzilla

DPDK patches and discussions

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.dpdk.org/dev/0 dev/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 dev dev/ http://inbox.dpdk.org/dev \
		dev@dpdk.org
	public-inbox-index dev

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.dev


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git