DPDK patches and discussions
 help / color / Atom feed
* [dpdk-dev] [Bug 559] [dpdk-20.11]loopback_virtio_user_server_mode: failed to start virtio-user with Virtio user server mode
@ 2020-10-16  5:38 bugzilla
  2020-10-20  9:48 ` bugzilla
  0 siblings, 1 reply; 2+ messages in thread
From: bugzilla @ 2020-10-16  5:38 UTC (permalink / raw)
  To: dev

https://bugs.dpdk.org/show_bug.cgi?id=559

            Bug ID: 559
           Summary: [dpdk-20.11]loopback_virtio_user_server_mode:  failed
                    to start virtio-user  with  Virtio user server mode
           Product: DPDK
           Version: 20.11
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: Normal
         Component: vhost/virtio
          Assignee: dev@dpdk.org
          Reporter: xix.zhang@intel.com
  Target Milestone: ---

steps:

x86_64-native-linuxapp-gcc/app/dpdk-testpmd -l 1,2,3 -n 4  
--file-prefix=virtio_88751_20201016012549 --no-pci --vdev
net_virtio_user0,mac=00:01:02:03:04:05,path=vhost-net,server=1,queues=1,packed_vq=1,in_order=0,mrg_rxbuf=1
-- -i --rxq=1 --txq=1 --no-numa


Actual results:

EAL: Detected 112 lcore(s)
EAL: Detected 2 NUMA nodes
EAL: Multi-process socket /var/run/dpdk/virtio_88751_20201016012549/mp_socket
EAL: Selected IOVA mode 'VA'
EAL: Probing VFIO support...
EAL: VFIO support initialized
virtio_user_pmd_probe(): unable to determine backend type for path vhost-net
vdev_probe(): failed to initialize net_virtio_user0 device
EAL: Bus (vdev) probe failed.
testpmd: No probed ethernet devices
Interactive-mode selected
Fail: input rxq (1) can't be greater than max_rx_queues (0) of port 0
EAL: Error - exiting with code: 1
  Cause: rxq 1 invalid - must be >= 0 && <= 0
root@virtio220:~/dpdk# rm -rf x86_64-native-linuxapp-gcc/
root@virtio220:~/dpdk# git reset --hard
86e71eb290bae5b7877ff706b28e7f29be0e40a2
HEAD is now at 86e71eb29 net/virtio: introduce DMA ops

Expect results:
  Start virtio normally

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 2+ messages in thread

* [dpdk-dev] [Bug 559] [dpdk-20.11]loopback_virtio_user_server_mode: failed to start virtio-user with Virtio user server mode
  2020-10-16  5:38 [dpdk-dev] [Bug 559] [dpdk-20.11]loopback_virtio_user_server_mode: failed to start virtio-user with Virtio user server mode bugzilla
@ 2020-10-20  9:48 ` bugzilla
  0 siblings, 0 replies; 2+ messages in thread
From: bugzilla @ 2020-10-20  9:48 UTC (permalink / raw)
  To: dev

https://bugs.dpdk.org/show_bug.cgi?id=559

xizhan4x (xix.zhang@intel.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|---                         |FIXED

--- Comment #2 from xizhan4x (xix.zhang@intel.com) ---
Verified patchset https://patches.dpdk.org/patch/81431/ on baseline 0e8704a45.
Tested pass on fortville_spirit  / Ubuntu 20.04.1 LTS
https://mails.dpdk.org/archives/dev/2020-October/187870.html

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-16  5:38 [dpdk-dev] [Bug 559] [dpdk-20.11]loopback_virtio_user_server_mode: failed to start virtio-user with Virtio user server mode bugzilla
2020-10-20  9:48 ` bugzilla

DPDK patches and discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/dev/0 dev/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 dev dev/ http://inbox.dpdk.org/dev \
		dev@dpdk.org
	public-inbox-index dev


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.dev


AGPL code for this site: git clone https://public-inbox.org/ public-inbox