From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mails.dpdk.org (mails.dpdk.org [217.70.189.124]) by inbox.dpdk.org (Postfix) with ESMTP id 874C545B40; Tue, 15 Oct 2024 09:10:36 +0200 (CEST) Received: from mails.dpdk.org (localhost [127.0.0.1]) by mails.dpdk.org (Postfix) with ESMTP id 203EB402A1; Tue, 15 Oct 2024 09:10:36 +0200 (CEST) Received: from mail.lysator.liu.se (mail.lysator.liu.se [130.236.254.3]) by mails.dpdk.org (Postfix) with ESMTP id B3E6A4027C for ; Tue, 15 Oct 2024 09:10:34 +0200 (CEST) Received: from mail.lysator.liu.se (localhost [127.0.0.1]) by mail.lysator.liu.se (Postfix) with ESMTP id 564B11313B for ; Tue, 15 Oct 2024 09:10:34 +0200 (CEST) Received: by mail.lysator.liu.se (Postfix, from userid 1004) id 4A1DD1313A; Tue, 15 Oct 2024 09:10:34 +0200 (CEST) X-Spam-Checker-Version: SpamAssassin 4.0.0 (2022-12-13) on hermod.lysator.liu.se X-Spam-Level: X-Spam-Status: No, score=-1.2 required=5.0 tests=ALL_TRUSTED,AWL, T_SCC_BODY_TEXT_LINE autolearn=disabled version=4.0.0 X-Spam-Score: -1.2 Received: from [192.168.1.85] (h-62-63-215-114.A163.priv.bahnhof.se [62.63.215.114]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by mail.lysator.liu.se (Postfix) with ESMTPSA id 174EB1307B; Tue, 15 Oct 2024 09:10:31 +0200 (CEST) Message-ID: Date: Tue, 15 Oct 2024 09:10:30 +0200 MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v11 1/7] eal: add static per-lcore memory allocation facility From: =?UTF-8?Q?Mattias_R=C3=B6nnblom?= To: =?UTF-8?Q?Morten_Br=C3=B8rup?= , =?UTF-8?Q?Mattias_R=C3=B6nnblom?= , dev@dpdk.org, thomas@monjalon.net Cc: Stephen Hemminger , Konstantin Ananyev , David Marchand , Jerin Jacob , Luka Jankovic , Konstantin Ananyev , Chengwen Feng References: <20241011081901.816211-2-mattias.ronnblom@ericsson.com> <20241014074348.821962-1-mattias.ronnblom@ericsson.com> <20241014074348.821962-2-mattias.ronnblom@ericsson.com> <98CBD80474FA8B44BF855DF32C47DC35E9F7D1@smartserver.smartshare.dk> Content-Language: en-US In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 8bit X-Virus-Scanned: ClamAV using ClamSMTP X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org On 2024-10-15 08:41, Mattias Rönnblom wrote: > On 2024-10-14 10:17, Morten Brørup wrote: >> >>> +/** >>> + * Get pointer to lcore variable instance with the specified lcore id. >>> + * >>> + * @param lcore_id >>> + *   The lcore id specifying which of the @c RTE_MAX_LCORE value >>> + *   instances should be accessed. The lcore id need not be valid >>> + *   (e.g., may be @ref LCORE_ID_ANY), but in such a case, the pointer >>> + *   is also not valid (and thus should not be dereferenced). >>> + * @param handle >>> + *   The lcore variable handle. >>> + */ >>> +#define RTE_LCORE_VAR_LCORE_VALUE(lcore_id, handle)            \ >>> +    ((typeof(handle))rte_lcore_var_lcore_ptr(lcore_id, handle)) >> >> Please remove the _VALUE suffix. >> > > You changed your mind? I'm missing the rationale here. > I supposed this is a bit of subjective hairsplitting, but does anyone else have an opinion? Short versus somewhat more readable name. To get "your own" value should be something like struct foo *lcore_foo = RTE_LCORE_VAR(foo); versus struct foo *lcore_foo = RTE_LCORE_VAR_VALUE(foo); We should also strip "_VALUE" off of the RTE_LCORE_FOREACH_VALUE() macro name in case we change the names of the access macros.