Soft Patch Panel
 help / color / Atom feed
* [spp] [Bug 453] SPP-CTL does not run with python2.7
@ 2020-04-19  6:19 bugzilla
  2020-04-23  5:21 ` bugzilla
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: bugzilla @ 2020-04-19  6:19 UTC (permalink / raw)
  To: spp

https://bugs.dpdk.org/show_bug.cgi?id=453

            Bug ID: 453
           Summary: SPP-CTL does not run with python2.7
           Product: SPP
           Version: unspecified
          Hardware: x86
                OS: Linux
            Status: UNCONFIRMED
          Severity: major
          Priority: High
         Component: ctl
          Assignee: yasufum.o@gmail.com
          Reporter: vipin.varghese@intel.com
                CC: spp@dpdk.org
  Target Milestone: ---

CMD: python2.7 src/spp-ctl/spp-ctl -b 127.0.0.1
URL: ```https://doc.dpdk.org/spp/setup/getting_started.html#setup``` states
python 2 is compatible

Expected Result: spp-ctl connecting to the primary SPP

Current result: 

```
# python2.7 src/spp-ctl/spp-ctl -b 127.0.0.1
Traceback (most recent call last):
  File "src/spp-ctl/spp-ctl", line 11, in <module>
    sys.exit(main())
  File "/home/saesrv02/Downloads/explore/spp-19.11/src/spp-ctl/spp_ctl.py",
line 269, in main
    args.api_port)
  File "/home/saesrv02/Downloads/explore/spp-19.11/src/spp-ctl/spp_ctl.py",
line 30, in __init__
    self.web_server = spp_webapi.WebServer(self, host, api_port)
  File "/home/saesrv02/Downloads/explore/spp-19.11/src/spp-ctl/spp_webapi.py",
line 159, in __init__
    self.mount("/v1", V1Handler(controller))
  File "/home/saesrv02/Downloads/explore/spp-19.11/src/spp-ctl/spp_webapi.py",
line 179, in __init__
    self.mount("/primary", V1PrimaryHandler(controller))
  File "/home/saesrv02/Downloads/explore/spp-19.11/src/spp-ctl/spp_webapi.py",
line 477, in __init__
    self._initialize()
  File "/home/saesrv02/Downloads/explore/spp-19.11/src/spp-ctl/spp_webapi.py",
line 485, in _initialize
    self.mount("/flow_rules", V1PrimaryFlowHandler(self.ctrl))
  File "/home/saesrv02/Downloads/explore/spp-19.11/src/spp-ctl/spp_webapi.py",
line 609, in __init__
    super().__init__(controller)
TypeError: super() takes at least 1 argument (0 given)

```

-- 
You are receiving this mail because:
You are on the CC list for the bug.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [spp] [Bug 453] SPP-CTL does not run with python2.7
  2020-04-19  6:19 [spp] [Bug 453] SPP-CTL does not run with python2.7 bugzilla
@ 2020-04-23  5:21 ` bugzilla
  2020-04-23  7:17 ` bugzilla
  2020-04-24  2:17 ` bugzilla
  2 siblings, 0 replies; 4+ messages in thread
From: bugzilla @ 2020-04-23  5:21 UTC (permalink / raw)
  To: spp

https://bugs.dpdk.org/show_bug.cgi?id=453

masahiro nemoto (masahiro.nemoto.es@s1.ntt-tx.co.jp) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |masahiro.nemoto.es@s1.ntt-t
                   |                            |x.co.jp

--- Comment #1 from masahiro nemoto (masahiro.nemoto.es@s1.ntt-tx.co.jp) ---
Hello Vipin,

According to the latest SPP documents, python2 is not supoorted anymore.
https://git.dpdk.org/apps/spp/tree/docs/guides/gsg/install.rst
What do you think?

-- 
You are receiving this mail because:
You are on the CC list for the bug.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [spp] [Bug 453] SPP-CTL does not run with python2.7
  2020-04-19  6:19 [spp] [Bug 453] SPP-CTL does not run with python2.7 bugzilla
  2020-04-23  5:21 ` bugzilla
@ 2020-04-23  7:17 ` bugzilla
  2020-04-24  2:17 ` bugzilla
  2 siblings, 0 replies; 4+ messages in thread
From: bugzilla @ 2020-04-23  7:17 UTC (permalink / raw)
  To: spp

https://bugs.dpdk.org/show_bug.cgi?id=453

--- Comment #2 from Vipin Varghese (vipin.varghese@intel.com) ---
as mentioned in the ticket the URL used for reference is public hosted one
```https://doc.dpdk.org/spp/setup/getting_started.html#setup```. So I humbly
think, this should be updated here and the issue is conformed

-- 
You are receiving this mail because:
You are on the CC list for the bug.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [spp] [Bug 453] SPP-CTL does not run with python2.7
  2020-04-19  6:19 [spp] [Bug 453] SPP-CTL does not run with python2.7 bugzilla
  2020-04-23  5:21 ` bugzilla
  2020-04-23  7:17 ` bugzilla
@ 2020-04-24  2:17 ` bugzilla
  2 siblings, 0 replies; 4+ messages in thread
From: bugzilla @ 2020-04-24  2:17 UTC (permalink / raw)
  To: spp

https://bugs.dpdk.org/show_bug.cgi?id=453

masahiro nemoto (masahiro.nemoto.es@s1.ntt-tx.co.jp) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |CONFIRMED
     Ever confirmed|0                           |1

--- Comment #3 from masahiro nemoto (masahiro.nemoto.es@s1.ntt-tx.co.jp) ---
Hello Vipin,

You are right.
SPP documents which can be reffered by DPDK.org page is old.
So 
1. I change the ticket status to "confirmed"
and
2. Try to change those documents to proper one.

Thanks

-- 
You are receiving this mail because:
You are on the CC list for the bug.

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, back to index

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-19  6:19 [spp] [Bug 453] SPP-CTL does not run with python2.7 bugzilla
2020-04-23  5:21 ` bugzilla
2020-04-23  7:17 ` bugzilla
2020-04-24  2:17 ` bugzilla

Soft Patch Panel

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/spp/0 spp/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 spp spp/ http://inbox.dpdk.org/spp \
		spp@dpdk.org
	public-inbox-index spp


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.spp


AGPL code for this site: git clone https://public-inbox.org/ public-inbox