DPDK usage discussions
 help / color / Atom feed
* [dpdk-users] seeing a problem dpdk startup
@ 2019-11-28  7:01 Venumadhav Josyula
  2019-11-28  7:39 ` [dpdk-users] [dpdk-dev] " Gavin Hu (Arm Technology China)
  2019-11-28  7:45 ` Hui Wei
  0 siblings, 2 replies; 9+ messages in thread
From: Venumadhav Josyula @ 2019-11-28  7:01 UTC (permalink / raw)
  To: dev, users; +Cc: Venumadhav Josyula

We are seeing following error, no device is detected....
==========
EAL: Detected 8 lcore(s)
EAL: Detected 2 NUMA nodes
EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
EAL: No free hugepages reported in hugepages-1048576kB
EAL: Probing VFIO support...
EAL: VFIO support initialized
EAL: PCI device 0000:04:00.0 on NUMA socket 0
EAL:   probe driver: 8086:1528 net_ixgbe
EAL:   0000:04:00.0 failed to select IOMMU type
EAL: Requested device 0000:04:00.0 cannot be used
EAL: PCI device 0000:04:00.1 on NUMA socket 0
EAL:   probe driver: 8086:1528 net_ixgbe
EAL:   0000:04:00.1 failed to select IOMMU type
EAL: Requested device 0000:04:00.1 cannot be used

==================
dmesg

[55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU domain
attach due to platform RMRR requirement.  Contact your platform vendor.
[55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU domain
attach due to platform RMRR requirement.  Contact your platform vendor.

======
BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
intel_iommu=on


Can anybody suggest how to work around the issue ?

Thanks,
Regards,
Venu

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28  7:01 [dpdk-users] seeing a problem dpdk startup Venumadhav Josyula
@ 2019-11-28  7:39 ` " Gavin Hu (Arm Technology China)
  2019-11-28  7:43   ` Venumadhav Josyula
  2019-11-28  7:45 ` Hui Wei
  1 sibling, 1 reply; 9+ messages in thread
From: Gavin Hu (Arm Technology China) @ 2019-11-28  7:39 UTC (permalink / raw)
  To: Venumadhav Josyula, dev, users; +Cc: Venumadhav Josyula, nd

Hi Venumadhav,

> -----Original Message-----
> From: dev <dev-bounces@dpdk.org> On Behalf Of Venumadhav Josyula
> Sent: Thursday, November 28, 2019 3:01 PM
> To: dev@dpdk.org; users@dpdk.org
> Cc: Venumadhav Josyula <vjosyula@parallelwireless.com>
> Subject: [dpdk-dev] seeing a problem dpdk startup
> 
> We are seeing following error, no device is detected....
> ==========
> EAL: Detected 8 lcore(s)
> EAL: Detected 2 NUMA nodes
> EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
> EAL: No free hugepages reported in hugepages-1048576kB
> EAL: Probing VFIO support...
> EAL: VFIO support initialized
> EAL: PCI device 0000:04:00.0 on NUMA socket 0
> EAL:   probe driver: 8086:1528 net_ixgbe
> EAL:   0000:04:00.0 failed to select IOMMU type
> EAL: Requested device 0000:04:00.0 cannot be used
> EAL: PCI device 0000:04:00.1 on NUMA socket 0
> EAL:   probe driver: 8086:1528 net_ixgbe
> EAL:   0000:04:00.1 failed to select IOMMU type
> EAL: Requested device 0000:04:00.1 cannot be used
> 
> ==================
> dmesg
> 
> [55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU domain
> attach due to platform RMRR requirement.  Contact your platform vendor.
> [55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU domain
> attach due to platform RMRR requirement.  Contact your platform vendor.
> 
> ======
> BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
> intel_iommu=on
> 
> 
> Can anybody suggest how to work around the issue ?
Did you check if the device is bound to DPDK? 
Here is an example on my host:
gavin@net-arm-thunderx2-01:~/dpdk$ ./usertools/dpdk-devbind.py -s

Network devices using DPDK-compatible driver
============================================
0000:0f:00.0 'Ethernet Controller XL710 for 40GbE QSFP+ 1583' drv=vfio-pci unused=i40e
0000:8a:00.0 'Ethernet Controller XXV710 for 25GbE SFP28 158b' drv=vfio-pci unused=i40e
0000:8a:00.1 'Ethernet Controller XXV710 for 25GbE SFP28 158b' drv=vfio-pci unused=i40e
> 
> Thanks,
> Regards,
> Venu

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28  7:39 ` [dpdk-users] [dpdk-dev] " Gavin Hu (Arm Technology China)
@ 2019-11-28  7:43   ` Venumadhav Josyula
  0 siblings, 0 replies; 9+ messages in thread
From: Venumadhav Josyula @ 2019-11-28  7:43 UTC (permalink / raw)
  To: Gavin Hu (Arm Technology China); +Cc: dev, users, Venumadhav Josyula, nd

Hi Gavin,

It is
[root@localhost scripts]# ./dpdk-devbind.py --status-dev net

Network devices using DPDK-compatible driver
============================================
0000:04:00.0 'Ethernet Controller 10-Gigabit X540-AT2 1528' drv=vfio-pci
unused=ixgbe
0000:04:00.1 'Ethernet Controller 10-Gigabit X540-AT2 1528' drv=vfio-pci
unused=ixgbe

Network devices using kernel driver
===================================
0000:02:00.0 'NetXtreme BCM5719 Gigabit Ethernet PCIe 1657' if=eno1 drv=tg3
unused=vfio-pci *Active*
0000:02:00.1 'NetXtreme BCM5719 Gigabit Ethernet PCIe 1657' if=eno2 drv=tg3
unused=vfio-pci
0000:02:00.2 'NetXtreme BCM5719 Gigabit Ethernet PCIe 1657' if=eno3 drv=tg3
unused=vfio-pci
0000:02:00.3 'NetXtreme BCM5719 Gigabit Ethernet PCIe 1657' if=eno4 drv=tg3
unused=vfio-pci
[root@localhost scripts]#

I understand from the that IOMMU type selection is failing, is it possible
to somehow default it to either igb_uio ?

Thanks,
Regards,
Venu

On Thu, 28 Nov 2019 at 13:09, Gavin Hu (Arm Technology China) <
Gavin.Hu@arm.com> wrote:

> Hi Venumadhav,
>
> > -----Original Message-----
> > From: dev <dev-bounces@dpdk.org> On Behalf Of Venumadhav Josyula
> > Sent: Thursday, November 28, 2019 3:01 PM
> > To: dev@dpdk.org; users@dpdk.org
> > Cc: Venumadhav Josyula <vjosyula@parallelwireless.com>
> > Subject: [dpdk-dev] seeing a problem dpdk startup
> >
> > We are seeing following error, no device is detected....
> > ==========
> > EAL: Detected 8 lcore(s)
> > EAL: Detected 2 NUMA nodes
> > EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
> > EAL: No free hugepages reported in hugepages-1048576kB
> > EAL: Probing VFIO support...
> > EAL: VFIO support initialized
> > EAL: PCI device 0000:04:00.0 on NUMA socket 0
> > EAL:   probe driver: 8086:1528 net_ixgbe
> > EAL:   0000:04:00.0 failed to select IOMMU type
> > EAL: Requested device 0000:04:00.0 cannot be used
> > EAL: PCI device 0000:04:00.1 on NUMA socket 0
> > EAL:   probe driver: 8086:1528 net_ixgbe
> > EAL:   0000:04:00.1 failed to select IOMMU type
> > EAL: Requested device 0000:04:00.1 cannot be used
> >
> > ==================
> > dmesg
> >
> > [55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU
> domain
> > attach due to platform RMRR requirement.  Contact your platform vendor.
> > [55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU
> domain
> > attach due to platform RMRR requirement.  Contact your platform vendor.
> >
> > ======
> > BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
> > intel_iommu=on
> >
> >
> > Can anybody suggest how to work around the issue ?
> Did you check if the device is bound to DPDK?
> Here is an example on my host:
> gavin@net-arm-thunderx2-01:~/dpdk$ ./usertools/dpdk-devbind.py -s
>
> Network devices using DPDK-compatible driver
> ============================================
> 0000:0f:00.0 'Ethernet Controller XL710 for 40GbE QSFP+ 1583' drv=vfio-pci
> unused=i40e
> 0000:8a:00.0 'Ethernet Controller XXV710 for 25GbE SFP28 158b'
> drv=vfio-pci unused=i40e
> 0000:8a:00.1 'Ethernet Controller XXV710 for 25GbE SFP28 158b'
> drv=vfio-pci unused=i40e
> >
> > Thanks,
> > Regards,
> > Venu
>

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28  7:01 [dpdk-users] seeing a problem dpdk startup Venumadhav Josyula
  2019-11-28  7:39 ` [dpdk-users] [dpdk-dev] " Gavin Hu (Arm Technology China)
@ 2019-11-28  7:45 ` Hui Wei
  2019-11-28  7:48   ` Venumadhav Josyula
  1 sibling, 1 reply; 9+ messages in thread
From: Hui Wei @ 2019-11-28  7:45 UTC (permalink / raw)
  To: Venumadhav Josyula, dev, users; +Cc: Venumadhav Josyula


>We are seeing following error, no device is detected....
>==========
>EAL: Detected 8 lcore(s)
>EAL: Detected 2 NUMA nodes
>EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
>EAL: No free hugepages reported in hugepages-1048576kB
>EAL: Probing VFIO support...
>EAL: VFIO support initialized
>EAL: PCI device 0000:04:00.0 on NUMA socket 0
>EAL:   probe driver: 8086:1528 net_ixgbe
>EAL:   0000:04:00.0 failed to select IOMMU type
>EAL: Requested device 0000:04:00.0 cannot be used
>EAL: PCI device 0000:04:00.1 on NUMA socket 0
>EAL:   probe driver: 8086:1528 net_ixgbe
>EAL:   0000:04:00.1 failed to select IOMMU type
>EAL: Requested device 0000:04:00.1 cannot be used
>
>==================
>dmesg
>
>[55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU domain
>attach due to platform RMRR requirement.  Contact your platform vendor.
>[55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU domain
>attach due to platform RMRR requirement.  Contact your platform vendor. 

Intel Vt-d document addresses RMRR, but not that clearly. Check BIOS setup, 
no link share, for example, a nic detect by linux kernel, it was shared by BIOS for
IPMI. If change BIOS setup don't solve your problem, contact platform vendor update 
nic firmware, a server made by HP, check HP's website for firmware.

>
>======
>BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
>intel_iommu=on
>
>
>Can anybody suggest how to work around the issue ?
>
>Thanks,
>Regards,
>Venu

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28  7:45 ` Hui Wei
@ 2019-11-28  7:48   ` Venumadhav Josyula
  2019-11-28  8:01     ` Hui Wei
  0 siblings, 1 reply; 9+ messages in thread
From: Venumadhav Josyula @ 2019-11-28  7:48 UTC (permalink / raw)
  To: Hui Wei; +Cc: dev, users, Venumadhav Josyula

Hi Hui,

I understand that and we are exploring that.

But is there no work around there where in it defaults to igb_uio driver
something like that..... Basic idea is we should not be situation of no
port detected at all under this situation ?

Thanks,
Regards,
Venu

On Thu, 28 Nov 2019 at 13:15, Hui Wei <huiweics@hotmail.com> wrote:

>
> >We are seeing following error, no device is detected....
> >==========
> >EAL: Detected 8 lcore(s)
> >EAL: Detected 2 NUMA nodes
> >EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
> >EAL: No free hugepages reported in hugepages-1048576kB
> >EAL: Probing VFIO support...
> >EAL: VFIO support initialized
> >EAL: PCI device 0000:04:00.0 on NUMA socket 0
> >EAL:   probe driver: 8086:1528 net_ixgbe
> >EAL:   0000:04:00.0 failed to select IOMMU type
> >EAL: Requested device 0000:04:00.0 cannot be used
> >EAL: PCI device 0000:04:00.1 on NUMA socket 0
> >EAL:   probe driver: 8086:1528 net_ixgbe
> >EAL:   0000:04:00.1 failed to select IOMMU type
> >EAL: Requested device 0000:04:00.1 cannot be used
> >
> >==================
> >dmesg
> >
> >[55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU
> domain
> >attach due to platform RMRR requirement.  Contact your platform vendor.
> >[55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU
> domain
> >attach due to platform RMRR requirement.  Contact your platform vendor.
>
> Intel Vt-d document addresses RMRR, but not that clearly. Check BIOS
> setup,
> no link share, for example, a nic detect by linux kernel, it was shared by
> BIOS for
> IPMI. If change BIOS setup don't solve your problem, contact platform
> vendor update
> nic firmware, a server made by HP, check HP's website for firmware.
>
> >
> >======
> >BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
> >intel_iommu=on
> >
> >
> >Can anybody suggest how to work around the issue ?
> >
> >Thanks,
> >Regards,
> >Venu

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28  7:48   ` Venumadhav Josyula
@ 2019-11-28  8:01     ` Hui Wei
  2019-11-28 14:15       ` Roberts, Lee A.
  0 siblings, 1 reply; 9+ messages in thread
From: Hui Wei @ 2019-11-28  8:01 UTC (permalink / raw)
  To: Venumadhav Josyula; +Cc: dev, users, Venumadhav Josyula

I think  BIOS turn off vt-d, use igb_uio can work around.

>Hi Hui,
>
>I understand that and we are exploring that.
>
>But is there no work around there where in it defaults to igb_uio driver
>something like that..... Basic idea is we should not be situation of no
>port detected at all under this situation ?
>
>Thanks,
>Regards,
>Venu
>
>On Thu, 28 Nov 2019 at 13:15, Hui Wei <huiweics@hotmail.com> wrote:
>
>>
>> >We are seeing following error, no device is detected....
>> >==========
>> >EAL: Detected 8 lcore(s)
>> >EAL: Detected 2 NUMA nodes
>> >EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
>> >EAL: No free hugepages reported in hugepages-1048576kB
>> >EAL: Probing VFIO support...
>> >EAL: VFIO support initialized
>> >EAL: PCI device 0000:04:00.0 on NUMA socket 0
>> >EAL:   probe driver: 8086:1528 net_ixgbe
>> >EAL:   0000:04:00.0 failed to select IOMMU type
>> >EAL: Requested device 0000:04:00.0 cannot be used
>> >EAL: PCI device 0000:04:00.1 on NUMA socket 0
>> >EAL:   probe driver: 8086:1528 net_ixgbe
>> >EAL:   0000:04:00.1 failed to select IOMMU type
>> >EAL: Requested device 0000:04:00.1 cannot be used
>> >
>> >==================
>> >dmesg
>> >
>> >[55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU
>> domain
>> >attach due to platform RMRR requirement.  Contact your platform vendor.
>> >[55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU
>> domain
>> >attach due to platform RMRR requirement.  Contact your platform vendor.
>>
>> Intel Vt-d document addresses RMRR, but not that clearly. Check BIOS
>> setup,
>> no link share, for example, a nic detect by linux kernel, it was shared by
>> BIOS for
>> IPMI. If change BIOS setup don't solve your problem, contact platform
>> vendor update
>> nic firmware, a server made by HP, check HP's website for firmware.
>>
>> >
>> >======
>> >BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
>> >intel_iommu=on
>> >
>> >
>> >Can anybody suggest how to work around the issue ?
>> >
>> >Thanks,
>> >Regards,
>> >Venu

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28  8:01     ` Hui Wei
@ 2019-11-28 14:15       ` Roberts, Lee A.
  2019-11-28 14:20         ` Venumadhav Josyula
  0 siblings, 1 reply; 9+ messages in thread
From: Roberts, Lee A. @ 2019-11-28 14:15 UTC (permalink / raw)
  To: Hui Wei, Venumadhav Josyula; +Cc: dev, users, Venumadhav Josyula

Please see the HPE customer advisory at https://support.hpe.com/hpsc/doc/public/display?sp4ts.oid=7271241&docId=emr_na-c04781229&docLocale=en_US.
You will need to disable the shared memory features for the NIC card.

                                 - Lee

-----Original Message-----
From: dev [mailto:dev-bounces@dpdk.org] On Behalf Of Hui Wei
Sent: Thursday, November 28, 2019 1:01 AM
To: Venumadhav Josyula <vjosyula@gmail.com>
Cc: dev <dev@dpdk.org>; users <users@dpdk.org>; Venumadhav Josyula <vjosyula@parallelwireless.com>
Subject: Re: [dpdk-dev] seeing a problem dpdk startup

I think  BIOS turn off vt-d, use igb_uio can work around.

>Hi Hui,
>
>I understand that and we are exploring that.
>
>But is there no work around there where in it defaults to igb_uio driver
>something like that..... Basic idea is we should not be situation of no
>port detected at all under this situation ?
>
>Thanks,
>Regards,
>Venu
>
>On Thu, 28 Nov 2019 at 13:15, Hui Wei <huiweics@hotmail.com> wrote:
>
>>
>> >We are seeing following error, no device is detected....
>> >==========
>> >EAL: Detected 8 lcore(s)
>> >EAL: Detected 2 NUMA nodes
>> >EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
>> >EAL: No free hugepages reported in hugepages-1048576kB
>> >EAL: Probing VFIO support...
>> >EAL: VFIO support initialized
>> >EAL: PCI device 0000:04:00.0 on NUMA socket 0
>> >EAL:   probe driver: 8086:1528 net_ixgbe
>> >EAL:   0000:04:00.0 failed to select IOMMU type
>> >EAL: Requested device 0000:04:00.0 cannot be used
>> >EAL: PCI device 0000:04:00.1 on NUMA socket 0
>> >EAL:   probe driver: 8086:1528 net_ixgbe
>> >EAL:   0000:04:00.1 failed to select IOMMU type
>> >EAL: Requested device 0000:04:00.1 cannot be used
>> >
>> >==================
>> >dmesg
>> >
>> >[55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU
>> domain
>> >attach due to platform RMRR requirement.  Contact your platform vendor.
>> >[55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU
>> domain
>> >attach due to platform RMRR requirement.  Contact your platform vendor.
>>
>> Intel Vt-d document addresses RMRR, but not that clearly. Check BIOS
>> setup,
>> no link share, for example, a nic detect by linux kernel, it was shared by
>> BIOS for
>> IPMI. If change BIOS setup don't solve your problem, contact platform
>> vendor update
>> nic firmware, a server made by HP, check HP's website for firmware.
>>
>> >
>> >======
>> >BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
>> >intel_iommu=on
>> >
>> >
>> >Can anybody suggest how to work around the issue ?
>> >
>> >Thanks,
>> >Regards,
>> >Venu

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28 14:15       ` Roberts, Lee A.
@ 2019-11-28 14:20         ` Venumadhav Josyula
  2019-11-28 16:11           ` Stephen Hemminger
  0 siblings, 1 reply; 9+ messages in thread
From: Venumadhav Josyula @ 2019-11-28 14:20 UTC (permalink / raw)
  To: Roberts, Lee A.; +Cc: Hui Wei, dev, users, Venumadhav Josyula

Hi Roberts,

Thanks for your reply. Basically, our BIOS is old we do not have that
feature in our BIOS , we need to upgrade it.

But after enabling will it work, can you confirm that based on your
experience or somebody informing you success story.

Thanks,
Regards,
Venu

On Thu, 28 Nov 2019 at 19:45, Roberts, Lee A. <lee.roberts@hpe.com> wrote:

> Please see the HPE customer advisory at
> https://support.hpe.com/hpsc/doc/public/display?sp4ts.oid=7271241&docId=emr_na-c04781229&docLocale=en_US
> .
> You will need to disable the shared memory features for the NIC card.
>
>                                  - Lee
>
> -----Original Message-----
> From: dev [mailto:dev-bounces@dpdk.org] On Behalf Of Hui Wei
> Sent: Thursday, November 28, 2019 1:01 AM
> To: Venumadhav Josyula <vjosyula@gmail.com>
> Cc: dev <dev@dpdk.org>; users <users@dpdk.org>; Venumadhav Josyula <
> vjosyula@parallelwireless.com>
> Subject: Re: [dpdk-dev] seeing a problem dpdk startup
>
> I think  BIOS turn off vt-d, use igb_uio can work around.
>
> >Hi Hui,
> >
> >I understand that and we are exploring that.
> >
> >But is there no work around there where in it defaults to igb_uio driver
> >something like that..... Basic idea is we should not be situation of no
> >port detected at all under this situation ?
> >
> >Thanks,
> >Regards,
> >Venu
> >
> >On Thu, 28 Nov 2019 at 13:15, Hui Wei <huiweics@hotmail.com> wrote:
> >
> >>
> >> >We are seeing following error, no device is detected....
> >> >==========
> >> >EAL: Detected 8 lcore(s)
> >> >EAL: Detected 2 NUMA nodes
> >> >EAL: Multi-process socket /var/run/dpdk/rte/mp_socket
> >> >EAL: No free hugepages reported in hugepages-1048576kB
> >> >EAL: Probing VFIO support...
> >> >EAL: VFIO support initialized
> >> >EAL: PCI device 0000:04:00.0 on NUMA socket 0
> >> >EAL:   probe driver: 8086:1528 net_ixgbe
> >> >EAL:   0000:04:00.0 failed to select IOMMU type
> >> >EAL: Requested device 0000:04:00.0 cannot be used
> >> >EAL: PCI device 0000:04:00.1 on NUMA socket 0
> >> >EAL:   probe driver: 8086:1528 net_ixgbe
> >> >EAL:   0000:04:00.1 failed to select IOMMU type
> >> >EAL: Requested device 0000:04:00.1 cannot be used
> >> >
> >> >==================
> >> >dmesg
> >> >
> >> >[55455.259493] vfio-pci 0000:04:00.0: Device is ineligible for IOMMU
> >> domain
> >> >attach due to platform RMRR requirement.  Contact your platform vendor.
> >> >[55455.260947] vfio-pci 0000:04:00.1: Device is ineligible for IOMMU
> >> domain
> >> >attach due to platform RMRR requirement.  Contact your platform vendor.
> >>
> >> Intel Vt-d document addresses RMRR, but not that clearly. Check BIOS
> >> setup,
> >> no link share, for example, a nic detect by linux kernel, it was shared
> by
> >> BIOS for
> >> IPMI. If change BIOS setup don't solve your problem, contact platform
> >> vendor update
> >> nic firmware, a server made by HP, check HP's website for firmware.
> >>
> >> >
> >> >======
> >> >BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.el7.pw.1.x86_64 root=/dev/sda3
> >> >intel_iommu=on
> >> >
> >> >
> >> >Can anybody suggest how to work around the issue ?
> >> >
> >> >Thanks,
> >> >Regards,
> >> >Venu
>

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [dpdk-users] [dpdk-dev] seeing a problem dpdk startup
  2019-11-28 14:20         ` Venumadhav Josyula
@ 2019-11-28 16:11           ` Stephen Hemminger
  0 siblings, 0 replies; 9+ messages in thread
From: Stephen Hemminger @ 2019-11-28 16:11 UTC (permalink / raw)
  To: Venumadhav Josyula
  Cc: Roberts, Lee A., Hui Wei, dev, users, Venumadhav Josyula

On Thu, 28 Nov 2019 19:50:41 +0530
Venumadhav Josyula <vjosyula@gmail.com> wrote:

> Hi Roberts,
> 
> Thanks for your reply. Basically, our BIOS is old we do not have that
> feature in our BIOS , we need to upgrade it.
> 
> But after enabling will it work, can you confirm that based on your
> experience or somebody informing you success story.
> 
> Thanks,
> Regards,
> Venu

This may help explain the issues.
https://access.redhat.com/sites/default/files/attachments/rmrr-wp1.pdf


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, back to index

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-11-28  7:01 [dpdk-users] seeing a problem dpdk startup Venumadhav Josyula
2019-11-28  7:39 ` [dpdk-users] [dpdk-dev] " Gavin Hu (Arm Technology China)
2019-11-28  7:43   ` Venumadhav Josyula
2019-11-28  7:45 ` Hui Wei
2019-11-28  7:48   ` Venumadhav Josyula
2019-11-28  8:01     ` Hui Wei
2019-11-28 14:15       ` Roberts, Lee A.
2019-11-28 14:20         ` Venumadhav Josyula
2019-11-28 16:11           ` Stephen Hemminger

DPDK usage discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/users/0 users/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 users users/ http://inbox.dpdk.org/users \
		users@dpdk.org
	public-inbox-index users


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.users


AGPL code for this site: git clone https://public-inbox.org/ public-inbox