DPDK usage discussions
 help / color / Atom feed
* [dpdk-users] no traffic sent/received while testing XL710 with Traffic generator on VM
@ 2019-09-11  2:09 Sampath, Amrutha
  2019-09-16  2:42 ` Zhang, Xiao
  0 siblings, 1 reply; 4+ messages in thread
From: Sampath, Amrutha @ 2019-09-11  2:09 UTC (permalink / raw)
  To: users

Hi All,

I have VF's created for the XL710.
I'm using i40e driver version: 2.9.21 and iavf driver: 3.7.53

I then run this command , whitelisting XL710 ports.

/home/userx/dpdk/x86_64-native-linuxapp-gcc/app/testpmd -c 0x00007 -n 6 -w 0000:00:08.0 -w 0000:00:09.0 --socket-mem=1024 -- --socket-num=0 --nb-cores=2 --coremask=0x0006 --rxq=1 --txq=1 -i --mbcache=512 --burst=64 --rxd=2048 --txd=2048 --forward-mode=mac --portmask=0x3



I see port as up in traffic generator (both ixia and spirent) and start traffic, but I only see tx on traffic generator end no statistics(rx or tx) on XL710 VF side.



Is there anything I'm missing?





Thanks






^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [dpdk-users] no traffic sent/received while testing XL710 with Traffic generator on VM
  2019-09-11  2:09 [dpdk-users] no traffic sent/received while testing XL710 with Traffic generator on VM Sampath, Amrutha
@ 2019-09-16  2:42 ` Zhang, Xiao
  2019-09-16  2:45   ` Sampath, Amrutha
  0 siblings, 1 reply; 4+ messages in thread
From: Zhang, Xiao @ 2019-09-16  2:42 UTC (permalink / raw)
  To: Sampath, Amrutha, users

Hi Amrutha,

Did you configure the vf to promiscuous mode?
You need to configure it to promiscuous mode to get packets with destination not the same as mac of vf.
The command is: ip link set dev vf 0 trust on

BR,
Xiao

> -----Original Message-----
> From: users [mailto:users-bounces@dpdk.org] On Behalf Of Sampath, Amrutha
> Sent: Wednesday, September 11, 2019 10:10 AM
> To: users@dpdk.org
> Subject: [dpdk-users] no traffic sent/received while testing XL710 with Traffic
> generator on VM
> 
> Hi All,
> 
> I have VF's created for the XL710.
> I'm using i40e driver version: 2.9.21 and iavf driver: 3.7.53
> 
> I then run this command , whitelisting XL710 ports.
> 
> /home/userx/dpdk/x86_64-native-linuxapp-gcc/app/testpmd -c 0x00007 -n 6 -w
> 0000:00:08.0 -w 0000:00:09.0 --socket-mem=1024 -- --socket-num=0 --nb-
> cores=2 --coremask=0x0006 --rxq=1 --txq=1 -i --mbcache=512 --burst=64 --
> rxd=2048 --txd=2048 --forward-mode=mac --portmask=0x3
> 
> 
> 
> I see port as up in traffic generator (both ixia and spirent) and start traffic, but I
> only see tx on traffic generator end no statistics(rx or tx) on XL710 VF side.
> 
> 
> 
> Is there anything I'm missing?
> 
> 
> 
> 
> 
> Thanks
> 
> 
> 
> 


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [dpdk-users] no traffic sent/received while testing XL710 with Traffic generator on VM
  2019-09-16  2:42 ` Zhang, Xiao
@ 2019-09-16  2:45   ` Sampath, Amrutha
  2019-09-16  2:53     ` Zhang, Xiao
  0 siblings, 1 reply; 4+ messages in thread
From: Sampath, Amrutha @ 2019-09-16  2:45 UTC (permalink / raw)
  To: Zhang, Xiao, users

Once I assigned static MAC address for FVL VF's , it worked.
I'm wondering why it didn't work for auto assigned MAC. Should I explicitly configure promiscuous mode for it to work?

Thanks

-----Original Message-----
From: Zhang, Xiao 
Sent: Sunday, September 15, 2019 7:42 PM
To: Sampath, Amrutha <amrutha.sampath@intel.com>; users@dpdk.org
Subject: RE: no traffic sent/received while testing XL710 with Traffic generator on VM

Hi Amrutha,

Did you configure the vf to promiscuous mode?
You need to configure it to promiscuous mode to get packets with destination not the same as mac of vf.
The command is: ip link set dev vf 0 trust on

BR,
Xiao

> -----Original Message-----
> From: users [mailto:users-bounces@dpdk.org] On Behalf Of Sampath, 
> Amrutha
> Sent: Wednesday, September 11, 2019 10:10 AM
> To: users@dpdk.org
> Subject: [dpdk-users] no traffic sent/received while testing XL710 
> with Traffic generator on VM
> 
> Hi All,
> 
> I have VF's created for the XL710.
> I'm using i40e driver version: 2.9.21 and iavf driver: 3.7.53
> 
> I then run this command , whitelisting XL710 ports.
> 
> /home/userx/dpdk/x86_64-native-linuxapp-gcc/app/testpmd -c 0x00007 -n 
> 6 -w
> 0000:00:08.0 -w 0000:00:09.0 --socket-mem=1024 -- --socket-num=0 --nb-
> cores=2 --coremask=0x0006 --rxq=1 --txq=1 -i --mbcache=512 --burst=64 
> --
> rxd=2048 --txd=2048 --forward-mode=mac --portmask=0x3
> 
> 
> 
> I see port as up in traffic generator (both ixia and spirent) and 
> start traffic, but I only see tx on traffic generator end no statistics(rx or tx) on XL710 VF side.
> 
> 
> 
> Is there anything I'm missing?
> 
> 
> 
> 
> 
> Thanks
> 
> 
> 
> 


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [dpdk-users] no traffic sent/received while testing XL710 with Traffic generator on VM
  2019-09-16  2:45   ` Sampath, Amrutha
@ 2019-09-16  2:53     ` Zhang, Xiao
  0 siblings, 0 replies; 4+ messages in thread
From: Zhang, Xiao @ 2019-09-16  2:53 UTC (permalink / raw)
  To: Sampath, Amrutha, users


Yes. You can configure the promiscuous mode to let it work, and I can check you mentioned for auto assigned MAC.

> -----Original Message-----
> From: Sampath, Amrutha
> Sent: Monday, September 16, 2019 10:46 AM
> To: Zhang, Xiao <xiao.zhang@intel.com>; users@dpdk.org
> Subject: RE: no traffic sent/received while testing XL710 with Traffic generator
> on VM
> 
> Once I assigned static MAC address for FVL VF's , it worked.
> I'm wondering why it didn't work for auto assigned MAC. Should I explicitly
> configure promiscuous mode for it to work?
> 
> Thanks
> 
> -----Original Message-----
> From: Zhang, Xiao
> Sent: Sunday, September 15, 2019 7:42 PM
> To: Sampath, Amrutha <amrutha.sampath@intel.com>; users@dpdk.org
> Subject: RE: no traffic sent/received while testing XL710 with Traffic generator
> on VM
> 
> Hi Amrutha,
> 
> Did you configure the vf to promiscuous mode?
> You need to configure it to promiscuous mode to get packets with destination
> not the same as mac of vf.
> The command is: ip link set dev vf 0 trust on
> 
> BR,
> Xiao
> 
> > -----Original Message-----
> > From: users [mailto:users-bounces@dpdk.org] On Behalf Of Sampath,
> > Amrutha
> > Sent: Wednesday, September 11, 2019 10:10 AM
> > To: users@dpdk.org
> > Subject: [dpdk-users] no traffic sent/received while testing XL710
> > with Traffic generator on VM
> >
> > Hi All,
> >
> > I have VF's created for the XL710.
> > I'm using i40e driver version: 2.9.21 and iavf driver: 3.7.53
> >
> > I then run this command , whitelisting XL710 ports.
> >
> > /home/userx/dpdk/x86_64-native-linuxapp-gcc/app/testpmd -c 0x00007 -n
> > 6 -w
> > 0000:00:08.0 -w 0000:00:09.0 --socket-mem=1024 -- --socket-num=0 --nb-
> > cores=2 --coremask=0x0006 --rxq=1 --txq=1 -i --mbcache=512 --burst=64
> > --
> > rxd=2048 --txd=2048 --forward-mode=mac --portmask=0x3
> >
> >
> >
> > I see port as up in traffic generator (both ixia and spirent) and
> > start traffic, but I only see tx on traffic generator end no statistics(rx or tx) on
> XL710 VF side.
> >
> >
> >
> > Is there anything I'm missing?
> >
> >
> >
> >
> >
> > Thanks
> >
> >
> >
> >


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, back to index

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-09-11  2:09 [dpdk-users] no traffic sent/received while testing XL710 with Traffic generator on VM Sampath, Amrutha
2019-09-16  2:42 ` Zhang, Xiao
2019-09-16  2:45   ` Sampath, Amrutha
2019-09-16  2:53     ` Zhang, Xiao

DPDK usage discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/users/0 users/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 users users/ http://inbox.dpdk.org/users \
		users@dpdk.org
	public-inbox-index users


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.users


AGPL code for this site: git clone https://public-inbox.org/ public-inbox