DPDK usage discussions
 help / color / Atom feed
* [dpdk-users] can't compile dpdk on Linux Core 10.1
@ 2019-09-09 15:06 Radovan Brezula
  0 siblings, 0 replies; only message in thread
From: Radovan Brezula @ 2019-09-09 15:06 UTC (permalink / raw)
  To: users

Hello,

I'm trying to compile dpdk 19.08 on Linux Core 10.1 (4.19.10-tinycore64)
with the error message below.  Can you please help me?

tc@box:~/dpdk-master$ make -j2
== Build lib
== Build lib/librte_kvargs
== Build lib/librte_eal
/home/tc/dpdk-master/mk/toolchain/gcc/rte.toolchain-compat.mk:37: AVX512
support disabled because of binutils 2.31. See Bug 249
== Build lib/librte_eal/common
== Build lib/librte_eal/linux
== Build lib/librte_eal/linux/eal
== Build lib/librte_pci
== Build lib/librte_ring
== Build lib/librte_stack
== Build lib/librte_timer
== Build lib/librte_cfgfile
== Build lib/librte_meter
== Build lib/librte_hash
== Build lib/librte_acl
== Build lib/librte_jobstats
== Build lib/librte_metrics
== Build lib/librte_power
== Build lib/librte_rcu
== Build lib/librte_mempool
== Build lib/librte_efd
== Build lib/librte_lpm
== Build lib/librte_member
== Build lib/librte_mbuf
== Build lib/librte_net
== Build lib/librte_bbdev
== Build lib/librte_cryptodev
== Build lib/librte_compressdev
== Build lib/librte_sched
== Build lib/librte_reorder
== Build lib/librte_cmdline
== Build lib/librte_ethdev
== Build lib/librte_security
== Build lib/librte_eventdev
== Build lib/librte_rawdev
== Build lib/librte_vhost
== Build lib/librte_ip_frag
== Build lib/librte_gro
== Build lib/librte_bitratestats
== Build lib/librte_latencystats
== Build lib/librte_kni
== Build lib/librte_distributor
== Build lib/librte_pdump
== Build lib/librte_gso
== Build lib/librte_bpf
== Build lib/librte_ipsec
== Build lib/librte_port
== Build lib/librte_table
== Build lib/librte_flow_classify
== Build lib/librte_pipeline
== Build buildtools
== Build kernel
== Build buildtools/pmdinfogen
== Build kernel/linux
== Build kernel/linux/igb_uio
== Build drivers
== Build drivers/common
== Build drivers/common/cpt
== Build drivers/common/octeontx
== Build drivers/common/octeontx2
 CC [M]  /home/tc/dpdk-master/build/build/kernel/linux/igb_uio/igb_uio.o
== Build drivers/common/dpaax
== Build drivers/bus
In file included from
/usr/src/linux-4.19.10/include/linux/pci-dma-compat.h:8,
                from /usr/src/linux-4.19.10/include/linux/pci.h:2325,
                from
/home/tc/dpdk-master/build/build/kernel/linux/igb_uio/igb_uio.c:10:
/usr/src/linux-4.19.10/include/linux/dma-mapping.h: In function '
igbuio_pci_probe':
/usr/src/linux-4.19.10/include/linux/dma-mapping.h:588:19: error: inlining
failed in call to 'dma_supported.constprop': call is unlikely and code siz
e would grow [-Werror=inline]
static inline int dma_supported(struct device *dev, u64 mask)
                  ^~~~~~~~~~~~~
/usr/src/linux-4.19.10/include/linux/dma-mapping.h:602:25: note: called
from here
 if (!dev->dma_mask || !dma_supported(dev, mask))
                        ^~~~~~~~~~~~~~~~~~~~~~~~
/usr/src/linux-4.19.10/include/linux/dma-mapping.h:588:19: error: inlining
failed in call to 'dma_supported.constprop': call is unlikely and code siz
e would grow [-Werror=inline]
static inline int dma_supported(struct device *dev, u64 mask)
                  ^~~~~~~~~~~~~
/usr/src/linux-4.19.10/include/linux/dma-mapping.h:624:7: note: called from
here
 if (!dma_supported(dev, mask))
      ^~~~~~~~~~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[7]: *** [/usr/src/linux-4.19.10/scripts/Makefile.build:310:
/home/tc/dpdk-master/build/build/kernel/linux/igb_uio/igb_uio.o] Error 1
make[6]: *** [/usr/src/linux-4.19.10/Makefile:1517:
_module_/home/tc/dpdk-master/build/build/kernel/linux/igb_uio] Error 2
make[5]: *** [Makefile:146: sub-make] Error 2
make[4]: *** [/home/tc/dpdk-master/mk/rte.module.mk:51: igb_uio.ko] Error 2
make[3]: *** [/home/tc/dpdk-master/mk/rte.subdir.mk:37: igb_uio] Error 2
make[2]: *** [/home/tc/dpdk-master/mk/rte.subdir.mk:37: linux] Error 2
make[1]: *** [/home/tc/dpdk-master/mk/rte.sdkbuild.mk:48: kernel] Error 2
make[1]: *** Waiting for unfinished jobs....
== Build drivers/bus/dpaa
== Build drivers/bus/fslmc
== Build drivers/bus/ifpga
== Build drivers/bus/pci
== Build drivers/bus/vdev
== Build drivers/bus/vmbus
== Build drivers/mempool
== Build drivers/mempool/bucket
== Build drivers/mempool/dpaa
== Build drivers/mempool/dpaa2
== Build drivers/mempool/ring
== Build drivers/mempool/stack
== Build drivers/mempool/octeontx
== Build drivers/mempool/octeontx2
== Build drivers/net
== Build drivers/baseband
== Build drivers/net/af_packet
== Build drivers/baseband/null
== Build drivers/net/ark
== Build drivers/baseband/turbo_sw
== Build drivers/baseband/fpga_lte_fec
== Build drivers/net/atlantic
== Build drivers/crypto
== Build drivers/net/avp
== Build drivers/crypto/octeontx
== Build drivers/net/axgbe
== Build drivers/crypto/scheduler
== Build drivers/net/bonding
== Build drivers/crypto/null
== Build drivers/net/cxgbe
== Build drivers/crypto/dpaa2_sec
== Build drivers/net/dpaa
== Build drivers/crypto/dpaa_sec
== Build drivers/net/dpaa2
== Build drivers/crypto/caam_jr
== Build drivers/net/e1000
== Build drivers/crypto/virtio
== Build drivers/net/ena
== Build drivers/common/qat
== Build drivers/net/enetc
== Build drivers/compress
== Build drivers/net/enic
== Build drivers/compress/octeontx
== Build drivers/net/failsafe
== Build drivers/net/fm10k
== Build drivers/net/hinic
== Build drivers/net/i40e
== Build drivers/net/iavf
== Build drivers/net/ice
== Build drivers/net/ipn3ke
== Build drivers/net/ixgbe
== Build drivers/net/liquidio
== Build drivers/net/memif
== Build drivers/net/netvsc
== Build drivers/net/nfp
== Build drivers/net/bnxt
== Build drivers/net/null
== Build drivers/net/octeontx
== Build drivers/net/octeontx2
== Build drivers/net/qede
== Build drivers/net/ring
== Build drivers/net/sfc
== Build drivers/net/tap
== Build drivers/net/thunderx
== Build drivers/net/vdev_netvsc
== Build drivers/net/virtio
== Build drivers/net/vmxnet3
== Build drivers/net/kni
== Build drivers/net/softnic
== Build drivers/net/vhost
== Build drivers/net/ifc
== Build drivers/event
== Build drivers/event/skeleton
== Build drivers/event/sw
== Build drivers/event/dsw
== Build drivers/event/octeontx
== Build drivers/event/octeontx2
== Build drivers/event/dpaa
== Build drivers/event/dpaa2
== Build drivers/event/opdl
== Build drivers/raw
== Build drivers/raw/skeleton
== Build drivers/raw/dpaa2_cmdif
== Build drivers/raw/dpaa2_qdma
== Build drivers/raw/ifpga
== Build drivers/raw/ioat
== Build drivers/raw/ntb
== Build drivers/raw/octeontx2_dma
make: *** [/home/tc/dpdk-master/mk/rte.sdkroot.mk:99: all] Error 2

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-09-09 15:06 [dpdk-users] can't compile dpdk on Linux Core 10.1 Radovan Brezula

DPDK usage discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/users/0 users/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 users users/ http://inbox.dpdk.org/users \
		users@dpdk.org
	public-inbox-index users


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.users


AGPL code for this site: git clone https://public-inbox.org/ public-inbox