DPDK usage discussions
 help / color / Atom feed
* [dpdk-users] Regarding pktgen-dpdk
@ 2020-08-28 14:13 Utkarsh Kathuria
  2020-08-28 14:35 ` Wiles, Keith
  0 siblings, 1 reply; 2+ messages in thread
From: Utkarsh Kathuria @ 2020-08-28 14:13 UTC (permalink / raw)
  To: users

Greetings of the day,
I am new to pktgen and dpdk.
I am using dpdk-19.11.3.
I downloaded pktgen-dpdk and when I try to run command make, it gives error
Meson.build:31:0: error: dependency "libbsd" not found , tried pkgconfig
and cmake.

Please help me

Thank you
Regards
Utkarsh

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [dpdk-users] Regarding pktgen-dpdk
  2020-08-28 14:13 [dpdk-users] Regarding pktgen-dpdk Utkarsh Kathuria
@ 2020-08-28 14:35 ` Wiles, Keith
  0 siblings, 0 replies; 2+ messages in thread
From: Wiles, Keith @ 2020-08-28 14:35 UTC (permalink / raw)
  To: Utkarsh Kathuria, users



-----Original Message-----
From: users <users-bounces@dpdk.org>
Date: Friday, August 28, 2020 at 9:14 AM
To: users@dpdk.org <users@dpdk.org>
Subject: [dpdk-users] Regarding pktgen-dpdk
Greetings of the day,
I am new to pktgen and dpdk.
I am using dpdk-19.11.3.
I downloaded pktgen-dpdk and when I try to run command make, it gives error
Meson.build:31:0: error: dependency "libbsd" not found , tried pkgconfig
and cmake.

Unless you need to use 19.11.3 for Pktgen please move to the latest version of DPDK and Pktgen. You can still use DPDK 19.11.3 for your application as Pktgen does not need to use the same version.

I use Ubuntu 20.04 and the command to install libbsd is ‘sudo apt-get install libbsd-dev’, you did not tell me your OS distro and version. I am surprised DPDK would build as it also requires libbsd.

With the latest DPDK and Pktgen versions here are the commands to build pktgen if you have all of the system dependencies addressed.

# cd DPDK
# meson build
# ninja -C build
# sudo ninja -C install

# cd pktgen-dpdk
# make rebuild

The above will build DPDK and install it into your system then build pktgen. Let me know if you have more Pktgen build issues.

Please help me

Thank you
Regards
Utkarsh



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-08-28 14:13 [dpdk-users] Regarding pktgen-dpdk Utkarsh Kathuria
2020-08-28 14:35 ` Wiles, Keith

DPDK usage discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/users/0 users/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 users users/ http://inbox.dpdk.org/users \
		users@dpdk.org
	public-inbox-index users


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.users


AGPL code for this site: git clone https://public-inbox.org/ public-inbox