DPDK patches and discussions
 help / color / mirror / Atom feed
From: Pavan Nikhilesh Bhagavatula <pbhagavatula@caviumnetworks.com>
To: Thomas Monjalon <thomas@monjalon.net>, harry.van.haaren@intel.com
Cc: dev@dpdk.org
Subject: Re: [dpdk-dev] [PATCH] eal: added new `rte_lcore_is_service_lcore` API.
Date: Wed, 20 Sep 2017 23:01:03 +0530	[thread overview]
Message-ID: <20170920173103.GA6627@PBHAGAVATULA-LT> (raw)
In-Reply-To: <1506605.4yxMIA60VI@xps>

On Wed, Sep 20, 2017 at 05:53:04PM +0200, Thomas Monjalon wrote:
> 20/09/2017 16:53, Van Haaren, Harry:
> > From: Pavan Nikhilesh Bhagavatula [mailto:pbhagavatula@caviumnetworks.com]
> > > On Fri, Sep 15, 2017 at 05:51:36PM +0200, Thomas Monjalon wrote:
> > > > 15/09/2017 16:59, Pavan Nikhilesh Bhagavatula:
> > > > > On Fri, Sep 15, 2017 at 02:44:57PM +0000, Van Haaren, Harry wrote:
> > > >
> > > > > > > > > We could also choose to add this function to rte_service.h ?
> > > > > > > >
> > > > > > > > Yes that is an option, and OK with me.
> > > > > > > >
> > > > > > > > @Pavan what do you think of adding it to service.h, implement in .c
> > > and add
> > > > > > > to .map?
> > > > > > > >
> > > > > > >
> > > > > > > The ROLE_SERVICE/ROLE_RTE defines the role of a lcore so it made sense
> > > to put
> > > > > > > it in rte_lcore.h as lcore properties are accessed mostly through this
> > > header.
> > > > > > > I'm fine with adding it to service.h as suggested by Harry.
> > > > > > >
> > > > > > > -Pavan
> > > > > >
> > > > > > *as suggested by Thomas ;)
> > > > > >
> > > > > > Initially I thought it made more sense in lcore.h too, however the
> > > application
> > > > > > should only require knowing if core X is a service core if it cares about
> > > > > > services / service-cores, hence I'm fine with rte_service.h too.
> > > > > >
> > > > > > -Harry
> > > > > >
> > > > > Agreed, will spin up a v2.
> > > >
> > > > The most difficult is to find a good name for this function :)
> > >
> > > If not rte_lcore_is_service_core then how about rte_lcore_is_role_service?
> > > But this would need a sibling api rte_lcore_is_role_rte (or a better one) which
> > > is satisfied by rte_lcore_is_enabled :(
> > > IMO when role was limited to RTE & OFF rte_lcore_is_enabled fits now with
> > > new role SERVICE it looks out of place cause even service lcores are
> > > "enabled".
> > > Modifying rte_lcore_is_enabled would be a huge task (API change) as it is used
> > > widely in many places.
> >
> > Hey all,
> >
> > I've been thinking a little, and adding the "is service core" functionality in the
> > rte_service_* namespace might be the wrong place. The function name certainly doesn't
> > roll off the tongue ( rte_service_lcore_has_service_role() ?? )
> >
> > What if we add a new function to rte_lcore.h? The implementation could be in a
> > new file, rte_lcore.c, to avoid "static inline" in a control-path function.
> >
> > In my eyes, this approach is the cleanest as it allows re-use of the same function
> > for various types, including SERVICE, RTE, OFF etc.
> >
> >
> > /** Probes if the calling core has a specific role.
> >  * @retval 1 If the core has role matching the *role* passed in
> >  * @retval 0 If the core's role does not match *role* passed in
> >  */
> > int
> > rte_lcore_has_role(enum rte_lcore_role_t role);
> >
> >
> > Application code becomes pretty self-documenting:
> > if (rte_lcore_has_role(ROLE_SERVICE)) {
> >     // do something
> > }
> >
> > Thoughts? -Harry
>
> OK, no problem
>
Thanks for all the inputs will spin up a v2.
-Pavan

  reply	other threads:[~2017-09-20 17:31 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-23 15:10 Pavan Nikhilesh
2017-08-28 10:59 ` Van Haaren, Harry
2017-08-28 11:33   ` Pavan Nikhilesh Bhagavatula
2017-08-28 13:49     ` Van Haaren, Harry
2017-08-28 15:09       ` Pavan Nikhilesh Bhagavatula
2017-08-28 15:24         ` Van Haaren, Harry
2017-08-28 15:43           ` Pavan Nikhilesh Bhagavatula
2017-08-29 13:17             ` Van Haaren, Harry
2017-08-29 13:44               ` Pavan Nikhilesh Bhagavatula
2017-09-15 13:52         ` Thomas Monjalon
2017-09-15 13:57           ` Van Haaren, Harry
2017-09-15 14:41             ` Pavan Nikhilesh Bhagavatula
2017-09-15 14:44               ` Van Haaren, Harry
2017-09-15 14:59                 ` Pavan Nikhilesh Bhagavatula
2017-09-15 15:51                   ` Thomas Monjalon
2017-09-15 17:37                     ` Pavan Nikhilesh Bhagavatula
2017-09-20 14:53                       ` Van Haaren, Harry
2017-09-20 15:53                         ` Thomas Monjalon
2017-09-20 17:31                           ` Pavan Nikhilesh Bhagavatula [this message]
2017-09-21  8:58 ` [dpdk-dev] [PATCH v2] eal: add function to check lcore role Pavan Nikhilesh
2017-09-21  9:41   ` Van Haaren, Harry
2017-09-21 10:03     ` Pavan Nikhilesh Bhagavatula
2017-09-21 10:59   ` [dpdk-dev] [PATCH v3] " Pavan Nikhilesh
2017-10-11 20:14     ` Thomas Monjalon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170920173103.GA6627@PBHAGAVATULA-LT \
    --to=pbhagavatula@caviumnetworks.com \
    --cc=dev@dpdk.org \
    --cc=harry.van.haaren@intel.com \
    --cc=thomas@monjalon.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).