From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-la0-x22b.google.com (mail-la0-x22b.google.com [IPv6:2a00:1450:4010:c03::22b]) by dpdk.org (Postfix) with ESMTP id 5269E68B8 for ; Fri, 4 Oct 2013 19:06:33 +0200 (CEST) Received: by mail-la0-f43.google.com with SMTP id ep20so3506992lab.16 for ; Fri, 04 Oct 2013 10:07:16 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=from:to:cc:subject:date:message-id; bh=n/ubUON4SnhcIb79Dc6W1sucAe7eoWDRpwE8/tX5Nlw=; b=a50kqDiF5nPdVbdC7nL4pIejRCIdxGrAy864spc4pmOEnsO96twahqPUzpJpGywCYu 7XWSdPNwN9W4xHaTCIPShvEhnT2ZQ1ilm1u5sbhS/ZmXqOcVfruN6qTSY0d7GVvhQieG JctSMWENuFVGeHz7aEMTaAuuCsckxhdly4KbytDQcfeqUsLgd/gl1imIHFmMACcjDfN1 pktl67DI6vDN8vHJdrufxS0YV3z8oiDr1kOtoAPLcQNerH08Os2GU7DEbsyKpE2rMGxz O//Y4/bXIILzDrEJiotM3tJrBeqbq4m2YBHkN4EPVuxSZ2u1vt591W/jv/zmWpcWNAqQ ENIA== X-Received: by 10.112.210.136 with SMTP id mu8mr12495661lbc.25.1380906436263; Fri, 04 Oct 2013 10:07:16 -0700 (PDT) Received: from localhost.localdomain (cs181018128.pp.htv.fi. [82.181.18.128]) by mx.google.com with ESMTPSA id i3sm11878771laf.4.1969.12.31.16.00.00 (version=TLSv1.2 cipher=ECDHE-RSA-RC4-SHA bits=128/128); Fri, 04 Oct 2013 10:07:15 -0700 (PDT) From: Qinglai Xiao To: dev@dpdk.org Date: Fri, 4 Oct 2013 20:06:52 +0300 Message-Id: <1380906413-3406-1-git-send-email-jigsaw@gmail.com> X-Mailer: git-send-email 1.7.10.4 Subject: [dpdk-dev] [PATCH] Request for comments on ixgbe TSO support X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Fri, 04 Oct 2013 17:06:33 -0000 This patch is a draft of TSO on 82599. That is, it is not expected to be accepted as is. The problem is where to put the mss field. In this patch, the mss is put in the union of hash in rte_pktmbuf. It is not the best place, but it is quite convenient, since hash is not used in TX procedure. The idea is to avoid increasing sizeof(struct rte_pktmbuf), while keeping mss easy to access. However, the hash is also misleading, coz mss has nothing to do with Rx hash. A more formal way could be rename hash as below: union { uint32_t data; struct rx_hash hash; uint32_t tx_mss; } misc; It is gonna be a major change coz it affects the core data structure. Any comments will be appreciated. Qinglai Xiao (1): ixgbe: TCP/UDP segment offload support on 82599. lib/librte_mbuf/rte_mbuf.h | 6 +++++- lib/librte_pmd_ixgbe/ixgbe_rxtx.c | 32 +++++++++++++++++++++++++++++--- 2 files changed, 34 insertions(+), 4 deletions(-) -- 1.7.10.4