From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mga03.intel.com (mga03.intel.com [134.134.136.65]) by dpdk.org (Postfix) with ESMTP id 32BD1C562 for ; Fri, 29 Jan 2016 08:07:02 +0100 (CET) Received: from fmsmga001.fm.intel.com ([10.253.24.23]) by orsmga103.jf.intel.com with ESMTP; 28 Jan 2016 23:07:01 -0800 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.22,362,1449561600"; d="scan'208";a="891676614" Received: from yliu-dev.sh.intel.com (HELO yliu-dev) ([10.239.66.49]) by fmsmga001.fm.intel.com with ESMTP; 28 Jan 2016 23:06:59 -0800 Date: Fri, 29 Jan 2016 15:07:46 +0800 From: Yuanhan Liu To: Santosh Shukla Message-ID: <20160129070746.GP4257@yliu-dev.sh.intel.com> References: <1453203972-24855-1-git-send-email-sshukla@mvista.com> <1453203972-24855-7-git-send-email-sshukla@mvista.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1453203972-24855-7-git-send-email-sshukla@mvista.com> User-Agent: Mutt/1.5.23 (2014-03-12) Cc: dev@dpdk.org, Rakesh Krishnamurthy , Rizwan Ansari Subject: Re: [dpdk-dev] [PATCH v5 06/11] virtio: vfio: add api support to rd/wr ioport bar X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Fri, 29 Jan 2016 07:07:02 -0000 On Tue, Jan 19, 2016 at 05:16:07PM +0530, Santosh Shukla wrote: > For vfio case - Use pread/pwrite api to access virtio > ioport space. > > Applicable for virtio 0.95 spec. > > Signed-off-by: Santosh Shukla > Signed-off-by: Rizwan Ansari > Signed-off-by: Rakesh Krishnamurthy > --- > v4 --> v5: > - Removed unnecessary type casting. > > drivers/net/virtio/virtio_vfio_rw.h | 104 +++++++++++++++++++++++++++++++++++ > 1 file changed, 104 insertions(+) > create mode 100644 drivers/net/virtio/virtio_vfio_rw.h > > diff --git a/drivers/net/virtio/virtio_vfio_rw.h b/drivers/net/virtio/virtio_vfio_rw.h > new file mode 100644 > index 0000000..a9ab04d > --- /dev/null > +++ b/drivers/net/virtio/virtio_vfio_rw.h Maybe virtio_vfio.h is enough, or if you have to put a sufix there, _io (instead of _rw) is a better option to me. > + > +/* vfio rd/rw virtio apis */ > +static inline void > +ioport_inb(const struct rte_pci_device *pci_dev, uint8_t reg, uint8_t *val) vfio_inb is a better name; ioport_inb is too generic. --yliu