From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mga09.intel.com (mga09.intel.com [134.134.136.24]) by dpdk.org (Postfix) with ESMTP id ECB0BFB59 for ; Tue, 20 Dec 2016 12:13:46 +0100 (CET) Received: from fmsmga001.fm.intel.com ([10.253.24.23]) by orsmga102.jf.intel.com with ESMTP; 20 Dec 2016 03:13:45 -0800 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.33,378,1477983600"; d="scan'208";a="1084530585" Received: from bricha3-mobl3.ger.corp.intel.com ([10.237.221.64]) by fmsmga001.fm.intel.com with SMTP; 20 Dec 2016 03:13:43 -0800 Received: by (sSMTP sendmail emulation); Tue, 20 Dec 2016 11:13:42 +0000 Date: Tue, 20 Dec 2016 11:13:42 +0000 From: Bruce Richardson To: Jerin Jacob Cc: dev@dpdk.org, thomas.monjalon@6wind.com, hemant.agrawal@nxp.com, gage.eads@intel.com, harry.van.haaren@intel.com Message-ID: <20161220111342.GA201880@bricha3-MOBL3.ger.corp.intel.com> References: <1480798539-13360-1-git-send-email-jerin.jacob@caviumnetworks.com> <1482070895-32491-1-git-send-email-jerin.jacob@caviumnetworks.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1482070895-32491-1-git-send-email-jerin.jacob@caviumnetworks.com> Organization: Intel Research and =?iso-8859-1?Q?De=ACvel?= =?iso-8859-1?Q?opment?= Ireland Ltd. User-Agent: Mutt/1.7.1 (2016-10-04) Subject: Re: [dpdk-dev] [PATCH v3 0/6] libeventdev API and northbound implementation X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Tue, 20 Dec 2016 11:13:47 -0000 On Sun, Dec 18, 2016 at 07:51:29PM +0530, Jerin Jacob wrote: > As previously discussed in RFC v1 [1], RFC v2 [2], with changes > described in [3] (also pasted below), here is the first non-draft series > for this new API. > > [1] http://dpdk.org/ml/archives/dev/2016-August/045181.html > [2] http://dpdk.org/ml/archives/dev/2016-October/048592.html > [3] http://dpdk.org/ml/archives/dev/2016-October/048196.html > > v2..v3: > > 1) Changed struct rte_event layout more aligment balanced(Harry, Jerin) > 2) Changed event_ptr type to void* from uintptr_t(Bruce) > 3) Changed ev[] as const in rte_event_enqueue_burst to disallow > drivers from modifying the events passed in(Bruce) > 4) Removed queue memory allocation from common code as some drivers may not need > it(Bruce) > 5) Removed "struct rte_event_queue_link" and replaced with queues and priorities > in the link and link_get API to avoid one redirection to use the API(Bruce) > > v1..v2: > 1) Remove unnecessary header files from rte_eventdev.h(Thomas) > 2) Removed PMD driver name(EVENTDEV_NAME_SKELETON_PMD) from rte_eventdev.h(Thomas) > 3) Removed different #define for different priority schemes. Changed to > one event device RTE_EVENT_DEV_PRIORITY_* priority (Bruce) > 4) add const to rte_event_dev_configure(), rte_event_queue_setup(), > rte_event_port_setup(), rte_event_port_link()(Bruce) > 5) Fixed missing dev argument in dev->schedule() function(Bruce) > 6) Changed \see to @see in doxgen comments(Thomas) > 7) Added additional text in specification to clarify the queue depth(Thomas) > 8) Changed wait to timeout across the specification(Thomas) > 9) Added longer explanation for RTE_EVENT_OP_NEW and RTE_EVENT_OP_FORWARD(Thomas) > 10) Fixed issue with RTE_EVENT_OP_RELEASE doxgen formatting(Thomas) > 11) Changed to RTE_EVENT_DEV_CFG_FLAG_ from RTE_EVENT_DEV_CFG_(Thomas) > 12) Changed to EVENT_QUEUE_CFG_FLAG_ from EVENT_QUEUE_CFG_(Thomas) > 13) s/RTE_EVENT_TYPE_CORE/RTE_EVENT_TYPE_CPU/(Thomas, Gage) > 14) Removed non burst API and kept only the burst API in the API specification > (Thomas, Bruce, Harry, Jerin) > -- Driver interface has non burst API, selection of the non burst API is based > on num_objects == 1 > 15) sizeeof(struct rte_event) was not 16 in v1. Fixed it in v2 > -- reduced the width of event_type to 4bit to save space for future change > -- introduced impl_opaque for implementation specific opaque data(Harry), > Something useful for HW driver too, in the context of removal the need for sepeare > release API. > -- squashed other element size and provided enough space to impl_opaque(Jerin) > -- added RTE_BUILD_BUG_ON(sizeof(struct rte_event) != 16); check > 16) add union of uint64_t in the second element in struct rte_event to > make sure the structure has 16byte address all arch(Thomas) > 17) Fixed invalid check of nb_atomic_order_sequences in implementation(Gage) > 18) s/EDEV_LOG_ERR/RTE_EDEV_LOG_ERR(Thomas) > 19) s/rte_eventdev_pmd_/rte_event_pmd_/(Bruce) > 20) added fine details of distributed vs centralized scheduling information > in the specification and introduced RTE_EVENT_DEV_CAP_FLAG_DISTRIBUTED_SCHED > flag(Gage) > 21)s/RTE_EVENT_QUEUE_CFG_FLAG_SINGLE_CONSUMER/RTE_EVENT_QUEUE_CFG_FLAG_SINGLE_LINK (Jerin) > to remove the confusion to between another producer and consumer in sw eventdev driver > 22) Northbound api implementation patch spited to more logical patches(Thomas) > > Changes since RFC v2: > > - Updated the documentation to define the need for this library[Jerin] > - Added RTE_EVENT_QUEUE_CFG_*_ONLY configuration parameters in > struct rte_event_queue_conf to enable optimized sw implementation [Bruce] > - Introduced RTE_EVENT_OP* ops [Bruce] > - Added nb_event_queue_flows,nb_event_port_dequeue_depth, nb_event_port_enqueue_depth > in rte_event_dev_configure() like ethdev and crypto library[Jerin] > - Removed rte_event_release() and replaced with RTE_EVENT_OP_RELEASE ops to > reduce fast path APIs and it is redundant too[Jerin] > - In the view of better application portability, Removed pin_event > from rte_event_enqueue as it is just hint and Intel/NXP can not support it[Jerin] > - Added rte_event_port_links_get()[Jerin] > - Added rte_event_dev_dump[Harry] > > Notes: > > - This patch set is check-patch clean with an exception that > 03/06 has one WARNING:MACRO_WITH_FLOW_CONTROL > - Looking forward to getting additional maintainers for libeventdev > > TODO: > 1) Create user guide > > Jerin Jacob (6): > eventdev: introduce event driven programming model > eventdev: define southbound driver interface > eventdev: implement the northbound APIs > eventdev: implement PMD registration functions > event/skeleton: add skeleton eventdev driver > app/test: unit test case for eventdev APIs > Hi Jerin, other than the couple of comments I've made in replies to the individual patches, this looks pretty good to me. Only additional comment I have is that some of the macro names are a little long, and maybe we can shorten them For example, you've added "_FLAG_" into the config flag macros, and I'm not sure that is necessary. Similarly, I think we can drop "_DEV_" from the PRIORITY names to shorten them. Irrespective of these naming suggestions, once the other couple of comments are taken care of, I think this set is suitable for merging to the next-event tree. Series Acked-by: Bruce Richardson Regards, /Bruce