DPDK patches and discussions
 help / color / mirror / Atom feed
From: Bruce Richardson <bruce.richardson@intel.com>
To: Shreyansh Jain <shreyansh.jain@nxp.com>
Cc: dev@dpdk.org, ferruh.yigit@intel.com, thomas@monjalon.net,
	matan@mellanox.com, konstantin.ananyev@intel.com,
	hemant.agrawal@nxp.com
Subject: Re: [dpdk-dev] [PATCH v2] doc: add preferred burst size support
Date: Thu, 1 Feb 2018 14:19:33 +0000	[thread overview]
Message-ID: <20180201141933.GA14048@bricha3-MOBL3.ger.corp.intel.com> (raw)
In-Reply-To: <78379784-5872-b051-bede-27ee4a8c0845@nxp.com>

On Thu, Feb 01, 2018 at 07:58:32PM +0530, Shreyansh Jain wrote:
> On Thursday 01 February 2018 06:57 PM, Bruce Richardson wrote:
> > On Thu, Feb 01, 2018 at 06:18:23PM +0530, Shreyansh Jain wrote:
> > > rte_eth_rx_burst(..,nb_pkts) function has semantic that if return value
> > > is smaller than requested, application can consider it end of packet
> > > stream. Some hardware can only support smaller burst sizes which need
> > > to be advertised. Similar is the case for Tx burst.
> > > 
> > > This patch adds deprecation notice for rte_eth_dev_info structure as
> > > two new members, for preferred Rx and Tx burst size would be added -
> > > impacting the size of the structure.
> > > 
> > > Signed-off-by: Shreyansh Jain <shreyansh.jain@nxp.com>
> > > ---
> > > * Refer: http://dpdk.org/dev/patchwork/patch/32112 for context
> > > 
> > > v2:
> > >   - fix spelling error in deprecation notice
> > > 
> > >   doc/guides/rel_notes/deprecation.rst | 8 ++++++++
> > >   1 file changed, 8 insertions(+)
> > > 
> > > diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> > > index d59ad5988..fdc7656fa 100644
> > > --- a/doc/guides/rel_notes/deprecation.rst
> > > +++ b/doc/guides/rel_notes/deprecation.rst
> > > @@ -59,3 +59,11 @@ Deprecation Notices
> > >     be added between the producer and consumer structures. The size of the
> > >     structure and the offset of the fields will remain the same on
> > >     platforms with 64B cache line, but will change on other platforms.
> > > +
> > > +* ethdev:  Currently, if the  rte_eth_rx_burst() function returns a value less
> > > +  than *nb_pkts*, the application will assume that no more packets are present.
> > > +  Some of the hw queue based hardware can only support smaller burst for RX
> > > +  and TX and thus break the expectation of the rx_burst API. Similar is the
> > > +  case for TX burst. ``rte_eth_dev_info`` will be added with two new
> > > +  parameters, ``uint16_t pref_rx_burst`` and ``uint16_t pref_tx_burst``,
> > > +  for preferred RX and TX burst sizes, respectively.
> > > -- 
> > > 2.14.1
> > > 
> > 
> > LTGM as far as it goes, but following discussion on this patch,
> > http://dpdk.org/ml/archives/dev/2018-January/089585.html
> > I think we might also want to add in parameters for "pref_tx_ring_sz"
> > and "pref_rx_ring_sz" too. While it is the case that, once the structure
> > is changed, we can make multiple additional changes, I think it might be
> > worth mentioning as many as we can for completeness.
> > 
> > Another point to consider, is whether we might want to add in a
> > sub-structure for "preferred_settings" to hold all these, rather than
> > just adding them as new fields. It might help with making names more
> > readable (though also longer).
> > 
> > 	struct {
> > 		uint16_t rx_burst;
> > 		uint16_t tx_burst;
> > 		uint16_t rx_ring_sz;
> > 		uint16_t tx_ring_sz;
> > 	} preferred_settings;
> 
> This, and the point above that we can make multiple additional changes, is
> definitely a good idea. Though, 'preferred_setting' is long and has chances
> of spell mistakes in first go - what about just 'pref' or, 'pref_size' if
> only 4 mentioned above are part of this.
> 
> For now I saw need for burst size because I hit that case. Ring size looks
> logical to me. We can have a look if more such toggles are required.
> 

I actually don't like the abbreviation "pref", as it looks too much like
"perf" short for performance. As this is an initialization setting, I
also don't think having a longer name is that big of deal. How about
calling them "suggested" or "recommended" settings - both of which have
less fiddly spellings.

/Bruce

  reply	other threads:[~2018-02-01 14:19 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-02-01 12:44 [dpdk-dev] [PATCH] " Shreyansh Jain
2018-02-01 12:48 ` [dpdk-dev] [PATCH v2] " Shreyansh Jain
2018-02-01 12:52   ` Hemant Agrawal
2018-02-01 12:52   ` Andrew Rybchenko
2018-02-01 13:27   ` Bruce Richardson
2018-02-01 14:28     ` Shreyansh Jain
2018-02-01 14:19       ` Bruce Richardson [this message]
2018-02-05  5:39         ` Shreyansh Jain
2018-02-05  6:22   ` [dpdk-dev] [PATCH v3] " Shreyansh Jain
2018-02-05  6:17     ` Yang, Zhiyong
2018-02-13 23:55       ` Thomas Monjalon
2018-02-14 16:31         ` Thomas Monjalon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180201141933.GA14048@bricha3-MOBL3.ger.corp.intel.com \
    --to=bruce.richardson@intel.com \
    --cc=dev@dpdk.org \
    --cc=ferruh.yigit@intel.com \
    --cc=hemant.agrawal@nxp.com \
    --cc=konstantin.ananyev@intel.com \
    --cc=matan@mellanox.com \
    --cc=shreyansh.jain@nxp.com \
    --cc=thomas@monjalon.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).