From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from dpdk.org (dpdk.org [92.243.14.124]) by dpdk.space (Postfix) with ESMTP id A91B1A00E6 for ; Tue, 19 Mar 2019 11:09:58 +0100 (CET) Received: from [92.243.14.124] (localhost [127.0.0.1]) by dpdk.org (Postfix) with ESMTP id C38F22956; Tue, 19 Mar 2019 11:09:57 +0100 (CET) Received: from mga11.intel.com (mga11.intel.com [192.55.52.93]) by dpdk.org (Postfix) with ESMTP id 640EB25A1 for ; Tue, 19 Mar 2019 11:09:56 +0100 (CET) X-Amp-Result: UNKNOWN X-Amp-Original-Verdict: FILE UNKNOWN X-Amp-File-Uploaded: False Received: from fmsmga008.fm.intel.com ([10.253.24.58]) by fmsmga102.fm.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 19 Mar 2019 03:09:55 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.58,497,1544515200"; d="scan'208";a="132827157" Received: from dpdk-tbie.sh.intel.com ([10.67.104.173]) by fmsmga008.fm.intel.com with ESMTP; 19 Mar 2019 03:09:54 -0700 Date: Tue, 19 Mar 2019 18:09:39 +0800 From: Tiwei Bie To: Jens Freimann Cc: maxime.coquelin@redhat.com, zhihong.wang@intel.com, dev@dpdk.org Message-ID: <20190319100939.GA3839@dpdk-tbie.sh.intel.com> References: <20190319064312.13743-1-tiwei.bie@intel.com> <20190319064312.13743-6-tiwei.bie@intel.com> <20190319094432.iap4i7ffs6soukr7@jenstp.localdomain> MIME-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Content-Disposition: inline In-Reply-To: <20190319094432.iap4i7ffs6soukr7@jenstp.localdomain> User-Agent: Mutt/1.9.4 (2018-02-28) Subject: Re: [dpdk-dev] [PATCH 05/10] net/virtio: refactor virtqueue structure X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Message-ID: <20190319100939.noqo0U9kx9MGn4U4W6lKp6OyAofw682ykweg6vB1Ooo@z> On Tue, Mar 19, 2019 at 10:44:32AM +0100, Jens Freimann wrote: > On Tue, Mar 19, 2019 at 02:43:07PM +0800, Tiwei Bie wrote: > > Put split ring and packed ring specific fields into separate > > sub-structures, and also union them as they won't be available > > at the same time. > > > > Signed-off-by: Tiwei Bie > > --- > > drivers/net/virtio/virtio_ethdev.c | 71 +++++++++--------- > > drivers/net/virtio/virtio_rxtx.c | 66 ++++++++--------- > > drivers/net/virtio/virtio_rxtx_simple.h | 2 +- > > drivers/net/virtio/virtio_rxtx_simple_neon.c | 2 +- > > drivers/net/virtio/virtio_rxtx_simple_sse.c | 2 +- > > drivers/net/virtio/virtqueue.c | 6 +- > > drivers/net/virtio/virtqueue.h | 77 +++++++++++--------- > > 7 files changed, 117 insertions(+), 109 deletions(-) > > > [snip] > ... > > diff --git a/drivers/net/virtio/virtqueue.h b/drivers/net/virtio/virtqueue.h > > index 80c0c43c3..48b3912e6 100644 > > --- a/drivers/net/virtio/virtqueue.h > > +++ b/drivers/net/virtio/virtqueue.h > > @@ -191,17 +191,22 @@ struct vq_desc_extra { > > > > struct virtqueue { > > struct virtio_hw *hw; /**< virtio_hw structure pointer. */ > > - struct vring vq_ring; /**< vring keeping desc, used and avail */ > > - struct vring_packed ring_packed; /**< vring keeping descs */ > > - bool used_wrap_counter; > > - uint16_t cached_flags; /**< cached flags for descs */ > > - uint16_t event_flags_shadow; > > + union { > > + struct { > > + /**< vring keeping desc, used and avail */ > > + struct vring ring; > > + } vq_split; > > > > - /** > > - * Last consumed descriptor in the used table, > > - * trails vq_ring.used->idx. > > - */ > > - uint16_t vq_used_cons_idx; > > + struct { > > + /**< vring keeping descs and events */ > > + struct vring_packed ring; > > + bool used_wrap_counter; > > + uint16_t cached_flags; /**< cached flags for descs */ > > + uint16_t event_flags_shadow; > > + } vq_packed; > > + }; > > + > > + uint16_t vq_used_cons_idx; /**< last consumed descriptor */ > > uint16_t vq_nentries; /**< vring desc numbers */ > > uint16_t vq_free_cnt; /**< num of desc available */ > > uint16_t vq_avail_idx; /**< sync until needed */ > > Honest question: What do we really gain by putting it in a union? We > save a little memory. But we also make code less readable IMHO. I think it will make it clear that fields like used_wrap_counter are only available in packed ring which will make the code more readable. > > If we do this, can we at least shorten some variable names, like drop > the vq_ prefix? (It's used everywhere like vq->vq_packed*, so with > vq->packed* we don't loose any context). I prefer to have consistent prefix like most fields in this structure (although some fields don't really follow this). Thanks, Tiwei > > I'm not strictly against this change but I'm wondering if it's worth > it. > > regards, > Jens >