From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from dpdk.org (dpdk.org [92.243.14.124]) by dpdk.space (Postfix) with ESMTP id E33C7A00E6 for ; Wed, 20 Mar 2019 05:35:49 +0100 (CET) Received: from [92.243.14.124] (localhost [127.0.0.1]) by dpdk.org (Postfix) with ESMTP id A97D01DBD; Wed, 20 Mar 2019 05:35:48 +0100 (CET) Received: from mga05.intel.com (mga05.intel.com [192.55.52.43]) by dpdk.org (Postfix) with ESMTP id 39EBF5A for ; Wed, 20 Mar 2019 05:35:47 +0100 (CET) X-Amp-Result: UNKNOWN X-Amp-Original-Verdict: FILE UNKNOWN X-Amp-File-Uploaded: False Received: from fmsmga006.fm.intel.com ([10.253.24.20]) by fmsmga105.fm.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 19 Mar 2019 21:35:45 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.60,247,1549958400"; d="scan'208";a="328848252" Received: from dpdk-tbie.sh.intel.com ([10.67.104.173]) by fmsmga006.fm.intel.com with ESMTP; 19 Mar 2019 21:35:44 -0700 Date: Wed, 20 Mar 2019 12:35:30 +0800 From: Tiwei Bie To: Maxime Coquelin Cc: Jens Freimann , zhihong.wang@intel.com, dev@dpdk.org Message-ID: <20190320043529.GA19833@dpdk-tbie.sh.intel.com> References: <20190319064312.13743-1-tiwei.bie@intel.com> <20190319064312.13743-6-tiwei.bie@intel.com> <20190319094432.iap4i7ffs6soukr7@jenstp.localdomain> <20190319100939.GA3839@dpdk-tbie.sh.intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.9.4 (2018-02-28) Subject: Re: [dpdk-dev] [PATCH 05/10] net/virtio: refactor virtqueue structure X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Message-ID: <20190320043530.-3EHwGezO8reeiOlZM-67dqEMidVYzHQpo9jo8CefNw@z> On Tue, Mar 19, 2019 at 02:28:30PM +0100, Maxime Coquelin wrote: > On 3/19/19 11:09 AM, Tiwei Bie wrote: > > On Tue, Mar 19, 2019 at 10:44:32AM +0100, Jens Freimann wrote: > > > On Tue, Mar 19, 2019 at 02:43:07PM +0800, Tiwei Bie wrote: > > > > Put split ring and packed ring specific fields into separate > > > > sub-structures, and also union them as they won't be available > > > > at the same time. > > > > > > > > Signed-off-by: Tiwei Bie > > > > --- > > > > drivers/net/virtio/virtio_ethdev.c | 71 +++++++++--------- > > > > drivers/net/virtio/virtio_rxtx.c | 66 ++++++++--------- > > > > drivers/net/virtio/virtio_rxtx_simple.h | 2 +- > > > > drivers/net/virtio/virtio_rxtx_simple_neon.c | 2 +- > > > > drivers/net/virtio/virtio_rxtx_simple_sse.c | 2 +- > > > > drivers/net/virtio/virtqueue.c | 6 +- > > > > drivers/net/virtio/virtqueue.h | 77 +++++++++++--------- > > > > 7 files changed, 117 insertions(+), 109 deletions(-) > > > > > > > [snip] > > > ... > > > > diff --git a/drivers/net/virtio/virtqueue.h b/drivers/net/virtio/virtqueue.h > > > > index 80c0c43c3..48b3912e6 100644 > > > > --- a/drivers/net/virtio/virtqueue.h > > > > +++ b/drivers/net/virtio/virtqueue.h > > > > @@ -191,17 +191,22 @@ struct vq_desc_extra { > > > > > > > > struct virtqueue { > > > > struct virtio_hw *hw; /**< virtio_hw structure pointer. */ > > > > - struct vring vq_ring; /**< vring keeping desc, used and avail */ > > > > - struct vring_packed ring_packed; /**< vring keeping descs */ > > > > - bool used_wrap_counter; > > > > - uint16_t cached_flags; /**< cached flags for descs */ > > > > - uint16_t event_flags_shadow; > > > > + union { > > > > + struct { > > > > + /**< vring keeping desc, used and avail */ > > > > + struct vring ring; > > > > + } vq_split; > > > > > > > > - /** > > > > - * Last consumed descriptor in the used table, > > > > - * trails vq_ring.used->idx. > > > > - */ > > > > - uint16_t vq_used_cons_idx; > > > > + struct { > > > > + /**< vring keeping descs and events */ > > > > + struct vring_packed ring; > > > > + bool used_wrap_counter; > > > > + uint16_t cached_flags; /**< cached flags for descs */ > > > > + uint16_t event_flags_shadow; > > > > + } vq_packed; > > > > + }; > > > > + > > > > + uint16_t vq_used_cons_idx; /**< last consumed descriptor */ > > > > uint16_t vq_nentries; /**< vring desc numbers */ > > > > uint16_t vq_free_cnt; /**< num of desc available */ > > > > uint16_t vq_avail_idx; /**< sync until needed */ > > > > > > Honest question: What do we really gain by putting it in a union? We > > > save a little memory. But we also make code less readable IMHO. > > > > I think it will make it clear that fields like used_wrap_counter > > are only available in packed ring which will make the code more > > readable. > > > > > > > > If we do this, can we at least shorten some variable names, like drop > > > the vq_ prefix? (It's used everywhere like vq->vq_packed*, so with > > > vq->packed* we don't loose any context). > > > > I prefer to have consistent prefix like most fields in this > > structure (although some fields don't really follow this). > > As Jens, I tend to agree that the vq_ prefix is quite redundant. > However, I think it is better to keep it in this patch for consistency. > > Maybe it can be remove in a separate patch later? Sounds good to me.