DPDK patches and discussions
 help / color / mirror / Atom feed
From: Nicolas Chautru <nicolas.chautru@intel.com>
To: dev@dpdk.org, maxime.coquelin@redhat.com
Cc: hernan.vargas@intel.com, Nicolas Chautru <nicolas.chautru@intel.com>
Subject: [PATCH v1 0/6] baseband/acc: ACC200 PMD refactor and rename
Date: Tue, 17 Jan 2023 22:36:36 +0000	[thread overview]
Message-ID: <20230117223642.17618-1-nicolas.chautru@intel.com> (raw)

In this serie we are renaming the ACC200PMD to a more generic
VRB PMD (Intel vRAN Boost). The 2nd commit is also making sure this
is future prood to be able to support both the first implementation
of VRB (The one in SPR-EE) as well as future implementations of
integrated product.
Most of changes are really rename to a large extend aanmaking the 
distinction of what is specific to current implementation (VRB1)
vs more generic functions (VRB) which would be common to VRB1, 
VRB2, etc...

Nicolas Chautru (6):
  baseband/acc: file renaming from acc200 to generic vrb
  baseband/acc: extension of the device structure
  baseband/acc: adding prefix to VRB1 registers
  baseband/acc: update prefix for VRB PMD functions
  baseband/acc: rename of remaining acc200 prefix to vrb1
  doc: updated naming convention for acc200 PMD

 .../bbdevs/features/{acc200.ini => vrb1.ini}  |   2 +-
 doc/guides/bbdevs/{acc200.rst => vrb1.rst}    |  33 +-
 drivers/baseband/acc/acc200_pf_enum.h         | 108 ---
 drivers/baseband/acc/acc200_pmd.h             | 196 -----
 drivers/baseband/acc/acc200_vf_enum.h         |  83 --
 drivers/baseband/acc/acc_common.h             |  18 +-
 drivers/baseband/acc/meson.build              |   2 +-
 drivers/baseband/acc/rte_acc100_pmd.c         |   6 +-
 .../acc/{rte_acc200_pmd.c => rte_vrb_pmd.c}   | 820 +++++++++---------
 drivers/baseband/acc/vrb1_pf_enum.h           | 108 +++
 drivers/baseband/acc/vrb1_vf_enum.h           |  83 ++
 .../baseband/acc/{acc200_cfg.h => vrb_cfg.h}  |  16 +-
 drivers/baseband/acc/vrb_pmd.h                | 208 +++++
 13 files changed, 843 insertions(+), 840 deletions(-)
 rename doc/guides/bbdevs/features/{acc200.ini => vrb1.ini} (83%)
 rename doc/guides/bbdevs/{acc200.rst => vrb1.rst} (90%)
 delete mode 100644 drivers/baseband/acc/acc200_pf_enum.h
 delete mode 100644 drivers/baseband/acc/acc200_pmd.h
 delete mode 100644 drivers/baseband/acc/acc200_vf_enum.h
 rename drivers/baseband/acc/{rte_acc200_pmd.c => rte_vrb_pmd.c} (82%)
 create mode 100644 drivers/baseband/acc/vrb1_pf_enum.h
 create mode 100644 drivers/baseband/acc/vrb1_vf_enum.h
 rename drivers/baseband/acc/{acc200_cfg.h => vrb_cfg.h} (65%)
 create mode 100644 drivers/baseband/acc/vrb_pmd.h

-- 
2.34.1


             reply	other threads:[~2023-01-17 22:40 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-17 22:36 Nicolas Chautru [this message]
2023-01-17 22:36 ` [PATCH v1 1/6] baseband/acc: file renaming from acc200 to generic vrb Nicolas Chautru
2023-01-31 14:23   ` Maxime Coquelin
2023-01-17 22:36 ` [PATCH v1 2/6] baseband/acc: extension of the device structure Nicolas Chautru
2023-01-31 14:44   ` Maxime Coquelin
2023-01-17 22:36 ` [PATCH v1 3/6] baseband/acc: adding prefix to VRB1 registers Nicolas Chautru
2023-01-31 14:45   ` Maxime Coquelin
2023-01-17 22:36 ` [PATCH v1 4/6] baseband/acc: update prefix for VRB PMD functions Nicolas Chautru
2023-01-31 14:51   ` Maxime Coquelin
2023-01-17 22:36 ` [PATCH v1 5/6] baseband/acc: rename of remaining acc200 prefix to vrb1 Nicolas Chautru
2023-01-31 15:11   ` Maxime Coquelin
2023-01-17 22:36 ` [PATCH v1 6/6] doc: updated naming convention for acc200 PMD Nicolas Chautru
2023-01-31 15:11   ` Maxime Coquelin
2023-02-07  8:00     ` David Marchand
2023-02-07  8:08       ` David Marchand
2023-02-03 11:03 ` [PATCH v1 0/6] baseband/acc: ACC200 PMD refactor and rename Maxime Coquelin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230117223642.17618-1-nicolas.chautru@intel.com \
    --to=nicolas.chautru@intel.com \
    --cc=dev@dpdk.org \
    --cc=hernan.vargas@intel.com \
    --cc=maxime.coquelin@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).