DPDK patches and discussions
 help / color / mirror / Atom feed
From: Thomas Monjalon <thomas@monjalon.net>
To: "Ananyev, Konstantin" <konstantin.ananyev@intel.com>
Cc: dev@dpdk.org, "Joseph, Anoob" <Anoob.Joseph@cavium.com>,
	Akhil Goyal <akhil.goyal@nxp.com>,
	Ravi Kumar <ravi1.kumar@amd.com>,
	"Jacob, Jerin" <Jerin.JacobKollanukkaran@cavium.com>,
	"Doherty, Declan" <declan.doherty@intel.com>,
	"Trahe, Fiona" <fiona.trahe@intel.com>,
	Tomasz Duszynski <tdu@semihalf.com>,
	Dmitri Epshtein <dima@marvell.com>,
	Natalie Samsonov <nsamsono@marvell.com>,
	Jay Zhou <jianjay.zhou@huawei.com>,
	"Athreya, Narayana Prasad" <NarayanaPrasad.Athreya@cavium.com>,
	"Verma, Shally" <Shally.Verma@cavium.com>,
	"Dwivedi, Ankur" <Ankur.Dwivedi@cavium.com>
Subject: Re: [dpdk-dev] [PATCH] doc: cryptodev deprecation notice for sym session changes
Date: Sat, 24 Nov 2018 19:07:57 +0100	[thread overview]
Message-ID: <6921091.9xEsaLRtPN@xps> (raw)
In-Reply-To: <SN6PR07MB49110FCCD3660DBEB9AE4E53F8C30@SN6PR07MB4911.namprd07.prod.outlook.com>

14/11/2018 11:12, Joseph, Anoob:
> From: Ananyev, Konstantin <konstantin.ananyev@intel.com>
> > 
> > Hi Anoob,
> > 
> > >
> > > Hi Akhil, Konstantin,
> > >
> > > Wouldn't the new element, userdata, conflict with the one referred by
> > >
> > > rte_cryptodev_sym_session_set_user_data()
> > > rte_cryptodev_sym_session_get_user_data()
> > >
> > > Do you mind a name change for either? Or do you have a clear picture of when
> > one should be used over the other?
> > 
> > Yes, Fiona also pointed to that naming collision.
> > Current suggestion is to name this new element 'opaque_data' or so.
> > Konstantin
> > 
> > >
> > > Thanks,
> > > Anoob
> > >
> > > From: Akhil Goyal <akhil.goyal@nxp.com>
> > > > On 10/11/2018 7:50 PM, Konstantin Ananyev wrote:
> > > > > Below are details and reasoning for proposed changes.
> > > > >
> > > > > 1.rte_cryptodev_sym_session_init()/ rte_cryptodev_sym_session_clear()
> > > > >    operate based on cytpodev device id, though inside
> > > > >    rte_cryptodev_sym_session device specific data is addressed
> > > > >    by driver id (not device id).
> > > > >    That creates a problem with current implementation when we have
> > > > >    two or more devices with the same driver used by the same session.
> > > > >    Consider the following example:
> > > > >
> > > > >    struct rte_cryptodev_sym_session *sess;
> > > > >    rte_cryptodev_sym_session_init(dev_id=X, sess, ...);
> > > > >    rte_cryptodev_sym_session_init(dev_id=Y, sess, ...);
> > > > >    rte_cryptodev_sym_session_clear(dev_id=X, sess);
> > > > >
> > > > >    After that point if X and Y uses the same driver,
> > > > >    then sess can't be used by device Y any more.
> > > > >    The reason for that - driver specific (not device specific)
> > > > >    data per session, plus there is no information
> > > > >    how many device instances use that data.
> > > > >    Probably the simplest way to deal with that issue -
> > > > >    add a reference counter per each driver data.
> > > > >
> > > > > 2.rte_cryptodev_sym_session_set_user_data() and
> > > > >    rte_cryptodev_sym_session_get_user_data() -
> > > > >    with current implementation there is no defined way for the user to
> > > > >    determine what is the max allowed size of the private data.
> > > > >    rte_cryptodev_sym_session_set_user_data() just blindly copies
> > > > >    user provided data without checking memory boundaries violation.
> > > > >    To overcome that issue propose to add 'uint16_t priv_size' into
> > > > >    rte_cryptodev_sym_session structure.
> > > > >
> > > > > 3.rte_cryptodev_sym_session contains an array of variable size for
> > > > >    driver specific data.
> > > > >    Though number of elements in that array is determined by static
> > > > >    variable nb_drivers, that could be modified by
> > > > >    rte_cryptodev_allocate_driver().
> > > > >    That construction seems to work ok so far, as right now users register
> > > > >    all their PMDs at startup, though it doesn't mean that it would always
> > > > >    remain like that.
> > > > >    To make it less error prone propose to add 'uint16_t nb_drivers'
> > > > >    into the rte_cryptodev_sym_session structure.
> > > > >    At least that allows related functions to check that provided
> > > > >    driver id wouldn't overrun variable array boundaries,
> > > > >    again it allows to determine size of already allocated session
> > > > >    without accessing global variable.
> > > > >
> > > > > 4.#2 and #3 above implies that now each struct
> > rte_cryptodev_sym_session
> > > > >    would have sort of readonly type data (init once at allocation time,
> > > > >    keep unmodified through session life-time).
> > > > >    That requires more changes in current cryptodev implementation:
> > > > >    Right now inside cryptodev framework both rte_cryptodev_sym_session
> > > > >    and driver specific session data are two completely different sctrucures
> > > > >    (e.g. struct cryptodev_sym_session and struct null_crypto_session).
> > > > >    Though current cryptodev implementation implicitly assumes that driver
> > > > >    will allocate both of them from within the same mempool.
> > > > >    Plus this is done in a manner that they override each other fields
> > > > >    (reuse the same space - sort of implicit C union).
> > > > >    That's probably not the best programming practice,
> > > > >    plus make impossible to have readonly fields inside both of them.
> > > > >    To overcome that situation propose to changed an API a bit, to allow
> > > > >    to use two different mempools for these two distinct data structures.
> > > > >
> > > > >   5. Add 'uint64_t userdata' inside struct rte_cryptodev_sym_session.
> > > > >     I suppose that self-explanatory, and might be used in a lot of places
> > > > >     (would be quite useful for ipsec library we develop).
> > > > >
> > > > > The new proposed layout for rte_cryptodev_sym_session:
> > > > > struct rte_cryptodev_sym_session {
> > > > >          uint64_t userdata;
> > > > >          /**< Can be used for external metadata */
> > > > >          uint16_t nb_drivers;
> > > > >          /**< number of elements in sess_data array */
> > > > >          uint16_t priv_size;
> > > > >          /**< session private data will be placed after sess_data */
> > > > >          __extension__ struct {
> > > > >                  void *data;
> > > > >                  uint16_t refcnt;
> > > > >          } sess_data[0];
> > > > >          /**< Driver specific session material, variable size */
> > > > > };
> > > > >
> > > > > Signed-off-by: Konstantin Ananyev <konstantin.ananyev@intel.com>
> > > >
> > > > Adding maintainers to ack this deprecation notice. These changes
> > > > will impact all the PMDs and everyone should agree to these changes.
> > > >
> > > > from NXP dpaa_sec, dpaa2_sec, caam_jr PMDs:
> > > >
> > > > Acked-by: Akhil Goyal <akhil.goyal@nxp.com>
> 
> With the naming changes,
> Acked-by: Anoob Joseph <anoob.joseph@caviumnetworks.com>

Applied

      reply	other threads:[~2018-11-24 18:08 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-11 14:20 Konstantin Ananyev
2018-11-02 17:01 ` Zhang, Roy Fan
2018-11-12 12:03 ` Akhil Goyal
2018-11-14  0:50   ` Trahe, Fiona
2018-11-14  3:15   ` Joseph, Anoob
2018-11-14 10:08     ` Ananyev, Konstantin
2018-11-14 10:12       ` Joseph, Anoob
2018-11-24 18:07         ` Thomas Monjalon [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6921091.9xEsaLRtPN@xps \
    --to=thomas@monjalon.net \
    --cc=Ankur.Dwivedi@cavium.com \
    --cc=Anoob.Joseph@cavium.com \
    --cc=Jerin.JacobKollanukkaran@cavium.com \
    --cc=NarayanaPrasad.Athreya@cavium.com \
    --cc=Shally.Verma@cavium.com \
    --cc=akhil.goyal@nxp.com \
    --cc=declan.doherty@intel.com \
    --cc=dev@dpdk.org \
    --cc=dima@marvell.com \
    --cc=fiona.trahe@intel.com \
    --cc=jianjay.zhou@huawei.com \
    --cc=konstantin.ananyev@intel.com \
    --cc=nsamsono@marvell.com \
    --cc=ravi1.kumar@amd.com \
    --cc=tdu@semihalf.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).