From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mga03.intel.com (mga03.intel.com [134.134.136.65]) by dpdk.org (Postfix) with ESMTP id 432561B03D for ; Mon, 21 May 2018 14:14:55 +0200 (CEST) X-Amp-Result: SKIPPED(no attachment in message) X-Amp-File-Uploaded: False Received: from orsmga002.jf.intel.com ([10.7.209.21]) by orsmga103.jf.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 21 May 2018 05:14:54 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.49,426,1520924400"; d="scan'208";a="60352403" Received: from irsmsx153.ger.corp.intel.com ([163.33.192.75]) by orsmga002.jf.intel.com with ESMTP; 21 May 2018 05:14:52 -0700 Received: from irsmsx111.ger.corp.intel.com (10.108.20.4) by IRSMSX153.ger.corp.intel.com (163.33.192.75) with Microsoft SMTP Server (TLS) id 14.3.319.2; Mon, 21 May 2018 13:14:52 +0100 Received: from irsmsx108.ger.corp.intel.com ([169.254.11.150]) by irsmsx111.ger.corp.intel.com ([169.254.2.47]) with mapi id 14.03.0319.002; Mon, 21 May 2018 13:14:52 +0100 From: "De Lara Guarch, Pablo" To: "Verma, Shally" , "Doherty, Declan" , "akhil.goyal@nxp.com" CC: "dev@dpdk.org" Thread-Topic: [PATCH v4 6/6] cryptodev: rename get session size API Thread-Index: AQHT8PPXZRSJvsepvku0T/hJ6qU/zaQ6BTwAgAATYWA= Date: Mon, 21 May 2018 12:14:50 +0000 Message-ID: References: <20180126090355.25903-1-pablo.de.lara.guarch@intel.com> <20180521110656.42437-1-pablo.de.lara.guarch@intel.com> <20180521110656.42437-7-pablo.de.lara.guarch@intel.com> In-Reply-To: Accept-Language: en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-titus-metadata-40: eyJDYXRlZ29yeUxhYmVscyI6IiIsIk1ldGFkYXRhIjp7Im5zIjoiaHR0cDpcL1wvd3d3LnRpdHVzLmNvbVwvbnNcL0ludGVsMyIsImlkIjoiYTBiNGI4MzYtNjBiNS00YzVlLWExODQtOTg2ZjdmMDE1MDVhIiwicHJvcHMiOlt7Im4iOiJDVFBDbGFzc2lmaWNhdGlvbiIsInZhbHMiOlt7InZhbHVlIjoiQ1RQX05UIn1dfV19LCJTdWJqZWN0TGFiZWxzIjpbXSwiVE1DVmVyc2lvbiI6IjE3LjEwLjE4MDQuNDkiLCJUcnVzdGVkTGFiZWxIYXNoIjoiVEZ1Z29VSmh2Q1wvSm9RSFp2NHZZVklqbVRhZEM2RzdpUkpvWUFrU1wvdDZ1ejRxSHZTQ2lcL1lQRDRjaWVqMElmVyJ9 x-ctpclassification: CTP_NT dlp-product: dlpe-windows dlp-version: 11.0.200.100 dlp-reaction: no-action x-originating-ip: [163.33.239.181] Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable MIME-Version: 1.0 Subject: Re: [dpdk-dev] [PATCH v4 6/6] cryptodev: rename get session size API X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Mon, 21 May 2018 12:14:55 -0000 > -----Original Message----- > From: Verma, Shally [mailto:Shally.Verma@cavium.com] > Sent: Monday, May 21, 2018 1:05 PM > To: De Lara Guarch, Pablo ; Doherty, Decl= an > ; akhil.goyal@nxp.com > Cc: dev@dpdk.org > Subject: RE: [PATCH v4 6/6] cryptodev: rename get session size API >=20 >=20 >=20 > >-----Original Message----- > >From: Pablo de Lara [mailto:pablo.de.lara.guarch@intel.com] > >Sent: 21 May 2018 16:37 > >To: declan.doherty@intel.com; akhil.goyal@nxp.com; Verma, Shally > > > >Cc: dev@dpdk.org; Pablo de Lara > >Subject: [PATCH v4 6/6] cryptodev: rename get session size API > > > >rte_cryptodev_get_header_session_size() and > >rte_cryptodev_get_private_session_size() functions are targetting > >symmetric sessions. > > > >With the future addition of asymmetric operations, these functions need > >to be renamed from *_session_* to *_sym_session_* to be symmetric > >specific. > > > >Signed-off-by: Pablo de Lara > >--- > //snip >=20 > >diff --git a/lib/librte_cryptodev/rte_cryptodev.h > >b/lib/librte_cryptodev/rte_cryptodev.h > >index db367a1f8..e02b474d7 100644 > >--- a/lib/librte_cryptodev/rte_cryptodev.h > >+++ b/lib/librte_cryptodev/rte_cryptodev.h > >@@ -969,15 +969,18 @@ rte_cryptodev_sym_session_clear(uint8_t dev_id, > > struct rte_cryptodev_sym_session *sess); > > > > /** > >+ * deprecated > > * Get the size of the header session, for all registered drivers. > > * > > * @return > > * Size of the header session. > > */ > >+__rte_deprecated > > unsigned int > > rte_cryptodev_get_header_session_size(void); > > > > /** > >+ * @deprecated > > * Get the size of the private session data for a device. > > * > > * @param dev_id The device identifier. > >@@ -986,9 +989,33 @@ rte_cryptodev_get_header_session_size(void); > > * - Size of the private data, if successful > > * - 0 if device is invalid or does not have private session > > */ > >+__rte_deprecated > > unsigned int > > rte_cryptodev_get_private_session_size(uint8_t dev_id); > > > >+/** > >+ * Get the size of the header session, for all registered drivers. > >+ * > >+ * @return > >+ * Size of the symmetric eader session. > >+ */ > >+unsigned int > >+rte_cryptodev_get_header_sym_session_size(void); > >+ > [Shally] To keep consistency in naming convention, we can rename API to > rte_cryptodev_sym_get_header_session_size and > rte_cryptodev_sym_get_private_session_size Agree. Will send a v7 with the change. Thanks! Pablo >=20 > Thanks > Shally