DPDK usage discussions
 help / color / mirror / Atom feed
* [dpdk-users] I40e - vlan packets are dropped when not setting MTU
@ 2021-01-24  8:43 Bar Zamir
  0 siblings, 0 replies; only message in thread
From: Bar Zamir @ 2021-01-24  8:43 UTC (permalink / raw)
  To: users

Hey all,

I’m having trouble receiving vlan packets with IP length bigger than 1496 Bytes on i40e driver.

I have seen this thread https://mails.dpdk.org/archives/dev/2019-October/146908.html and indeed, after calling rte_eth_dev_set_mtu with mtu=1500, it works. I don’t understand why I have to use jumbo frames for that. I have tried it with different drivers (ixgbe) and no action beside rte_eth_dev_configure is required.

Using DPDK 16.11.1, but also reproduced on 17.11.3



thanks




^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2021-01-26  9:07 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-24  8:43 [dpdk-users] I40e - vlan packets are dropped when not setting MTU Bar Zamir

DPDK usage discussions

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://inbox.dpdk.org/users/0 users/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 users users/ https://inbox.dpdk.org/users \
		users@dpdk.org
	public-inbox-index users

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.users


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git