DPDK usage discussions
 help / color / mirror / Atom feed
* [dpdk-users] EAL: failed to parse device "XX:XX.X" on CentOS 7
@ 2021-08-12 22:32 Thao Hull
  2021-08-16 10:48 ` Mikulicz, Szymon (Nokia - PL/Krakow)
  0 siblings, 1 reply; 4+ messages in thread
From: Thao Hull @ 2021-08-12 22:32 UTC (permalink / raw)
  To: dev, szymon.mikulicz, users

Hi.

This looks similar to the problem I am having.
https://lore.kernel.org/dpdk-dev/bug-689-3@http.bugs.dpdk.org%2F/T/

I can't figure out how this issue was resolved on Centos7 per the thread.
Can someone please explain how to get past this failure error?  Just like
this user, testpmd works fine for me.  My device is in slot b3:00.0.   I am
using arkville on a bittware FPGA card.  My error is slightly different as
shown below:

EAL: Detected 24 lcore(s)
EAL: Detected 2 NUMA nodes
EAL: Detected static linkage of DPDK
EAL: failed to parse device "b3:00.0"
EAL: Unable to parse device 'b3:00.0, Pkt_dir=0xF0000, Pkt_gen=./pg.conf'

EAL: Error - exiting with EAL initialization

I'm using dpdk version 21.08.0

Any thoughts on how to debug, if not fix this?  I am new to dpdk.

Thank you!
Thao

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [dpdk-users] EAL: failed to parse device "XX:XX.X" on CentOS 7
  2021-08-12 22:32 [dpdk-users] EAL: failed to parse device "XX:XX.X" on CentOS 7 Thao Hull
@ 2021-08-16 10:48 ` Mikulicz, Szymon (Nokia - PL/Krakow)
  2021-08-16 13:13   ` Thao Hull
  0 siblings, 1 reply; 4+ messages in thread
From: Mikulicz, Szymon (Nokia - PL/Krakow) @ 2021-08-16 10:48 UTC (permalink / raw)
  To: Thao Hull, dev, users

Hi Thao,

the original issue was resolved by updating pkg-config. I compiled a new version of it on our centos 7 setup. We are currently using pkg-config 0.29.2 and it works.

BR,
SM

On 8/13/21 12:32 AM, Thao Hull wrote:
Hi.

This looks similar to the problem I am having.
https://lore.kernel.org/dpdk-dev/bug-689-3@http.bugs.dpdk.org%2F/T/

I can't figure out how this issue was resolved on Centos7 per the thread.  Can someone please explain how to get past this failure error?  Just like this user, testpmd works fine for me.  My device is in slot b3:00.0.   I am using arkville on a bittware FPGA card.  My error is slightly different as shown below:


EAL: Detected 24 lcore(s)
EAL: Detected 2 NUMA nodes
EAL: Detected static linkage of DPDK
EAL: failed to parse device "b3:00.0"
EAL: Unable to parse device 'b3:00.0, Pkt_dir=0xF0000, Pkt_gen=./pg.conf'

EAL: Error - exiting with EAL initialization

I'm using dpdk version 21.08.0

Any thoughts on how to debug, if not fix this?  I am new to dpdk.

Thank you!
Thao

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [dpdk-users] EAL: failed to parse device "XX:XX.X" on CentOS 7
  2021-08-16 10:48 ` Mikulicz, Szymon (Nokia - PL/Krakow)
@ 2021-08-16 13:13   ` Thao Hull
  2021-08-17 14:47     ` [dpdk-users] [dpdk-dev] " Bruce Richardson
  0 siblings, 1 reply; 4+ messages in thread
From: Thao Hull @ 2021-08-16 13:13 UTC (permalink / raw)
  To: Mikulicz, Szymon (Nokia - PL/Krakow); +Cc: dev, users

Thank you!  Will try that when I get back from vacation.  Thao

On Mon, Aug 16, 2021, 4:48 AM Mikulicz, Szymon (Nokia - PL/Krakow) <
szymon.mikulicz@nokia.com> wrote:

> Hi Thao,
>
> the original issue was resolved by updating pkg-config. I compiled a new
> version of it on our centos 7 setup. We are currently using pkg-config 0.29.2
> and it works.
>
> BR,
> SM
>
> On 8/13/21 12:32 AM, Thao Hull wrote:
>
> Hi.
>
> This looks similar to the problem I am having.
> https://lore.kernel.org/dpdk-dev/bug-689-3@http.bugs.dpdk.org%2F/T/
>
> I can't figure out how this issue was resolved on Centos7 per the thread.
> Can someone please explain how to get past this failure error?  Just like
> this user, testpmd works fine for me.  My device is in slot b3:00.0.   I am
> using arkville on a bittware FPGA card.  My error is slightly different as
> shown below:
>
> EAL: Detected 24 lcore(s)
> EAL: Detected 2 NUMA nodes
> EAL: Detected static linkage of DPDK
> EAL: failed to parse device "b3:00.0"
> EAL: Unable to parse device 'b3:00.0, Pkt_dir=0xF0000, Pkt_gen=./pg.conf'
>
> EAL: Error - exiting with EAL initialization
>
> I'm using dpdk version 21.08.0
>
> Any thoughts on how to debug, if not fix this?  I am new to dpdk.
>
> Thank you!
> Thao
>
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [dpdk-users] [dpdk-dev] EAL: failed to parse device "XX:XX.X" on CentOS 7
  2021-08-16 13:13   ` Thao Hull
@ 2021-08-17 14:47     ` Bruce Richardson
  0 siblings, 0 replies; 4+ messages in thread
From: Bruce Richardson @ 2021-08-17 14:47 UTC (permalink / raw)
  To: Thao Hull; +Cc: Mikulicz, Szymon (Nokia - PL/Krakow), dev, users

On Mon, Aug 16, 2021 at 07:13:54AM -0600, Thao Hull wrote:
> Thank you!  Will try that when I get back from vacation.  Thao
> 
> On Mon, Aug 16, 2021, 4:48 AM Mikulicz, Szymon (Nokia - PL/Krakow) <
> szymon.mikulicz@nokia.com> wrote:
> 
> > Hi Thao,
> >
> > the original issue was resolved by updating pkg-config. I compiled a new
> > version of it on our centos 7 setup. We are currently using pkg-config 0.29.2
> > and it works.
> >
> > BR,
> > SM
> >

The likely cause of the inability to parse the address is the PCI driver
not being linked into the binary for a static build. This could indeed be
caused by incorrect output from pkg-config, and the default pkg-config on
centos 7 is known to have such an issue. Updating pkg-config, or use
pkgconf instead, is recommended to fix this, as suggested above.

/Bruce

> > On 8/13/21 12:32 AM, Thao Hull wrote:
> >
> > Hi.
> >
> > This looks similar to the problem I am having.
> > https://lore.kernel.org/dpdk-dev/bug-689-3@http.bugs.dpdk.org%2F/T/
> >
> > I can't figure out how this issue was resolved on Centos7 per the thread.
> > Can someone please explain how to get past this failure error?  Just like
> > this user, testpmd works fine for me.  My device is in slot b3:00.0.   I am
> > using arkville on a bittware FPGA card.  My error is slightly different as
> > shown below:
> >
> > EAL: Detected 24 lcore(s)
> > EAL: Detected 2 NUMA nodes
> > EAL: Detected static linkage of DPDK
> > EAL: failed to parse device "b3:00.0"
> > EAL: Unable to parse device 'b3:00.0, Pkt_dir=0xF0000, Pkt_gen=./pg.conf'
> >
> > EAL: Error - exiting with EAL initialization
> >
> > I'm using dpdk version 21.08.0
> >
> > Any thoughts on how to debug, if not fix this?  I am new to dpdk.
> >
> > Thank you!
> > Thao
> >
> >

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-09-03  6:36 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-12 22:32 [dpdk-users] EAL: failed to parse device "XX:XX.X" on CentOS 7 Thao Hull
2021-08-16 10:48 ` Mikulicz, Szymon (Nokia - PL/Krakow)
2021-08-16 13:13   ` Thao Hull
2021-08-17 14:47     ` [dpdk-users] [dpdk-dev] " Bruce Richardson

DPDK usage discussions

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://inbox.dpdk.org/users/0 users/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 users users/ http://inbox.dpdk.org/users \
		users@dpdk.org
	public-inbox-index users

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.users


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git