DPDK usage discussions
 help / color / Atom feed
* [dpdk-users] API version mismatch error for intel XL710 Sriov when running multiple Pktgen DPDK in parallel for same PF.
@ 2020-05-19  4:44 Anand Gupta
  0 siblings, 0 replies; only message in thread
From: Anand Gupta @ 2020-05-19  4:44 UTC (permalink / raw)
  To: users

Hello All,

We are trying run Pktgen DPDK using intel XL710 in Sriov mode but facing an error.

Setup:
Openstack . Host A and B contain Intel XL 710 card in back to back mode.
NIC: Intel XL710

Driver info for PCI cards in Host:
ethtool -i ens1f0
driver: i40e
version: 1.4.25
firmware-version: 6.01 0x800036ea 1.1861.0
expansion-rom-version:
bus-info: 0000:81:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes

Sriov driver in VM:
              driver: iavf
version: 3.7.61.20
firmware-version: N/A
expansion-rom-version:
bus-info: 0000:00:04.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no

DPDK Version: 18.11.1
Pktgen Version: 3.7.1

Test scenario:


  1.  We are deploying multiple VMs in host A and B and doing Sriov passthrough.
  2.  Each VM contain a Sriov port from the same PF.
  3.  From both end Pktgen DPDK is running inside the VMs in parallel.
  4.  VMs in Host A are the sender and in Host B are receiver and are paired one to one i.e, VM0 in host A will send packets to VM0 in Host B and so on.

Problem:

  1.  When we are running Pktgen DPDK in multiple VMs in parallel for say if we deploy 5 instances each in Host A and Host B then in some of the instances we are getting error:
i40evf_check_api_version(): PF/VF API version mismatch:(0.0)-(1.1)
i40evf_init_vf(): check_api version failed
EAL: Requested device 0000:00:04.0 cannot be used

  1.  From the kernel log in the host machine we get the following error of the faulty VMs:
0000:81:00.0: Invalid message from VF 3, opcode 28, len 0

i40e 0000:81:00.0: Invalid message from VF 4, opcode 28, len 0

i40e 0000:81:00.0: VF 4 failed opcode 14, error: -5

i40e 0000:81:00.0: VF 3 failed opcode 14, error: -5


The Above problem does not repeat if we are running only one DPDK pktgen i.e deploying only 1 VM in host A and host B.

Could someone pls help me please regarding the issue.

Thanks,
Anand


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-19  4:44 [dpdk-users] API version mismatch error for intel XL710 Sriov when running multiple Pktgen DPDK in parallel for same PF Anand Gupta

DPDK usage discussions

Archives are clonable:
	git clone --mirror http://inbox.dpdk.org/users/0 users/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 users users/ http://inbox.dpdk.org/users \
		users@dpdk.org
	public-inbox-index users


Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.users


AGPL code for this site: git clone https://public-inbox.org/ public-inbox