DPDK patches and discussions
 help / color / mirror / Atom feed
From: Ori Kam <orika@nvidia.com>
To: Suanming Mou <suanmingm@nvidia.com>,
	Ferruh Yigit <ferruh.yigit@amd.com>,
	 Aman Singh <aman.deep.singh@intel.com>,
	Yuying Zhang <yuying.zhang@intel.com>,
	"NBU-Contact-Thomas Monjalon (EXTERNAL)" <thomas@monjalon.net>,
	Andrew Rybchenko <andrew.rybchenko@oktetlabs.ru>
Cc: "dev@dpdk.org" <dev@dpdk.org>
Subject: RE: [PATCH v3 2/3] ethdev: add compare item
Date: Wed, 31 Jan 2024 15:56:19 +0000	[thread overview]
Message-ID: <MW2PR12MB4666946F55EB2C3A35DF23EAD67C2@MW2PR12MB4666.namprd12.prod.outlook.com> (raw)
In-Reply-To: <CO6PR12MB5396652563572C147D0BAF4AC17C2@CO6PR12MB5396.namprd12.prod.outlook.com>

Hi

> -----Original Message-----
> From: Suanming Mou <suanmingm@nvidia.com>
> Sent: Wednesday, January 31, 2024 4:48 AM
> 
> Hi,
> 
> > -----Original Message-----
> > From: Ferruh Yigit <ferruh.yigit@amd.com>
> > Sent: Wednesday, January 31, 2024 1:34 AM
> > To: Suanming Mou <suanmingm@nvidia.com>; Ori Kam
> <orika@nvidia.com>;
> > Aman Singh <aman.deep.singh@intel.com>; Yuying Zhang
> > <yuying.zhang@intel.com>; NBU-Contact-Thomas Monjalon (EXTERNAL)
> > <thomas@monjalon.net>; Andrew Rybchenko
> > <andrew.rybchenko@oktetlabs.ru>
> > Cc: dev@dpdk.org
> > Subject: Re: [PATCH v3 2/3] ethdev: add compare item
> >
> > On 1/15/2024 9:13 AM, Suanming Mou wrote:
> > > The new item type is added for the case user wants to match traffic
> > > based on packet field compare result with other fields or immediate
> > > value.
> > >
> > > e.g. take advantage the compare item user will be able to accumulate a
> > > IPv4/TCP packet's TCP data_offset and IPv4 IHL field to a tag
> > > register, then compare the tag register with IPv4 header total length
> > > to understand the packet has payload or not.
> > >
> >
> > ack, above sample makes it easier to understand.
> >
> > This patch is adding testpmd commands, can you please provide some
> sample
> > commands in commit log?
> > The more samples are better, as far as I remember there was a testpmd
> > documentation that documents the sample usages, can you please check
> for it?

[Snip ..]

> >
> > > +/**
> > > + * @warning
> > > + * @b EXPERIMENTAL: this structure may change without prior notice
> > > + *
> > > + * Field description for packet field.
> > > + */
> > > +struct rte_flow_field_data {
> > > +	enum rte_flow_field_id field; /**< Field or memory type ID. */
> > > +	union {
> > > +		struct {
> > > +			/** Encapsulation level and tag index or flex item
> > handle. */
> > > +			union {
> > > +				struct {
> > > +					/**
> > > +					 * Packet encapsulation level
> containing
> > > +					 * the field to modify.
> > > +					 *
> > > +					 * - @p 0 requests the default
> behavior.
> > > +					 *   Depending on the packet type, it
> > > +					 *   can mean outermost, innermost
> or
> > > +					 *   anything in between.
> > > +					 *
> > > +					 *   It basically stands for the
> > > +					 *   innermost encapsulation level.
> > > +					 *   Modification can be performed
> > > +					 *   according to PMD and device
> > > +					 *   capabilities.
> > > +					 *
> > > +					 * - @p 1 requests modification to be
> > > +					 *   performed on the outermost
> packet
> > > +					 *   encapsulation level.
> > > +					 *
> > > +					 * - @p 2 and subsequent values
> > request
> > > +					 *   modification to be performed on
> > > +					 *   the specified inner packet
> > > +					 *   encapsulation level, from
> > > +					 *   outermost to innermost (lower to
> > > +					 *   higher values).
> > > +					 *
> > > +					 * Values other than @p 0 are not
> > > +					 * necessarily supported.
> > > +					 *
> > > +					 * @note that for MPLS field,
> > > +					 * encapsulation level also include
> > > +					 * tunnel since MPLS may appear in
> > > +					 * outer, inner or tunnel.
> > > +					 */
> > > +					uint8_t level;
> > > +					union {
> > > +						/**
> > > +						 * Tag index array inside
> > > +						 * encapsulation level.
> > > +						 * Used for VLAN, MPLS or
> TAG
> > types.
> > > +						 */
> > > +						uint8_t tag_index;
> > > +						/**
> > > +						 * Geneve option identifier.
> > > +						 * Relevant only for
> > > +						 *
> > RTE_FLOW_FIELD_GENEVE_OPT_XXXX
> > > +						 * modification type.
> > > +						 */
> > > +						struct {
> > > +							/**
> > > +							 * Geneve option
> type.
> > > +							 */
> > > +							uint8_t type;
> > > +							/**
> > > +							 * Geneve option
> class.
> > > +							 */
> > > +							rte_be16_t class_id;
> > > +						};
> > > +					};
> > > +				};
> > > +				struct rte_flow_item_flex_handle
> *flex_handle;
> > > +			};
> > > +			/** Number of bits to skip from a field. */
> > > +			uint32_t offset;
> > > +		};
> > > +		/**
> > > +		 * Immediate value for RTE_FLOW_FIELD_VALUE, presented
> in
> > the
> > > +		 * same byte order and length as in relevant
> rte_flow_item_xxx.
> > > +		 * The immediate source bitfield offset is inherited from
> > > +		 * the destination's one.
> > > +		 */
> > > +		uint8_t value[16];
> > > +		/**
> > > +		 * Memory address for RTE_FLOW_FIELD_POINTER, memory
> > layout
> > > +		 * should be the same as for relevant field in the
> > > +		 * rte_flow_item_xxx structure.
> > > +		 */
> > > +		void *pvalue;
> > > +	};
> > > +};
> > > +
> > >
> >
> > I am aware that you are just moving the above struct, but it is nested too
> much
> > which is making it hard to read.
> >
> > As you are touching it, can we extract some structs and make this struct less
> > nested, what do you think?
> > Of course it needs to be done in separate patch, as a preperation/clean-up
> patch
> > before moving it around.
> 
> Agree the struct maybe a bit nested. But not sure how it was discussed
> before during the last new member was added... @Ori, Do you have any idea
> about this?
> 

As far as I remember, it was never discussed, 

I think for this series we should keep it as is, and revise it later.

Best,
Ori
> And if it is really expected, I believe another new thread is worth for that
> change,  better not be in that series.
> Need to discuss the new struct name and other stuff. What do you think?
> 
> >
> > <...>
> >
> > > +/**
> > > + *
> > > + * RTE_FLOW_ITEM_TYPE_COMPARE
> > > + *
> > > + * Matches the packet with compare result.
> > > + *
> > > + * The operation means a compare with b result.
> > > + */
> > > +struct rte_flow_item_compare {
> > > +	enum rte_flow_item_compare_op operation; /* The compare
> operation.
> > */
> > > +	struct rte_flow_field_data a;		 /* Field be compared.  */
> > > +	struct rte_flow_field_data b;		 /* Field as comparator. */
> > >
> >
> > Variable names 'a' and 'b' are not descriptive although it may be OK since
> there is
> > no significance to the values, but other option can be 'first' and 'second',
> but
> > overall not strong opinion.
> 
> Yes, thanks for the suggestion, in fact we also discussed about the name a lot,
> finally we choose the widely used 'a' and 'b'
> 
> Thanks


  reply	other threads:[~2024-01-31 15:56 UTC|newest]

Thread overview: 66+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-14  3:12 [PATCH 0/2] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Suanming Mou
2023-12-14  3:12 ` [PATCH 1/2] " Suanming Mou
2023-12-14  3:12 ` [PATCH 2/2] net/mlx5: add compare item support Suanming Mou
2023-12-19  1:33 ` [PATCH v2 0/3] [PATCH 0/2] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Suanming Mou
2023-12-19  1:33   ` [PATCH v2 1/3] ethdev: rename action modify field data structure Suanming Mou
2024-01-09 14:07     ` Ori Kam
2024-01-12  8:03       ` Andrew Rybchenko
2023-12-19  1:33   ` [PATCH v2 2/3] ethdev: add compare item Suanming Mou
2024-01-09 14:26     ` Ori Kam
2024-01-12  8:11     ` Andrew Rybchenko
2024-01-15  8:14       ` Suanming Mou
2023-12-19  1:33   ` [PATCH v2 3/3] net/mlx5: add compare item support Suanming Mou
2024-01-09 14:28     ` Ori Kam
2024-01-15  9:13   ` [PATCH v3 0/3] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Suanming Mou
2024-01-15  9:13     ` [PATCH v3 1/3] ethdev: rename action modify field data structure Suanming Mou
2024-01-30 17:19       ` Ferruh Yigit
2024-01-31  2:57         ` Suanming Mou
2024-02-01 10:56           ` Ferruh Yigit
2024-02-01 11:09             ` Suanming Mou
2024-02-01 11:20               ` Ferruh Yigit
2024-02-01 11:39                 ` Suanming Mou
2024-01-15  9:13     ` [PATCH v3 2/3] ethdev: add compare item Suanming Mou
2024-01-30 17:33       ` Ferruh Yigit
2024-01-31  2:47         ` Suanming Mou
2024-01-31 15:56           ` Ori Kam [this message]
2024-01-31 16:46             ` Ferruh Yigit
2024-01-31 17:43               ` Ori Kam
2024-01-31 17:54                 ` Ferruh Yigit
2024-02-01  6:51                   ` Ori Kam
2024-02-01  0:31               ` Suanming Mou
2024-01-15  9:13     ` [PATCH v3 3/3] net/mlx5: add compare item support Suanming Mou
2024-02-01  2:30 ` [PATCH v4 0/3] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Suanming Mou
2024-02-01  2:30   ` [PATCH v4 1/3] ethdev: rename action modify field data structure Suanming Mou
2024-02-01  2:30   ` [PATCH v4 2/3] ethdev: add compare item Suanming Mou
2024-02-01  2:30   ` [PATCH v4 3/3] net/mlx5: add compare item support Suanming Mou
2024-02-01 12:29 ` [PATCH v5 0/3] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Suanming Mou
2024-02-01 12:29   ` [PATCH v5 1/3] ethdev: rename action modify field data structure Suanming Mou
2024-02-01 18:57     ` Ferruh Yigit
2024-02-01 12:29   ` [PATCH v5 2/3] ethdev: add compare item Suanming Mou
2024-02-01 18:57     ` Ferruh Yigit
2024-02-01 12:29   ` [PATCH v5 3/3] net/mlx5: add compare item support Suanming Mou
2024-02-01 18:57     ` Ferruh Yigit
2024-02-01 18:56   ` [PATCH v5 0/3] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Ferruh Yigit
2024-02-02  0:32     ` Suanming Mou
2024-02-02  0:42 ` [PATCH v6 " Suanming Mou
2024-02-02  0:42   ` [PATCH v6 1/3] ethdev: rename action modify field data structure Suanming Mou
2024-02-05 11:23     ` Thomas Monjalon
2024-02-05 11:49       ` Suanming Mou
2024-02-05 12:39         ` Thomas Monjalon
2024-02-05 12:53           ` Suanming Mou
2024-02-02  0:42   ` [PATCH v6 2/3] ethdev: add compare item Suanming Mou
2024-02-05 13:00     ` Thomas Monjalon
2024-02-05 13:28       ` Suanming Mou
2024-02-05 14:09         ` Thomas Monjalon
2024-02-06  1:26           ` Suanming Mou
2024-02-02  0:42   ` [PATCH v6 3/3] net/mlx5: add compare item support Suanming Mou
2024-02-06  2:06 ` [PATCH v7 0/4] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Suanming Mou
2024-02-06  2:06   ` [PATCH v7 1/4] ethdev: rename action modify field data structure Suanming Mou
2024-02-06 21:23     ` Ferruh Yigit
2024-02-06  2:06   ` [PATCH v7 2/4] ethdev: move flow field data structures Suanming Mou
2024-02-06 21:23     ` Ferruh Yigit
2024-02-06  2:06   ` [PATCH v7 3/4] ethdev: add compare item Suanming Mou
2024-02-06 21:24     ` Ferruh Yigit
2024-02-06  2:06   ` [PATCH v7 4/4] net/mlx5: add compare item support Suanming Mou
2024-02-06 21:23     ` Ferruh Yigit
2024-02-06 21:24   ` [PATCH v7 0/4] ethdev: add RTE_FLOW_ITEM_TYPE_COMPARE Ferruh Yigit

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=MW2PR12MB4666946F55EB2C3A35DF23EAD67C2@MW2PR12MB4666.namprd12.prod.outlook.com \
    --to=orika@nvidia.com \
    --cc=aman.deep.singh@intel.com \
    --cc=andrew.rybchenko@oktetlabs.ru \
    --cc=dev@dpdk.org \
    --cc=ferruh.yigit@amd.com \
    --cc=suanmingm@nvidia.com \
    --cc=thomas@monjalon.net \
    --cc=yuying.zhang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).