DPDK patches and discussions
 help / color / mirror / Atom feed
* [dpdk-dev] CPU does not support x86-64 instruction set
@ 2014-06-23 12:42 Alex Markuze
  2014-06-23 14:42 ` Thomas Monjalon
  0 siblings, 1 reply; 5+ messages in thread
From: Alex Markuze @ 2014-06-23 12:42 UTC (permalink / raw)
  To: dev

Hi, I'm new to DPDK and Im trying to compile on a x86 Ubuntu 14.04 VM(KVM).
And I'm getting this error:

"error: CPU you selected does not support x86-64 instruction set"

I've seen in the Archive that Jinho had this same issue last year, I'd be
glad to know how it was resolved.

Thanks
Alex.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [dpdk-dev] CPU does not support x86-64 instruction set
  2014-06-23 12:42 [dpdk-dev] CPU does not support x86-64 instruction set Alex Markuze
@ 2014-06-23 14:42 ` Thomas Monjalon
       [not found]   ` <CAKfHP0XAfnXU1mC8b+=1d63rnj1J9GR-UM471HAyCQXkDEKDcg@mail.gmail.com>
  0 siblings, 1 reply; 5+ messages in thread
From: Thomas Monjalon @ 2014-06-23 14:42 UTC (permalink / raw)
  To: Alex Markuze; +Cc: dev

Hi,

2014-06-23 15:42, Alex Markuze:
> Hi, I'm new to DPDK and Im trying to compile on a x86 Ubuntu 14.04 VM(KVM).
> And I'm getting this error:
> 
> "error: CPU you selected does not support x86-64 instruction set"

You should try "-cpu host" option of Qemu/KVM in order to have the full 
instruction set of your host.

Please confirm it's working.
-- 
Thomas

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [dpdk-dev] Fwd:  CPU does not support x86-64 instruction set
       [not found]   ` <CAKfHP0XAfnXU1mC8b+=1d63rnj1J9GR-UM471HAyCQXkDEKDcg@mail.gmail.com>
@ 2014-06-24  8:12     ` Alex Markuze
  2014-06-24  8:21       ` Thomas Monjalon
  0 siblings, 1 reply; 5+ messages in thread
From: Alex Markuze @ 2014-06-24  8:12 UTC (permalink / raw)
  To: dev

Thomas Thanks for your reply,
I've resolved the issue in a similar way by modifying the VM xml config
file with this line
<cpu mode='host-passthrough’/>.

I was wondering if a Makefile/.config solution exists w/o modifying an
existing VM in cases where its not possible.
I've tried to modify the .config file with 'CONFIG_RTE_MACHINE="native" ->
CONFIG_RTE_MACHINE="x86-64"'
But it didn't seem to matter (I didn't explore this much farther, I
dint really try a clean build and didn't make sure that the .config file
I've modified was read).

Alex.



On Mon, Jun 23, 2014 at 5:42 PM, Thomas Monjalon <thomas.monjalon@6wind.com>
wrote:

> Hi,
>
> 2014-06-23 15:42, Alex Markuze:
> > Hi, I'm new to DPDK and Im trying to compile on a x86 Ubuntu 14.04
> VM(KVM).
> > And I'm getting this error:
> >
> > "error: CPU you selected does not support x86-64 instruction set"
>
> You should try "-cpu host" option of Qemu/KVM in order to have the full
> instruction set of your host.
>
> Please confirm it's working.
> --
> Thomas
>

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [dpdk-dev] Fwd:  CPU does not support x86-64 instruction set
  2014-06-24  8:12     ` [dpdk-dev] Fwd: " Alex Markuze
@ 2014-06-24  8:21       ` Thomas Monjalon
  2014-06-24  9:14         ` Alex Markuze
  0 siblings, 1 reply; 5+ messages in thread
From: Thomas Monjalon @ 2014-06-24  8:21 UTC (permalink / raw)
  To: Alex Markuze; +Cc: dev

Welcome Alex.
Please, for future messages, try to answer below as explained here:
	http://dpdk.org/ml

2014-06-24 11:12, Alex Markuze:
> Thomas Monjalon <thomas.monjalon@6wind.com> wrote:
> > 2014-06-23 15:42, Alex Markuze:
> > > Hi, I'm new to DPDK and Im trying to compile on a x86 Ubuntu 14.04
> > VM(KVM).
> > > And I'm getting this error:
> > >
> > > "error: CPU you selected does not support x86-64 instruction set"
> >
> > You should try "-cpu host" option of Qemu/KVM in order to have the full
> > instruction set of your host.
> 
> I've resolved the issue in a similar way by modifying the VM xml config
> file with this line
> <cpu mode='host-passthrough’/>.
> 
> I was wondering if a Makefile/.config solution exists w/o modifying an
> existing VM in cases where its not possible.
> I've tried to modify the .config file with 'CONFIG_RTE_MACHINE="native" ->
> CONFIG_RTE_MACHINE="x86-64"'
> But it didn't seem to matter (I didn't explore this much farther, I
> dint really try a clean build and didn't make sure that the .config file
> I've modified was read).

Not sure to understand what you want.
If you try to build DPDK for most of machines (including VM), you should set
	CONFIG_RTE_MACHINE="default"
in your .config file.

-- 
Thomas

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [dpdk-dev] Fwd: CPU does not support x86-64 instruction set
  2014-06-24  8:21       ` Thomas Monjalon
@ 2014-06-24  9:14         ` Alex Markuze
  0 siblings, 0 replies; 5+ messages in thread
From: Alex Markuze @ 2014-06-24  9:14 UTC (permalink / raw)
  To: Thomas Monjalon; +Cc: dev

On Tue, Jun 24, 2014 at 11:21 AM, Thomas Monjalon <thomas.monjalon@6wind.com
> wrote:

> Welcome Alex.
> Please, for future messages, try to answer below as explained here:
>         http://dpdk.org/ml
>
> 2014-06-24 11:12, Alex Markuze:
> > Thomas Monjalon <thomas.monjalon@6wind.com> wrote:
> > > 2014-06-23 15:42, Alex Markuze:
> > > > Hi, I'm new to DPDK and Im trying to compile on a x86 Ubuntu 14.04
> > > VM(KVM).
> > > > And I'm getting this error:
> > > >
> > > > "error: CPU you selected does not support x86-64 instruction set"
> > >
> > > You should try "-cpu host" option of Qemu/KVM in order to have the full
> > > instruction set of your host.
> >
> > I've resolved the issue in a similar way by modifying the VM xml config
> > file with this line
> > <cpu mode='host-passthrough’/>.
> >
> > I was wondering if a Makefile/.config solution exists w/o modifying an
> > existing VM in cases where its not possible.
> > I've tried to modify the .config file with 'CONFIG_RTE_MACHINE="native"
> ->
> > CONFIG_RTE_MACHINE="x86-64"'
> > But it didn't seem to matter (I didn't explore this much farther, I
> > dint really try a clean build and didn't make sure that the .config file
> > I've modified was read).
>
> Not sure to understand what you want.
> If you try to build DPDK for most of machines (including VM), you should
> set
>         CONFIG_RTE_MACHINE="default"
> in your .config file.
>
>    My wish is to be able to compile DPDK on a VM that has "model name :
QEMU Virtual CPU version 2.0.0"
   I'm guessing that the gcc doesn't understand the Arch so it throws this
error:
  "error: CPU you selected does not support x86-64 instruction set"

   I was looking for a way to tell the gcc not to worry about the QEMU cpu
and just compile x86_64 binary.

> --
> Thomas
>

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2014-06-24  9:14 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-06-23 12:42 [dpdk-dev] CPU does not support x86-64 instruction set Alex Markuze
2014-06-23 14:42 ` Thomas Monjalon
     [not found]   ` <CAKfHP0XAfnXU1mC8b+=1d63rnj1J9GR-UM471HAyCQXkDEKDcg@mail.gmail.com>
2014-06-24  8:12     ` [dpdk-dev] Fwd: " Alex Markuze
2014-06-24  8:21       ` Thomas Monjalon
2014-06-24  9:14         ` Alex Markuze

DPDK patches and discussions

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://inbox.dpdk.org/dev/0 dev/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 dev dev/ https://inbox.dpdk.org/dev \
		dev@dpdk.org
	public-inbox-index dev

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://inbox.dpdk.org/inbox.dpdk.dev


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git