Soft Patch Panel
 help / color / mirror / Atom feed
* [spp] [PATCH 00/17] Refactor command parser of SPP worker
@ 2019-05-08  2:01 ogawa.yasufumi
  2019-05-08  2:01 ` [spp] [PATCH 01/17] shared/sec: change prefix of common functions ogawa.yasufumi
                   ` (16 more replies)
  0 siblings, 17 replies; 18+ messages in thread
From: ogawa.yasufumi @ 2019-05-08  2:01 UTC (permalink / raw)
  To: spp, ferruh.yigit, ogawa.yasufumi

From: Yasufumi Ogawa <ogawa.yasufumi@lab.ntt.co.jp>

Hi,

The name of group of spp_vf siblings is changed to SPP worker for
removing ambiguity by which prefix of libs of SPP worker `spp_` is
renamed to `sppwk_`. For this update, each of common functions and vars
should also be renamed.

This series of patches is the first step of the update.

* Rename `command_dec.h` to `cmd_parser.h`.
* Update all of functions and vars in `cmd_parser.h` to apply with the
  above changes.

Regards,
Yasufumi

Yasufumi Ogawa (17):
  shared/sec: change prefix of common functions
  shared/sec: refactor parse error code
  shared/sec: revice cmd parser of SPP worker
  shared/sec: refactor branching for cmd action
  shared/sec: rename define starts from SPP_CMD_MAX
  shared/sec: rename define of buffer size for cmds
  shared/sec: remove unused define of cmd parser
  shared/sec: refactor commad type of SPP worker
  shared/sec: change struct of classier table attrs
  shared/sec: refactor function parsing cls port
  shared/sec: rename func of flush command
  shared/sec: change struct of comp command
  shared/sec: revise port info of SPP worker
  shared/sec: rename func for getting port ID
  shared/sec: rename dpdk_port attr
  shared/sec: rename struct for command request
  shared/sec: rename func for parsing request

 src/mirror/spp_mirror.c                       |  30 +--
 .../secondary/spp_worker_th/cmd_parser.h      | 157 ++++++++++++
 .../secondary/spp_worker_th/command_dec.c     | 233 +++++++++---------
 .../secondary/spp_worker_th/command_dec.h     | 201 ---------------
 .../secondary/spp_worker_th/command_proc.c    | 168 ++++++-------
 src/shared/secondary/spp_worker_th/spp_port.c |   6 +-
 src/shared/secondary/spp_worker_th/spp_proc.c |  80 +++---
 src/shared/secondary/spp_worker_th/spp_proc.h |  72 +++---
 src/vf/classifier_mac.c                       |  42 ++--
 src/vf/spp_forward.c                          |  26 +-
 src/vf/spp_vf.c                               |   2 +-
 11 files changed, 487 insertions(+), 530 deletions(-)
 create mode 100644 src/shared/secondary/spp_worker_th/cmd_parser.h
 delete mode 100644 src/shared/secondary/spp_worker_th/command_dec.h

-- 
2.17.1


^ permalink raw reply	[flat|nested] 18+ messages in thread

end of thread, other threads:[~2019-05-08  2:04 UTC | newest]

Thread overview: 18+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-05-08  2:01 [spp] [PATCH 00/17] Refactor command parser of SPP worker ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 01/17] shared/sec: change prefix of common functions ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 02/17] shared/sec: refactor parse error code ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 03/17] shared/sec: revice cmd parser of SPP worker ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 04/17] shared/sec: refactor branching for cmd action ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 05/17] shared/sec: rename define starts from SPP_CMD_MAX ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 06/17] shared/sec: rename define of buffer size for cmds ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 07/17] shared/sec: remove unused define of cmd parser ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 08/17] shared/sec: refactor commad type of SPP worker ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 09/17] shared/sec: change struct of classier table attrs ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 10/17] shared/sec: refactor function parsing cls port ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 11/17] shared/sec: rename func of flush command ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 12/17] shared/sec: change struct of comp command ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 13/17] shared/sec: revise port info of SPP worker ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 14/17] shared/sec: rename func for getting port ID ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 15/17] shared/sec: rename dpdk_port attr ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 16/17] shared/sec: rename struct for command request ogawa.yasufumi
2019-05-08  2:01 ` [spp] [PATCH 17/17] shared/sec: rename func for parsing request ogawa.yasufumi

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).